Help me with tplink Archer c60 configuration on OpenWrt with PPPoE


I'm having hard time configuring for my router with OpenWRT firmware on it. someone please guide me through the setup.

when I do the setup with tplink firmware, I choose PPPoE then none (out of Disable/Dynamic IP/Static IP) and put login and pass given by my ISP in IPv4 that’s it router detects everything else by itself. IPv6 is not used. I do not have any separate modem, wire directly comes from outside and directly goes into my router.

with OpenWRT firmware I'm having hard time getting it to work

please help me

@omkarpatil29, welcome to the community!

Can you is this related to OpenWrt?

I thought it's kind of obvious that I'm asking help on OpenWRT forum but
I've made the edits so that it's more clere that I need help for OpenWRT configuration with PPPoE on my C60 router.
and the image shows what very little user input needed for get it working on stock firmware.


Can you show the OpenWrt config you're having issue with?

I'm not sure how we can help from an OEM picture.

1 Like

actually i have no in depth knowledge of networking i know enough to play with stock firmware but when i saw OpenWRT settings it confused me. i fiddled with the settings but it's not connecting with the ISP network.

could you please :pray: help me to set up a PPPoE connection on OpenWRT.

Since you refuse to show us, I will:


What happens when you enter username and password like on TP-Link???

What happens when you enter username and password like on TP-Link???

nothing happens

i did tried simply selecting PPPoE and putting username password but there is no internet access. i thought there might be something else i have to configure.


Which ISP are you using? Are you sure that you do not need to use a specific VLAN tag to connect to you ISP?

1 Like

Thanks for the reply
I'm from mumbai,India and my ISP is 'machone broadband' devision of 'intech online'. In the the ISP name switches between them.

By VLAN tag do you mean service name?
Their technicians use service name as 'macone' (h is missing) apart from that they do not enter any additional details. And i occasionally reset my router. And i never put in that service name and it still works fine.

A question- after switching to openWRT dose the mac id changes?
Because my internet access is bound to my routers mac id if i change the router i had to request them to reset my mac id otherwise put in last used mac id

Thanks, unfortunately I came up empty when trying to google for what technology the deploy...

No, a number of ISPs forces the use of a VLAN on the WAN interface and unless one uses that VLAN PPPoE authentication will hang.

Have you tried setting that in the OpenWrt GUI?

Which router are you talking about here? The tp-link ISP router?

Yes, the Openwrt router will not have the same MAC address as your ISP supplied/old router as MAC addresses are supposed to be worldwide unique...

That sounds like a decent course of action, either contact them or try to change the wan MAC address of the openwrt router...

1 Like

I think he meant after flashing the TP-Link router with OpenWrt, does that change the MAC address from hardware MAC. @omkarpatil29 Can you confirm it was working on tp-link firmware before flashing?

You could double check with them what MAC address they have for you.

1 Like

I have similar issue with my wndrmacv2 router (just opened new topic on this). Like on a screen which lleachii showed I enter user/pass given by ISP. I do not need any VLAN tags and don't have any MAC restrictions from ISP side. I press connect and nothing happens. It just shows RX and TX are zeros. Logread output is empty when I grep ppp and eth1, it just shows me wireless clients connections info. I've tried everything including debug option for wan iface, still have an empty log. Chaos Calmer worked for me in past on the same router.
So maybe some bug in latest releases related to PPPoE? I agree with topic starter, you don't really need to be an expert to configure PPPoE properly via Luci. So not sure what the issue is.

@omkarpatil29 & @Dron, which openwrt version are you using? I had success with master versions up 20190516 (r10012-5c742c86ef-20190516-2231) to get a working PPPoE connection (on a netgear wndr3700v2, which I believe to be closely related to the wndrmacv2). But PPP has been updated between 20190604 and 20190516 and with the newer builds I see unrequested reboots if a PPPoE session dies and then reconnects (see This is decidedly not your failure mode, but indicates that there might be issues with the newer ppp.

I've already tried all stable releases listed on project main page 18.x.x and oldstable 17.x.x. I remember 15th release worked for me in past but it seems to be no longer supported so I don't want to flash it. I agree there may be some issue with ppp in latest releases.