Help me to use openwrt

I have mi router 4a running openwrt and TP link c6 v4 on stock I have ISP ethernet comeing in my house ISP is running pppoe server I want my openwrt router to connect 1st pppoe account and though lan 2 use 2nd pppoe account in TP link c6 running on stock is help me

why would you want to use two PPPoE accounts ?

Don't have answer just use first pppoe account on mi router 4a running openwrt and second pppoe account on tp link c6 v4 running stock please help me

Help me to configure openwrt router

then you probably don't need it ?

does this run a PPPoE server your 4A's supposed to connect to ?

why are you keeping the C6 between the ISP and the 4A, in the 1st place ?

1 Like

I have two pppoe accounts from ISP so I want 1st pppoe account on mi router 4a running openwrt and second in TP link c6 v4

But I have only one ethernet coming from isp

tried putting a switch in front of the two routers ?

I don't have switch can I do it from openwrt router mi router 4a switch on lan2 and 1st pppoe running and 2nd pppoe running on tp link c6 v4

If you don't have a separate switch, you can configure one of the routers to switch the ISP through to the second router on one of its Ethernet ports. That is not possible with stock firmware, so the one running OpenWrt must be first in line.

Is it a Mi 4A or a Mi 4A Gigabit?

1 Like

It's mi 4a gigabit and its running openwrt OpenWrt 22.03.5 r20134-5f15225c1e already please just tell me how to configure

You were just told how to configure the device:

Therefore, if you need more help, please explain what issue you're having (e.g. configs or showing screenshots) or what information you need.

As has been stated, the Mi 4a gigabit with OpenWrt must be directly connected to the ISP, and your other router can be connected to the Mi 4a.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
1 Like

I don't know how to configure help me to configure in luci

root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
config globals 'globals'
        option packet_steering '1'
config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipv6 '0'
        option delegate '0'
        option ipaddr '192.168.31.1'
config interface 'wan'
        option device 'wan'
        option ipv6 '0'
        option proto 'pppoe'
        option username '******'
        option password '******'
config device
        option name 'eth0'
        option macaddr '*************'
config device
        option name 'wan'
        option macaddr '**************'
config device
root@OpenWrt:~#

That either looks like an incomplete listing, or possibly missing a bunch of things due to misconfigurations. Have you changed the config of this device (aside from the IP address and PPPoE details)?

1 Like

Just FYI:

  • You're missing line breaks between each config stanza
  • Your last line

I agree - the config appears to be corrupt and missing things.

root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
config globals 'globals'
        option packet_steering '1'
config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipv6 '0'
        option delegate '0'
        option ipaddr '192.168.31.1'
config interface 'wan'
        option device 'wan'
        option ipv6 '0'
        option proto 'pppoe'
        option username '*******'
        option password '******'
config device
        option name 'eth0'
        option macaddr '**********'
config device
        option name 'wan'
        option macaddr '************'
root@OpenWrt:~

root@OpenWrt:~# cat /etc/config/network config interface 'loopback' option device 'lo' option proto 'static' option ipaddr '127.0.0.1' option netmask '255.0.0.0' config globals 'globals' option packet_steering '1' config device option name 'br-lan' option type 'bridge' list ports 'lan1' list ports 'lan2' config interface 'lan' option device 'br-lan' option proto 'static' option netmask '255.255.255.0' option ip6assign '60' option ipv6 '0' option delegate '0' option ipaddr '192.168.31.1' config interface 'wan' option device 'wan' option ipv6 '0' option proto 'pppoe' option username '*********' option password '*********' config device option name 'eth0' option macaddr '*********' config device option name 'wan' option macaddr '*********' root@OpenWrt:~

  1. Remove lan1
config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'
  1. Make WAN a bridge
config device
        option name 'br-wan'
        option type 'bridge'
        list ports 'wan'
        list ports 'lan1'
  1. Change these configs to br-wan (I'm not sure about these configs below):
config interface 'wan'
        option device 'wan'
        option ipv6 '0'
        option proto 'pppoe'
        option username '*******'
        option password '******'
config device
        option name 'wan'
        option macaddr '************'
  1. LAN1 can now be used to plug in your other router :partying_face:

Where are your line breaks?

Did you add this?