Help me setup ipv6 connectivity

i want to have ipv6 connectivity
my ipv6 upstream is as follow :
image

content of /etc/config/dhcp :

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ra 'relay'
	option dhcpv6 'relay'
	option ndp 'relay'

config dhcp 'wan6'
	option interface 'wan6'
	option ignore '1'
	option master '1'
	option ra 'relay'
	option dhcpv6 'relay'
	option ndp 'relay'

content of /etc/config/network :

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.96.1'
	option delegate '0'
	option ip6assign '64'

config interface 'wan6'
	option proto 'dhcpv6'
	option device '@wan'
	option metric '20'
	option reqaddress 'try'
	option reqprefix 'auto'
	option ip6assign '64'

i can ping ipv6 address from openwrt, need help how to configure further so that the clients also can ping or visit ipv6 addresses

There is no prefix from the ISP, so use relay mode. LAN clients will use IPs out of the single /64 that you do have.

Do you have any other device (modem, ONT, etc) in front of your router?

yes, im using LTE as internet source, it is huawei B312-926


is there something i need to configure there ?

i've read that, i'm confusing on setting up the LAN part, i've tried to configure relay also on LAN changed "delegate" and "ip6assign" option but nothing work

weird, i didn't make any changes and today i just have ipv6 connectivity.
image

anyway i'm curious how to block specific client to access internet
also i used adblock to block some domain, looks like it blocked the ipv4 address of the domain but not the ipv6 address

See if you can configure it as a bridge.

Please start a separate topic.