Help in debricking my Tplink CPE210

Greetings
I need help to bring my TP LINK CPE210 back to life
When I turn it on, the boot process seems to go well, the LEDs light up and it behaves the same as always, but I do not have LAN access to the device.

The only way to access it is by pressing the reset button and turning it on after 20 to 30 seconds I have access to FAILSAFE MODE from this interface I have tried to do several things but without results.

I had the OpenWrt version 19.07.4 installed and copy to the / tmp folder used WinSCP the OpenWrt version 19.07.7 and then update from Putty sysupgrade –n /tmp/openwrt….sysupgrade.bin

The update process lasted about 1 minute, when Tplin finished it restarted automatically. But the firmware update did not solve the problem continued with the same problem.
(I don't remember the exact message it gave)

but it continues with the same behavior. When I go back into FAILSAFE MODE now I see that it says OpenWrt 19.07.7, r11306-c4a6851c72. Apparently he made the update.

Now, from WinSCP I see that a large part of the folders is dated 2/15/2021 and others are dated 1/1/1970 I don't know if this is right or not.
WinSCP

How can I see the boot log or the system to know if it gives me a clue that it is happening?

Could you advise me what to do in this case to be able to diagnose the problem and solve it if possible, I have read a lot in the forum but I can't find anything to help me.

Thank you very much in advance.

There's no RTC in the device, date will be off until you set it, or define a NTP server.

Dmesg will show system log.

Restarting the unit mid upgrade probably wasn't a great idea.

thanks for your reply, the tp link CPE210 not working had that problem.

I just updated it to see if it could solve the problem with the firmware update, the update process finished correctly and it only restarted when it finished and now it has the new firmware version but it still does not work.

Doesn't work as in you're back if failsafe?

Greetings.
Thank you for your interest in helping.
So that you better understand the situation. I will attach an image.
To enter failsafe mode I must press the reset button and then turn on the device, this only allows me to enter with the Putty until this image that I show you or with the WinSCP enter and see the file structure. Execute commands but the device does not work.


What I need is for someone to tell me where I can find a device or system boot log, to see what error it gives, I suspect there could be a problem with a partition or something like that, but I need to know which one and then how can I do it? with commands reset this situation.
Or another idea that can lead me to solve the problem.
Thanks again

Access in failsafe mode but not on a normal boot means that something about your previous configuration is wrong. Your best bet is to run firstboot which will erase all configurations then boot normally in default configuration. Then reconfigure.

Greetings. I already tried but it does not solve the problem I need a tool that allows me to diagnose what is happening

Run sysupgrade again with 19.07.7, adding the -n option to not save configuration.

A router with default configuration should work exactly like one booted in failsafe mode.

The first CLI "tool" to consider here is logread or dmesg to review the boot log, but you have to be able to log in while the problem exists.

My regards, brother.
I have already run the sysupgrade several times with –n but am not getting any results.
The decision to update was made with the aim of seeing if it solved the existing problem, but it did not give me any results. I just update and it kept not working
To give you an idea if I Ping 192.168.1.1 it doesn't pin, the only way to ping 192.168.1.1 is when it is in fail-safe mode

This image is: Sysupgrade –n /tmp/sysupgrade.bin the process takes a couple of minutes and then the router reboots. But it is still the same

Be sure you're using the proper build for your model and version. You could mount_root to see if the configuration looks sane, and enable the default wifi AP then reboot normal to see if wifi works in normal boot.

Ultimately it's likely to require serial to see what the problem is in normal mode.

Well I run the mount_root command and this is the result.


How can I enable Wi-Fi ???
What file should I configure?

I have access with WinSCP

Blockquote
Ultimately it's likely to require serial to see what the problem is in normal mode.
Blockquote

how could I do this?
I have knowledge of electronics, is there a link where it is well detailed?

https://openwrt.org/toh/tp-link/cpe210#serial

Well I have a little good news inside the problem. :grinning:

After running Mount_root inside the overlay folder which was always empty, now the settings appeared. I went into Wireless I made a change to activate the wifi and then I restarted the Device and to my surprise I was able to detect the wifi and connect with a phone.

Now drawing conclusions (speculated a bit) apparently the device is fine, only that I do not have access through the network, I do not know, if it will be hardware or software problems. I will dedicate myself to investigate that.

If you could give me some advice on what to do from now on?

Log in by wifi and investigate the eth0 port.

When a cable (with a live Ethernet device on the other end) is connected or disconnected you should get a message in the log.

brctl show should show that eth0 is in br-lan along with wlan0.

when firmware.bin was copied to /tmp in mode failsafe
Did you check firmware hash sha256?

Greetings, thank you all very much for your help.

I tell you that I was able to solve the problem. :rofl:

Once in failsafe, use this mount_root command and then inside the overlay folder I found the settings, there I activated the wifi, and I had access to LuCI via wifi and made my settings this way. The problem I had is that this Tp link CPE 210 has 1 LAN connection and a WAN from which the LAN does not work. But I made one change and now it uses the WAN as a LAN now I have a connection with the device by cable and by Wifi and it works fine
.
Thanks for your help.
Ivan

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.