Help identifying if Apple TV caused network crash

My network went down. When I looked at the Openwrt log, I found AppleTV-2 entries repeating over and over before crash (sample of repeating entries below):

Fri Mar 24 12:07:37 2023 dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) c6:d1:37:d7:16:43
Fri Mar 24 12:07:37 2023 dnsmasq-dhcp[1]: DHCPACK(br-lan) c6:d1:37:d7:16:43 AppleTV-2

I have quantity two Apple TVs on the network. Interestingly AppleTV-1 only appears once in the log (which comprises yesterday and today):

Thu Mar 23 21:34:17 2023 dnsmasq-dhcp[1]: DHCPACK(br-lan) 36:dc:d3:3d:c4:88 AppleTV-1

So AppleTV-2 is spamming the logs but not AppleTV-1. Far as I know, I have both AppleTVs configured the same but under different Apple-user accounts. Anybody seen this before, know how to fix it?

If it's because the log filled up then you can do the following to reduce the DHCP noise

How many entries and on what time interval (the request and ack will be short, but what is the time from request-to-request?

Is there any possibility that another device is using (maybe a static IP)?

Does the AppleTV 2 work as expected (i.e. normal network functionality for streaming, etc)?

Are the two AppleTVs the same model/generation? Are they both running the same version of TVOS?

Can you describe in more detail what the symptoms were?

For yesterday and today, there are 354 entries. The request/ack is repeating about every 5 minutes

No. Everything is on DHCP except for a printer that is using .27 host ID.

Yes. Person that uses it streams from it without issue. When I check its function, it works fine.

Yes, both AppleTVs are exact same model and they are both fully up to date.

I was watching a stream on AppleTV-1 and it froze. I then tried to get on Internet with an iPad and it wouldn't work. Also ATA to phones was down. I looked at Openwrt log, saw the AppleTV-2 request/acks and then rebooted the AppleTV-2 and Internet worked again.

Is the AppleTV connected via wifi or ethernet?

What is the pyhsical topology of your network?
And what is the DHCP lease time for your network? Let's take a look at your network config to understand what else might be going on.

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

The AppleTV is on ethernet

the lease time is 192 hours (too long for a client?)

I'm in the process of ordering a Cisco smart switch. But currently I have:
modem > router (openwrt) > unmanaged switch:
-openwrt dumb AP
-IP Phone
-ATA for wireless DECT phone

Do either of these devices happen to have a USB-C docking hub with ethernet connected?


config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        list server '/'
        list server '/'
        list server '/'
        list server ''
        list server ''
        option doh_backup_noresolv '-1'
        option noresolv '1'
        list doh_backup_server '/'
        list doh_backup_server '/'
        list doh_backup_server '/'
        list doh_backup_server ''
        list doh_backup_server ''

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '192h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

How did "list server '/'" get in my dhcp? Does openwrt use that or did an Apple device insert that?

Oh. I identified a difference between the Apple TVs. AppleTV-2 user account makes use of iCloud for backing up photos taken with iPhone. AppleTV-1 does not use iCloud at all.

Yes, the laptop has Anker small hub that has ethernet>usb-c connection (no power delivery, just ethernet to non-power-delivery USB-C port)

I set a DHCP reservation for AppleTV-2. Wait and see if that improves things.

If the problem occurs again, try unplugging the ethernet connection from the anker hub.

Found this.

Going to experiment with different switch. But maybe ATV nic is going bad?

Reserving IP didn't help. receiving request/ack every 30 seconds right now.

This is a rather important difference.... especially given that it appears you're not running the default dns situation (are you using DoH/DoT, or adblock or something else)?

I'm not sure how that got there, but I do think that those servers need to be accessable for icloud to work properly.

Try disabling the icloud features of AppleTV 2 and see if it stops having DHCP issues.

Possible, but unlikely IMO, since the device is requesting a lease... more than likely this is a DNS thing and the AppleTV isn't happy with the DNS situation so it's requesting another lease for some reason (maybe it believes the lease is bad or wahtever).

I believe it's solved. Going to wait awhile to be sure before marking this thread.

Apparently, someone at Apple thought it a good idea to spam router logs with DHCPREQUEST/DHCPACK if Apple TV user chooses to not add their Apple TV as an accessory to the Apple Home app.

Once Apple TV is added as accessory to Home app, the spamming stops.

Thanks so much to all who posted trying to help. Love you guys!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.