Help I think I bricked my Xiaomi Router 4 (R4)

I have a Xiaomi Router 4 (R4), I was trying to flash it, I was following this video

I did the part until 2:55 in the video, where he flashed the kernel1 and rootfs0 partition. I downloaded the files from here

Then I could not proceed following the video, according to the video the next command was

nvram set uart_en=1

I could not run this command, it failed saying something about core dumped. I tried logging in to my router admin page and it won't load. The internet is working though. I can FTP into the router, but telnet and ssh fails to connect. Can I fix it? I'm a bit worried.

@apoorv569, welcome to the community?

  • Why did you follow an unofficial install procedure?
  • Why did you install an unofficial firmware?
  • Why are you asking here instead of the video's producer or the firmware maker (I simply wish to understand if they tried to assist you already)?

Which one?

Please provide the correct link to your hardware. Also, you can browse to the section on how to recover your device.

Why not here?

That doesn't mean could be a dumb switch (i.e. router did not boot and set the switch ports) connected to your ISP, no details provided here that helps regarding the device.

Sorry, but my stock router firmware was in Chinese I could not understand much, after trying to use the translator to see the information about the model, it only said Xiaomi Router 4 (R4) nothing else. There is no more info than this on the back of the router either. I did check the OpenWRT official download page first but was not sure, the video I followed I followed because it had the same name as my router and the guy uses same method as guy that OpenWRT recommended for video tutorial on the website, which is -

I could not flash the firmware following this video, it failed at mtd -e OS1 -r write firmware.bin OS1, from here -

so I kept looking for some other tutorial, so I found that video I posted in OP. Also in the section in github link above Xiaomi 4A Gigabit Global Edition the download link was for mir3g but my router model 4.

BTW, I rebooted my router today and tried going to and I was able to view the page, I logged in and set up my config for internet, its working so far. But I want to make sure the firmware I'm using is official and secure, could you please point me to a direction to try to find the correct model somehow. If I were to bet my best bet would be Xiaomi Mi Router 4A (MIR4A) Gbit.

  • OpenWrt recommended???
  • Can you provide information/links for on those so-called official suggestions?

It would really help to explain why you keep linking unofficial videos.

I'm just lost on how you think we can provide assistance:

  • When you don't even know the model to communicate it to us
  • We don't know if it's officially supported
  • You didn't use official firmware


(Perhaps someone else more clearly knows the you have a picture of your device?)

If you're running a third party OpenWrt it is likely still going to show the model build and CPU type on the main status page. Find the matching official build and install it with sysupgrade.

4A Gigabit is the same as 3GV2. But that is not the same as 4A non-Gigabit or 3GV1.


This is what status page reports as the model,

1 Like

This is what my router looks like

1 Like

So my model is Xiaomi Mi Router 4A Gigabit Edition ?

I should download this then?

I would verify that everything's the only "4" router with a MT7621.

It kinda looks like MiWiFi R4 too, this has the MT7621AT. Images online looks similar.

Well the cpu make = MT7621, cpu cores = 2, clock speed = 880, memory = 120mb, does match with Xiaomi Mi Router 4A Gigabit Edition. But the link you sent to the forum, the photos there, looking at them the sticker on the back is up to top of backside and specific says 4A, where as mine is in center and only says 4. If that makes any difference.

Giving a second look, no it does not look similar to the one in forum link you sent. The reset button and ports are different on mine. The reset button on mine is inside I have to push a safety pin or something to press it, where as in the pic in forum the reset button is outside. Also mine has some button on top of the router as well, where Mi logo is. It looks more like this,

See the picture of router in the link.

The availability link here is indeed 1 of them, where I bought it from. Gearbest.

Its definitely this one

But this has no download link for firmware.

You can get it back using a serial cable and

But the unit has to be reset for the serial to accept input.

Thanks for this link, this is my router for sure, looks very similar. Although what I'm looking for is the right firmware to flash not go back to the original.

Also I noticed one of the person that is in the discussion in the link provided, is the guy that I got the rom from, his github page.

Back as in resurrect, not go back to stock fw.

No, actually the firmware I flashed from the github of the guy I linked above is working, when I was in the process of flashing it the telnet connection closed, and I could not login to my router admin console on web either, so I thought I bricked it, but the internet was working so I left it for the night like that, but when I restarted the router next day and went to, it booted fine and I was able to set up my network configuration for WiFi and all, so as of now I'm using my router fine. But I wanna make sure the firmware I'm using is officially supported and stable for use. So I'm looking for the right file, so I can upgrade to that firmware.