Help! I need firmware for TP LINK WDR3320v2

I have a device TP LINK WDR3320 version 2 but when I go to Opentwrt to download it, it gives me a 404 error. Does anyone have the Factory firmware and Update of TP LINK WDR3320, please give me the download link. Thank you

slightly newer

1 Like

thank you very much

Be aware of - neither this device (below minimum systems requirements), nor 17.01.x (EOL, affected by multiple high profile security issues) are supported by OpenWrt anymore.

Can you tell me why when I run the firmware sysupdate.bin, I get such an error?

Factory (going from TP-Link stock firmware to OpenWrt) -

System upgrade (upgrading existing OpenWrt installation) -

I have downloaded 2 firmwares as above, then I received the "factory" firmware, and the "sysupdate" firmware received an error as shown.

What version is already installed?

Verify the SHA256 checksums of the downloads -

Factory -


Sysupgrade -


i am using 2 firmwares like you gave above

So if you successfully installed the 17.01.7 factory firmware, why are you trying to upgrade it to 17.01.7?

I see people when the instructions usually install the "factory" firmware first and then install the "update" firmware, so I follow the instructions from everyone. so do i need to install the update file now?


It's not necessary.

Can you tell me why I don't see the wifi display and the wifi display light on the router?

Is the WiFi switch on the back of the router turned on?

Did you enable WiFi in OpenWrt?

It's turned off by default after install.

I have reset and on the router the wifi light is on. In Openwrt, % wifi = 0

Use channel 1, 6, or 11 instead of "auto".

See the OpenWrt docs on configuring WiFi...

Can you tell me where it is located because I can't find the support section?

Where what is located?

I also tried changing channels 1, 6, 11 but still showing 0%

Read the Wi-Fi configuration docs...

I posted the link for you earlier.