Help getting connectivity for a new user

Hello, all. My apologies in advance for what I'm sure is a dumb question. I'm brand new to OpenWRT.

I have an Archer AC1750 router. Yesterday, I went to install OpenWRT. I downloaded the image for the latest full release and went to upload it - said that the file was not valid. I discovered that I have an Archer A7 instead of the C7, so I needed to use a snapshot release - no problem (I thought). Downloaded and installed that, no issues. So I SSH via putty to the router. Yay, it's alive!

But when I try to download the latest packages so that I can get the GUI up and rolling, it appears not to be connected to the internet. It's hooked up to my modem. When I put an old router back on, it works fine. The router also worked before I installed OpenWRT. So I'm stuck. Most of the troubleshooting that I've seen online gives steps for the GUI that I can't follow, as I'm limited to the CLI. So I'm hoping that someone here can give me some specific steps for how to get the router itself connected to the internet connection that it has available. Any help would be greatly appreciated.

Do ip addr show and see what your wan IP is (I think that will be on eth1.2) Also confirm that it is not 192.168.1.X. If your upstream network is the same range as the LAN you will not be able to reach the Internet.

Don't quote me on this but I thought that once an A7 has been initially flashed to OpenWrt, you can run C7 builds on it.

Thanks for the reply! Honestly, not entirely sure what I'm looking at, but there's the output:

root@OpenWrt:~# ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP qlen 1000
    link/ether b0:be:76:2c:f0:df brd ff:ff:ff:ff:ff:ff
    inet6 fe80::b2be:76ff:fe2c:f0df/64 scope link
       valid_lft forever preferred_lft forever
4: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether b0:be:76:2c:f0:de brd ff:ff:ff:ff:ff:ff
5: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether b0:be:76:2c:f0:df brd ff:ff:ff:ff:ff:ff
6: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether b0:be:76:2c:f0:df brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
       valid_lft forever preferred_lft forever
    inet6 fd44:25be:ab61::1/60 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::b2be:76ff:fe2c:f0df/64 scope link
       valid_lft forever preferred_lft forever
7: eth0.1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
    link/ether b0:be:76:2c:f0:df brd ff:ff:ff:ff:ff:ff
8: eth0.2@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    link/ether b0:be:76:2c:f0:e0 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::b2be:76ff:fe2c:f0e0/64 scope link
       valid_lft forever preferred_lft forever

And I would be willing to flash it again with one of the full releases... if I knew how to do that via ssh. But it seems likely that troubleshooting this install and getting luci up and running will probably be just about the same amount of trouble (but I may be way wrong).

I would think the easiest way to get connectivity (if you are more of GUI guy) s to connect the other router's LAN to OpenWrt LAN, so that you can download the GUI and then set things up as desired.

Just make sure when you connect both routers together that not both of them is 192.168.1.1.

That seems like a very viable solution. Another dumb question though: my other router sits on 192.168.0.1; will the OpenWRT router be able to connect through it? Or would I need to put the OpenWRT router on, say, 192.168.0.2? My assumption is that I would have to do so; if so, what's the easiest way to update the OpenWRT router's IP?

And I just keep them coming: if I do this, should I connect the live line from the working router to the internet port of the OpenWRT or to one of the output ports (like I was setting it up as a secondary wifi connection)?

Yes, we would need to have them both on the same network. So you will have to change the IP of either the old router via its GUI, or OpenWrt as follows

uci set network.lan.ipaddr="192.168.0.2"
service network reload
uci commit network

So... that's seems to have boogered it up. I hit the first command, no problem. I hit the second command, and it kicked me out of the ssh session. Now I can't get back to it via the new or the old IP.

EDIT: Ok, it eventually reverted back to the 192.168.1.1 address. Is there some way to queue all the commands to run?

EDIT #2: Nevermind! I decided to change up the working router instead, and now everything seems to be accessible. I have luci up - now to finally figure out why I have no internet access.

Ok, everyone. Thanks for all the help. I seem to be good to go. The entire issue seems to have stemmed from the fact that it takes Comcast a very long time to give a new IP when a new MAC is looking for one. I enabled "Use broadcast flag" on the WAN and then I just let it sit for about 20 minutes. Boom! I am finally connected.

Great. If you issue is solved, please mark the reply with the solution by ticking the the box underneath it, as shown below
grafik

You may also edit the subject of the topic using the pencil icon to add [Solved] at the beginning.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.