Help for a noob

I just bought a new ZBTLink WE1326 router with 4G/LTE support and was having difficulty getting it to work with my SIM card, so I thought that I’d try OpenWRT as a firmware replacement to see if that might solve my issue. However I’ve now got myself into a predicament.

I got the openwrt firmware installed but it didn’t seem like there were any options for setting or configuring the SIM card, so I thought I’d try rolling the firmware back to the original one. Then I realized there was no simple rollback or restore function in the web UI. So then I thought maybe using the factory reset button on the router may work. However that just made it worse. Now the openwrt boot loader is gone, replaced by some sort of Chinese boot loader of some kind called Breed Web, and I can’t make heads or tails of anything.

I tried using Google Translate to figure out what the various menus and options were, and found something that looked like an “upload firmware” button, but when I select the openwrt firmware file I installed previously it says the file size is incorrect (or something similar according to Google Translate)

So as it sits the router is pretty much dead in the water. I’d appreciate any advice anyone has to get back to a working state. I’ve never used openwrt before so I’m definitely in over my head here. I’d love to just get the original firmware back in place if that is even possible.

Time to fire up ye olde google translator.

Here's what you need.
Translator for the Breed Bootloader


Thanks for the tips, but unfortunately I didn't quite see anything there that helped with my particular problem.

I did some more searching and found this page that explained how to SSH into the router and manually reinstall the firmware:

After following those steps I was able to reinstall the 21.02.0-rc3 firmware version and am now seeing the original openwrt admin panel instead of the weird Chinese boot loader thing. So at least I've got the router back to a somewhat working state.

The question still remains though: is there any way I can recover the original firmware that shipped with my router? I may be a bit in over my head here trying to get openwrt working and am thinking it might be best to undo all of this.

1 Like

You would first need to obtain the original firmware as a file from the manufacturer. There is only enough space in the flash memory for one firmware at a time, so the firmware that came with the router has been erased.

The LTE modem is a separate module with its own independent CPU and closed-source firmware. Changing the firmware on the router side is unlikely to help with basic connection problems such as SIM card locked, IMEI rejected, or band capability is incompatible. Those are all handled between the modem and the cellular provider.


Thanks for the suggestion regarding the original firmware. I've reached out to the manufacturer to see if they are willing to send me a copy of the original firmware in case I decide to go back to it. While testing this weekend I have made some progress with OpenWrt so I may continue down this road.

As for my choice to attempt using OpenWrt to being with, I suspected that the original problem I had with the stock firmware didn't have anything to do with the SIM card itself or the cell provider, but rather limitations in the firmware itself. Based on my latest ad-hoc testing I've discovered more evidence to support my belief. I'll post more details in a follow up comment in the thread.

As I mentioned in an earlier comment, I managed to get the latest RC version of OpenWrt installed and running on my router, after which I proceeded to follow the instructions here to attempt setting up the LTE modem in my router. After much testing and debugging I've managed to get an active connection to my cell provider (Koodo). For reference, while debugging I hit 2 problems that I think are worth mentioning:

  1. putting the SIM card into the router while it was powered on seems to put the card into an indeterminate state or something. Rebooting the router didn't rectify the problem. I had to completely power off the router and power it back on again for the card to respond correctly to commands
  2. when adding a new network interface via the LuCI web UI, the "PDP Type" defaults to "IPv4/IPv6", however when selected the modem refused to respond and seemed to crash or something (ie: wouldn't accept any further commands). I had to select the "IPv4" only option in order to get the modem to respond

So now I have an active uqmi connection to my service provider. Here's a sample from the uqmi -d /dev/cdc-wdm0 --get-current-settings call:

	"pdp-type": "ipv4",
	"ip-family": "ipv4",
	"mtu": 1500,
	"ipv4": {
		"ip": "",
		"gateway": "",
		"subnet": ""
	"ipv6": {

	"domain-names": {


Following some other tutorials / forums, I also set up minicom and am able to send AT commands directly to the serial interface further confirming the fact that the modem is actually connected.

One sticking point I hit on the LTE users guide I mentioned was the fact that they recommend setting up the new LTE interface using the "DHCP" protocol. I tried several different variations of settings, including those mentioned in the guide, but I could never get the connection / network interface to work correctly. I had numerous errors including "failed to connect to provider" as well as vague "failed"/"error" type messages. After messing with this for some time, I discovered this YouTube video of a person demonstrating a very similar configuration, but they instead chose to use the "QMI Cellular" protocol instead. After doing some further testing/debugging with this approach I was able to successfully see the LTE connection in the LuCI web interface.

So far so good, however now I am stuck yet again. Despite getting this far the router still can't seem to communicate with the internet. When I execute "ping" operations from the router itself, either to host names or IP addresses from the web, they always fail with "host not found" or "network unreachable" or other such errors. I've confirmed that the network interface I created (CELL2 in my example) is added to the "wan" network zone in the firewall, which seems to be the most common problem people hit when setting this up, so that's not the problem here. I could really use some advice on where to proceed next!

Here are a few more interesting pieces of information that may be helpful for debugging:

  • I noticed the ipv4 connection parameters returned from uqmi are missing entries for DNS servers. Perhaps this is expected though.
  • I noticed the inet address shown for the wwan0 interface in the ifconfig output doesn't match the ip address returned from the uqmi command. Again, maybe this is normal though.
  • when I connect a wired connected to the "wan" port on the router, I am able to ping internet addresses
  • I've confirmed that the "wan", "wan6" and "cell2" interfaces are all part of the same firewall zone
  • I've confirmed that both the wan and wwan0 interfaces show up with valid net addresses when running ifconfig from the router
  • I noticed that the wwan0 interface shows an inet6 address associated with it when looking at the ifconfig output, even though I was unable to create an ipv6 compatible interface for it in the LuCI web UI
  • I noticed the wwan0 interface has other "unusual" details in the ifconfig report, as I've shown below (ie: the link encap, hwaddr, and P-t-P fields in particular):
wwan0     Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:  P-t-P:  Mask:
          inet6 addr: fe80::73d:84:d390:dee8/64 Scope:Link
          RX packets:2 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1880 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:610 (610.0 B)  TX bytes:127326 (124.3 KiB)

Any help on what I can check next would be greatly appreciated!

Just a shot in the dark...

Might have to assign an address before the other stuff works. option macaddr 'xx:xx:xx:xx:xx:xx' in the appropriate iface / UCI.

Or using LuCI network-->interfaces-->wan-->advanced settings-->override MAC address

Also forcing could help....

LuCI-->network-->interfaces-->wan-->advanced settings-->force link

Manually configure some if possible?

Some users disable all ipv6 related settings and it all starts working. Not sure what the case is here.

Some users adjust the TTL to trick the provider into thinking its a cellphone. Not sure what the case is here.

Here's some other webpage with recommended settings - in case there is anything there that helps.

So I’ve tried all the above suggestions without any luck. Forcing a MAC address onto the wwan0 interface, enabling the force link setting, and adding explicit DNS server names to the resolver. Same results.

I now have purchased another SIM card from another provider to compare and am getting similar results. With the new SIM I see the following differences:

  1. The LTE modem returns a set of DNS servers on connection unlike my previous SIM
  2. Host name resolution works (ie: pinging servers on the web like or resolve to valid IP addresses)

But otherwise, I’m getting the same results. The LTE modem appears to be connected based on all the tools and queries I run, and yet it still seems to be blocking traffic between my cell service provider and the rest of the internet. I even had a friend of mine who is a professional Linux system admin / network admin take a look and he is baffled. Traffic seems to flow from the router to the service provider but not out to the rest of the internet.

Is there maybe some additional setting that I might need to make on the router to maybe signal to the service provider that it is OK to route requests out to the rest of the internet?

Just want to make sure you looked at this TTL issue ...

Another idea would be to stick the sim in an android phone to see if you can scrape the settings its using and then compare / re-use them in the router.

Thanks for the reminder. I did get the TTL value as suggested and I still get the same results.

1 Like

After digging into this further and having numerous phone calls with my cell provider, I came to discover that the provider is filtering traffic to the internet based on restrictions associated with my plan. Apparently my plan will only allow internet traffic to flow if it originates from a cell phone, and won't work on another connected device. From what I can tell the filtering is based on the IMEI of the device the SIM card is installed in. So if I put the card in a cell phone, everything works fine, but if I put it in my router it will connect but can't get traffic routed to the internet. The kicker is, if I want to convert my plan to one that supports a router, I have to pay about twice the price for less bandwidth and they also throttle the speed of the network so I get less throughput. So overall less functionality for way more money.

The only other alternative that seems feasible here is to tether a phone to the router and use it like an external modem. This will work for me in the short term but longer term I'm not sure if this will suffice. The reason I purchased a router was so I could install external antennae to improve signal quality when we are in low-signal areas, something which you can't do on a phone. So it looks like I may be forced to pay through the nose to get something decent here.

Maybe it's time to look at alternatives like StarLink or something for remote/mobile internet. :stuck_out_tongue:

Anyway, thanks everyone who offered help and suggestions here. I appreciate everyones time.

1 Like

...or you could connect to the phone's hotspot using OpenWRT in AP / STA mode.

...installing external antennae on a cellphone would be a fun challenge. But the easy solution here is you can place the phone in a better location for best signal and then use the phone's hotspot to connect to.

***Extra credit: put the cell phone in the focal point of a parabolic dish or build your own custom reflector.

***or heaven forbid one of those cell phone repeaters you can buy online - haha are those legal? Could be good in a rural situation to try and grab some signal?

Verify with a provider if you are allowed to do this with a cellphone hotspot on an unlimited data plan instead of playing the LTE/3G modem game in the least competitively priced market in the world.

Stop kicking things. Change providers if need be. Unlike the budget friendly WE1326, most LTE CAT12 modems (even CAT6) for example, are expensive and often fail to deliver or even work with some providers.


I have read time and again of angry users (rightfully so) reporting cheap handsets (with better antenna diversity) getting significantly better connectivity and throughput than expensive LTE/3G routers. Often the difference in antennas is 2db handset vs. 6db router antenna. 4db improvement?

Check with provider first so you can avoid breach of contract/ scurrilous lawsuits.

Thanks for the tips. I'll have to do some practical testing to see how far I get with my current solution. Maybe internal antennae will be sufficient for my needs. Fingers crossed.

As for cell providers and contracts, I’ve check literally ALL of the available service providers in my area (bell, Telus, Rogers, etc. etc.) and they all have nearly identical terms. Want data on your phone? Here’s a decent $40-50 plan. Want data on a wireless hotspot? Here’s a $90-120 plan that has equivalent data caps with slower transfer rates. Trust me, if the solution were as simple as just changing providers I would do it in a heartbeat.

I will point out that I am in Canada and it seems that cellular providers here have much worse terms and contracts than US providers, even in cases where they are the same company! Crazy. Heck, some providers here won’t even sell me a data only plan unless I buy a $400 hotspot / mifi device directly from them that is even worse quality than the WE off brand unit I already have. Absolute craziness!

But at least my current solution is working and within the terms of my contract (ie: no weird IMEI spoofing or hacks needed). Tethered data is allowed, although I’m told that when I reach my “guaranteed” data cap tethering will be disabled even though I’m paying for unlimited data plan. So not only do they throttle your throughput after your superficial “limit” is exceeded, but the block other devices from sharing the data after they throttle you. Gotta love the “unlimited” data plans. Crazy! And yes, all of my local carriers have the same or similar terms as well.

If anyone on this forum knows of a Canadian cell provider that does charge double the rate for limited data only plans, or who don’t restrict tethered data on their unlimited phone plans, or who don’t force you to buy overpriced hardware with limited features, etc. I’d love to know about them. Who knew buying cellular data was so complicated! I figured setting up the access point and learning about high gain antennas was going to be the complicated part. Boy was I mistaken!

Oh, and I had originally used the Wi-Fi binding from the phone to the router, which didn’t work too bad, but it requires me to have an additional power source for the phone which is less than ideal. With USB tethering I get the power distribution for free with no additional equipment. (Ie: power outlets in motor homes are quite limited)

The non-bell-rogers-telus provider's in Ontario are offering 10-15gb / unlimited cellphone plans in the $50-65 range.

After you reach the cap they allow 100-150Kbps unlimited - which I have tested and should be clearly stated in the plans. Unless they rolled back due to recent rulings - that I don't know.

Buying two-three used phones / plans could be a price competitive way to go compared to the over priced hotspot non-sense and offer redundancy. If you could LAG them you could get 300-450Kbps after the cap. I like those motorola MAX G or whatever it was a few years ago - 5000maH battery.

IMO most cell networks are maxxed out and hence the push to 5G.

I think Starlink will be aimed at and licensed primarily for rural users. It will be nice for them.

  • Get 2 or 3, 25,800maH (~60 watt hours) USB power banks. They will run a 2W load (typical cellphone or AR750S tested) for 30 hours. You can usually get them for around $25CAD (rule of thumb 1,000maH = $1CAD) from the big online retailers otherwise you are overpaying.

  • Or run a custom DC extension cable to the cell phone to avoid inverter losses. Lots of cheap 12VDC auto parts and kibble available online. The cellphone might get good reception on your dash right beside the cigarette or USB power. Buy a long USB cable.

  • Or run an AC extension cord to the phone with a USB charger on it.


Bonus points:

  • make a crude RF reflector using the dash board aluminum mylar sun reflector

If you look at the fine print they likely disable tethering after the initial 10-15gb limit is passed. So not only do they reduce your speed, they also block you from sharing the data at that reduced speed as well. Honestly, for 75% of the stuff we're planning to use our device for, 100-200Kbs is probably more than enough anyway. Plus all the providers I've spoken to won't let you use a SIM card from one of those cell plans in a non-phone device like a hotspot, so there's still that part. :stuck_out_tongue:

Thanks for the tips on ways to power the phone as well. I'm sure I could get creative to find some way to do that, but I just hate spending time and money building solutions to problems that shouldn't even be problems in the first place. :stuck_out_tongue: I'm still holding out hope that I'll be able to find a decent cell provider that'll just let me use one of their typical cell plans / SIM cards in my wifi device, then all my "problems" will be solved. It's just mind boggling they make something that should be so simple, so difficult / expensive. :frowning:

Totally agree - monopolistic 19th century business practices in the 21st century. Progressive. It's actually hurting the economy at this point.

Fortunately Canadians still have many options in the modern epoch. I was recently reading RFC2549 concerning a relatively new protocol that may be of benefit. Have you looked at IPoAC? It suffers zero packet loss if implemented correctly and has a proven track record - although it may not be ideal for every use case.