Help flashing new firmware to stable version on apu2c4

need help flashing new firmware on apu2c4 and would like to use a stable build rather than my neighbors build that he made, but i cant seem to figure it out myself.

i have been using his builds for a while now. this current build does not have luci installed on it and that is making it difficult for me to figure out. i have tried to go through and install luci through ssh, and the standard
opkg update
opkg install luci

is not working for me. im a newbie and could really use some help.

ssh in, download to /tmp/ (don't decompress) and use sysupgrade from there (technically sysupgrade would also download the image itself, if you hand it the URL); consider -n (deleting the config), if you don't trust the current image.

ill give it a try, i have no coding background so im using the forum and website to learn right now but ill look into how to do that

update ive been trying to figure it out myself for the last 3 hours or so and i dont feel like ive gotten anywhere, i would be happy with the current image if it had luci


thanks man, now i just need to go through and update everything hoping to learn alot more in terminal and build a better knowledge base across this platform

By update, if you mean install new packages (fresh) and configure your device, great. But don't (blindly) upgrade packages...

Upgrading packages (via the CLI opkg upgrade command or the LuCI Upgrade... button) can result in major problems. It is generally highly discouraged, unless you know what you are doing or if there is specific instruction to do so.

You live and you learn, I think I did something wrong, after the update, I was logged into luci via chrome and all of the sudden I was no longer able to connect to my the firewall and dns is showing home.arpa and even connected over Ethernet, I can no longer find the firewall from my desktop or any other device

Maybe failsafe mode can help.

Or a serial connection would also help.

Sadly lost my only serial connector a while back and haven’t actually needed it since. But I will try to boot into fail safe mode

Try moving the ethernet cables around, port assignments might have shifted.

I tried that and it didn’t seem to work

perhaps you got the same issue as I do (no likely since my Roqos RC10 uses an Atom CPU, your's from AMD, but you never know), where 23.05.0 won't boot, the boot sequence looks complete, but the system's actually frozen.

I had to roll back to the previous release.

the Roqos got HDMI, you'll need serial for your recovery, unless you changed the boot order, and have
it try to boot off USB 1st.

Thanks for looking into it, I’m going to take a break tonight, just so my household isn’t pissed at me, I’m rolling back to using my isp’s provided modem and resetting back to default so everything should work seamlessly for them while I look into getting it back up and running right