HELP: Dumb AP as DHCP Client broken after reboot

I want to use my Linksys WRT1200AC v2 with the newest openwrt available for it as dumb AP behind a Fritzbox.

My setup is pretty simple:

  • changed the br-lan interface to DHCP-Client
  • RA-Service, DHCPv6-Service, and NDP-Proxy dropdowns are disabled
  • The "Ignore Interface Checkbox" in the DHCP-Server-Tab is NOT checked because if checked the Interface (that is configured as DHCP-Client) does not get an IP.
  • dnsmasq and firewall disabled
  • wifi enabled

This Setup works like it should, the Fritzbox assigns the IP to the OpenWRT Router after i plug in the cable and everything works.

The one big Problem i have with this Setup is rebooting (over the WebUI and hard with the power switch, did not test over ssh), if i reboot then it stops working, the router is not accessible on its IP anymore, WIFI will show up but also without any access.

I have absolutely no idea whats wrong and this is the 4. Time i reconfigured the AP, luckily i just found the config-backup option... :smiley: Thanks a lot for your help.

You could plugin a cable between this AP and your PC and access the AP via link local IPv6 to have a look at the log file...

Thanks a lot for the tip with link local, did not think about that, however i am not experienced with OpenWrt so i cannot see suspicious things in the log.

Here is the log:

As I read the log dnsmasq is still running?
Execute /etc/init.d/Dnsmasq disable again, and reboot.

That is not true, DHCP client operation is handled by a separate program called udhcpc and is not affected by the settings in /etc/config/dhcp. Ignore interface should be checked there to make sure it is not running a DHCP server on the interface. This would serve incorrect settings to other DHCP clients and cause network problems.

The issue becomes moot when dnsmasq is disabled, if dnsmasq is truly disabled.

udhcpc is not a service, it is started as needed at runtime by the UCI network scripts.

Thanks to both of you, i corrected the DHCP setting and the OpenWRT AP did not get an IP-Address as i mentioned before.
I tried it again with static ip instead of DHCP-Client, however the Problem persists:

After a reboot there was no ssh access and no luci access possible, but the Fritzbox showed that the AP is online with its ip.
The wifi of the AP was also not able to reach the internet or other devices on the network.

Here is the new log:

Let’s look at the config. Also, how is this connected to the upstream router - by the lan or wan port?

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

Thanks but it works now without any change after i powered it on again to gather the logs you requested. I rebooted multiple times to make sure.

Edit: it just stopped working out of nowhere again, i will soon post the configs

Edit2: configs

/etc/config/network:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd87:0c7f:2814::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.178.2'
	option gateway '192.168.178.1'
	list dns '192.168.178.24'

config device
	option name 'wan'
	option macaddr '62:38:e0:0e:68:93'

/etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option country 'FR'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option macaddr '60:38:e0:0e:68:95'
	option ssid 'WIFI_5_ghz'
	option encryption 'psk-mixed'
	option key 'somekey'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option country 'FR'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option macaddr '60:38:e0:0e:68:94'
	option ssid 'WIFI_2.4_ghz'
	option encryption 'psk-mixed'
	option key 'somekey'

/etc/config/dhcp:

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

/etc/config/firewall:

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'lan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

From your log:

[441.429858] mv88e6085 f1072004.mdio-mii:00 lan4: Link is Up - 100Mbps/Full - flow control rx/tx

This is the only Ethernet port that is up, and it took 7 minutes to come up. Is that because you had the cable unplugged? Also it is only running 100Mb, if the device at the other end is Gb capable that probably means the cable is bad.

lan1 did come up at 1 Gb for a few seconds early in the boot, but then it went down and never returned.

Which port connects this AP to the rest of the network?

lan1 is connected to the Network.

lan1 link is down which is why it is not working.