Help DIR-2660 stuck in recovery orange flash

on DIR-2660 A1

downgraded from 1.11 ofw to 1.04b3
entered recovery mode with reset button

flashed 21.02.0.factory image, flashed successful message and now nothing I know it's probably bricked, but how do I fix it please?

new to openwrt, so any help is appreciated.


As long as you can still get to the web recovery UI, make sure to flash OpenWrt using a Windows based browser. Firefox e.g. on Linux will break (seen it with DIR-878 A1 and there's multiple reports on this forum with newer 802.11ac D-Links about the same issue).

I think i flashed a master no luci from what i read

on booting the router just has white led on power, cannot get access to webui now

The recovery gu doesn't load it times out

It can be a bit finicky. Don't forget to set your client to a static IP in the same subnet as the recovery (see D-Link's instructions for that). And snapshots don't have a web UI indeed but you should still be able to get in over SSH if it managed to boot normally.

had manual ip setup...definitely have a feeling it's bricked

if you manage to get recovery working again, use 22.03rc5 or newer:

I have never read of an OpenWRT deployment file destroying the recovery partition, except if you had used commandline flash tools

1 Like

That was my original plan rc5 then i had to jump through hoops downgrading ofw etc they never make it easy!

it worries me it is nolonger reachable on its default ip though since flashing opnwrt factory image or now that i think about it openwrt uses and not 0.1 like dlink fw that could possibly be my answer

Have you tried rebooting it e.g. 2-3x?
As it has this internal secondary vendor firmware partion. It may eventually use that partition to turn back to an older factory firmware version.

That was it the ip address had changed to from ofw and already had luci gui on the openwrt factory image...updated to rc5

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.