Help: db120 board LAN keeps changing MAC address

Can someone tell me is my firmware flashed in my board behave normal? i flashed the AR7XX/generic/db120.bin firmware. i log in as root without password in GUI via luci ( went to Network>Interface>lan and remembered the mac. i reboot the node and see if lan interface mac address changed. and yes the MAC changes. but when i try to edit>advance settings>override mac then once again reboot the node. br-lan followed my input but the eth0 keeps changing. any help here?

Duplicate of: Help: DB120 Board with Meshdesk MAC changing every reboot

Please do not make mutiple posts of the same issue.

My apology IIachii but can you help me how to remove my previous post, i created a new one because i think the issue does not reside anymore in meshdesk package. but it also happen only if i install the stable version firmware from

There's no need to remove the post, you could have edited it.


  • Did you change the MAC?
  • Did you specify a MAC?

This isn't possible...did you ever create a password!?!?

Yup from fresh install it says there is no password on this router so i leave it blank. and yes i put my desired MAC address in "Override MAC".

I'll try again:

You cannot leave the password blank.

This isn't possible, until you specify a password.
Also, the alphabets must be lower-case.

config interface 'wan'
option ifname 'eth0.2'
option _orig_ifname 'eth0.2'
option _orig_bridge 'false'
option proto 'dhcp'
option macaddr '0f:1b:2f:3f:4f:5a'

MESHdesk scripts create whole configuration files (at least /etc/config/wireless and /etc/config/network) from information supplied by the server, wiping out any changes you locally make. This is not necessarily bad but that is how it works.

If you don't have an already defined and specifically supported router model, you may need to make changes to the scripts or on the server to make it work.

I did not think it tries to change the MAC address though.

I would suggest looking at config files directly rather than through LuCI. Again Meshdesk's philosophy is to take total control of the AP, any configuration by the user will be through the Meshdesk server.




No password set!
There is no password set on this router. Please configure a root password to protect the web interface and enable SSH.


Please set a password!


yes i understand that. but i already have minicom running on a LINUX VM connected via usb to serial TTL that is why im seeing the bootloader.


WHAT!?!? What are you talking about!?!? This is the Web GUI!

  • Set a password
  • Change the letters in the MAC to lower-case 00:19:be:a1:5a:4e
  • Reboot

sorry lleachii i think were not in sync. ok i got your point already, i set a password and i have managed to change the password via SSH. added option macadd xx:xx:xx:xx:xx:xx in /etc/config/network.

Now i flash again the firmware with meshdesk package. even if i do the option mac, when i reboot the router it does not save my previous configuration and the option mac i did is gone. Thanks

This option should have been there already, you show me a picture. All you needed to do was make it LOWERCASE.

Generally you should get a sensible factory MAC address without any configuration. Does your router do that with plain OpenWrt? MAC addresses should be changed only in rare situations since a factory MAC is guaranteed to be unique.

As I said before, MESHdesk is going to completely erase your /etc/config/network and put what it wants there every time it checks with the server.

1 Like

yes thats correct, i change it to lower case. everything was saved and applied. but the issue is when i reboot the router it seems that the config did not applied and it went back to defaults

Is the config erased upon reboot???

thank mk24, but the meshdesk server needs to know the mac of the node before you can move it to known nodes. is the meshdesk server is responsible of giving mac add to the node?

No. The node sends its MAC address to the server for identification purposes, since a factory MAC should be a number unique to each unit. If the administrator has registered that MAC address as one of his nodes, the server will send the corresponding configuration back to the node.

The whole philosophy is that other than the initial flash, it is not necessary to write anything to the node directly. The MESHdesk server is in control of the configuration.

this is what really happend in my case: i never edited anything in nodes etc/config/network. Server reads it as uknown node, but when i try to attach/transfer it to known nodes, my node reboot immediately. And once its up again the server will read the node again but with different MAC address.

The problem may be that as interfaces are added, new MACs are derived for them of the "locally administered" class. These can be recognized by the second digit of the first number (xX:xx:xx:xx:xx:xx) being either 2,6,A, or E. A factory MAC has bit 1 of that digit 0, in other words it will be 0,4,8, or C.

The MESHdesk script running on the router is supposed to be looking at eth0's MAC, which should not change.