Help configuring new ISP

Hi there, hopefully someone can help me.
I've just switched ISP and I can't get my TP-Link Archer C7 with OpenWRT to work.
The new ISP uses DHCP and VLAN, but their instructions are pretty lightweight (https://support.simplybroadband.co.nz/settings) - OpenWrt is quite a bit more powerful than off the shelf solutions and I'm out of my depth.
The ISP's instructions simply say to use DHCP and enable VLAN with VLAN ID 10. I found instructions for another ISP that has the same requirements (https://openwrt.org/docs/guide-user/network/wan/isp-configurations#slingshot_fibre) and tried to copy them, but wasn't sure which parts of my network config not to alter.
Currently Luci shows an error in Network Interfaces for wan and wan6, stating "Error: Network device is not present".
Below is my /etc/config/network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd41:e9a2:c5e2::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.2.1'

config interface 'wan'
        option proto 'dhcp'
        option device 'wan.10'
        option hostname '*'

config interface 'wan6'
        option proto 'dhcpv6'
        option device 'wan.10'
        option reqaddress 'try'
        option reqprefix 'auto'

config device
        option type '8021q'
        option ifname 'wan'
        option vid '10'
        option name 'wan.10'
        option mtu '1500'
        option ipv6 '1'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 2 3 4 5'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 1'
        option vid '2'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '0t 1t'
        option vid '10'

Any help appreciated.
Cheers
Wayne

should look something like this: VLAN tagging, and VLAN tag 10 on Openwrt 23.05.5 - #4 by brada4.

you can skip the MAC address override.

Am I missing something? Looks like it's the same to me:

Okay, I solved it. I don't even really remember how I got to the result, but the wan.10 device was the problem. Here's the updated config that is currently working:

config interface 'wan'
        option proto 'dhcp'
        option hostname '*'
        option device 'eth0.10'

config interface 'wan6'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix 'auto'
        option device 'eth0.10'

config device
        option name 'eth0.10'
        option type '8021q'
        option ifname 'eth0'
        option vid '10'
        option ipv6 '0'
1 Like

I'd have added the name of your ISP to the page you linked to earlier.

1 Like

Do you mean the ISP setup that was flawed? Or the ISP that I am using?

it seems pretty much identical to the Slingshot Fibre config, so I'll just point to that one.

That's the config that is broken. The interfaces point at the device, which point at the interfaces - it's an infinite loop.

I really can't see any difference except for eth0 vs wan ?

eth0 could be correct too, but then again, I'm not really VLAN savvy.

I believe that was the issue. "wan" was the name of the interface I was creating, which was connected to the device named "wan.10", which was connected to the interface named "wan"... you get the drift.
By creating a device that connected to an actual port (whatever the proper word is), and then connecting the interfaces to that device, it fixed it.

1 Like

The Archer C7 still uses the old swconfig system while most other platforms have been migrated to the DSA system.

wan.10 is correct for DSA. In swconfig you need to change three things:

  • Inside the switch (switch-vlan block) make the vlan number of the wan vlan 10 instead of the default 2.
  • Make the switch WAN port tagged instead of untagged.
  • Change the wan (and wan6 if ISP supports v6) device from eth0.2 to eth0.10.

In the GUI the first two steps are on the Network-Switch page and the last one is on Network-Interfaces; click Edit button on the wan one.

1 Like

thnx for the clarification, created two tabs, one for DSA, one for swconfig.

Thanks to both of you.
I have fumbled my way into making the VLAN Switch changes, but wasn't sure if I could delete/modify the existing VLAN2 so just left it. I've deleted it now.
As an aside, I disabled IPv6 purposely, but for completely unrelated reasons; so that part of my config isn't required (for anyone reading this in the future).
I see you have updated the ISP configuration page and it all looks perfect. Thanks for that (I will also let my ISP help desk know they can reference it for OpenWrt customers.
Thanks again.
Cheers
Wayne

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.