Help configuring LEDE/WRT1900ACS : IPV6 on WAN, IPV4 on LAN


I've shopped the questions at a few spots, but not coming up with anything.

I am bringing up a new WRT1900ACS with the davidc502 build, and have some ipv6 (wan) to ipv4 lan issues. Please feel free to redirect as I know is more of a ipv6 to ipv4 config issue, but since it is probably relative to whats included in the package, I'm starting here.

I am coming off a WNDR3700 running an older build of openwrt CC. My LAN is IPV4(and needs to stay that for now) , and I believe my CC build is still using 6relayd. With this config, The WAN gets both IPV6 and IPV4 addresses, connected to a bridged cable modem. The ISP is Comcast if that helps.

I know the stock LEDE build is using odhcpd. I've not configured/setup odhcpd before, and my ipv6 memory is fuzzy, as I set and forgot on the wndr.

Using the uci stock defaults for wan and wan6 config from the davidc502 build, the WRT1900ACS receives an IPV6 address (only) from Comcast on WAN6, but no IPV4 address, on WAN. And maybe thats by design, intending to default to native.

And at the router, using diags I can ping over wan, traceroute wan using ipv6. Obviously, not so much for IPV4, and my IPV4 clients on LAN cannot get out to WAN.

Apologies if its rudimentary, whats the right way to do this to get the IPV4 LAN clients working? I need to config and/or add dual stack pkg(s) , or other?


WAN IPv4: Did you restart your Comcast modem? If not, restart it first and check the WAN.

When I switch between routers, I need to restart the Modem in order to get IPv4 address (while WAN6 IPv6 is working). More interestingly, before you restart it, when you go to, it will only give you IPv6 test. Restart the modem (and wait for 5 mins to let the Modem initialized) for me helps.

Yeah, I should have noted that too. I rebooted/power cycled both the cablemodem and router multiple times. Both at same time, each individually etc.

And, comparing/contrasting against the wnd3700, it pretty much always gets both IPV4 and IPV6 when I reapply the wan cable, with a 'reconnect' at gui, or a reboot worst case. And granted, its different build, and different packages (6relayd versus odhcpd) etc.

A 6relayd and others have been deprecated, looking for the right way to do.

I have David's build at the very beginning without this problem. I switched over to standard and no problem as well. I no longer have the router with me, here is the general suggestion:

  1. Get LEDE RC-1. I tested it and work.

  2. Upgrade, Do not keep settings, start over fresh. This make sure everything is default

  3. After boot up, you should see no WAN WAN6 connection. Power off the Modem, then Power On. Just stay in the router LEDE Overview page, wait 5 mins. * Special configuration is not needed.

At this point I believe everything will be okay.

I am using a fresh install, and used all stock settings to start. I only added/changed what I specifically required with UCI command line changes.

I figured it out. I found an error buried in the system log for 'malformed hex for hostname' on the WAN interface. This was preventing WAN interface from starting. Looking in the configuration, I noticed a 'clientid' setting that I didn't specifically make via UCI. I was walking through the gui at different times during debug, and I think I may have accidentally done a 'save/apply' on the advanced settings in WAN interface, that may have added the entry. I deleted the clientid parameter via UCI; and the hostname field was auto populated properly.

Once I did that, WAN pulled an IPV4 and life was good.