Help cleaning up dependencies wpad/hostapd

Hi, this is likely a self-inflicted wound by installing hostapd/wpad and/or -openssl variants and I'd appreciate some help cleaning things up. Probably too much fiddling around and now I can't seem to install wpad nor wpad-openssl.

root@3965U:/# opkg list-installed | grep -e wpad -e hostapd
hostapd-common - 2023-09-08-e5ccbfc6-6
root@3965U:/# opkg install wpad-openssl
Installing wpad-openssl (2023-09-08-e5ccbfc6-6) to root...
Collected errors:
 * check_conflicts_for: The following packages conflict with wpad-openssl:
 * check_conflicts_for:         hostapd-openssl * check_conflicts_for:  wpad *
 * opkg_install_cmd: Cannot install package wpad-openssl.
root@3965U:/# opkg install wpad
Installing wpad (2023-09-08-e5ccbfc6-6) to root...
Collected errors:
 * check_conflicts_for: The following packages conflict with wpad:
 * check_conflicts_for:         hostapd-openssl *
 * opkg_install_cmd: Cannot install package wpad.
root@3965U:/# opkg remove hostapd-openssl
No packages removed.
root@3965U:/#

it looks like there's a hostapd-openssl dangling dependency conflict, even though it's not installed (anymore). Any ideas how to proceed from here?

thanks!

You can use the opkg force options to force the installation.
--force-depends and/or --force-overwrite if I remember right

1 Like

Should be quite easy to do package name adjustments in firmware-selector or ettendedsysupgrade luci....

force-depends did the trick, thanks!

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.