Help bricked my wrt32x

hi im a complete novice who has bricked his wrt32x i had ddwrt installed on it wanted to update as there was a newer version but update kept failing tried to revert back to stock and that kept failing also . at this point i wish i had just left it alone as was still working but stupidly i tried to flash the router to stock using putty ssh which is way above my skill level and seem to have bricked it now i bought a usb -ttl pl2303hax which windows told me was unsupported i managed to install an old driver and get it to work so i was hoping to copy venom.img using putty serial and tftp but when i turn on router it posts but i dont get a promt to communicate with it the power light is flashing and the ethernet port is also on i know i should of left well alone but now just want to get it working not even really bothered what firmware it is on .
here is what the router say when started

BootROM - 1.73
Booting from NAND flash

General initialization - Version: 1.0.0
AVS selection from EFUSE disabled (Skip reading EFUSE values)
mvSysEnvIsFlavourReduced: TWSI Read of 'flavor' failed
Detected Device ID 6820
High speed PHY - Version: 2.0

Init RD NAS topology Serdes Lane 3 is USB3
Serdes Lane 4 is SGMII
board SerDes lanes topology details:
 | Lane # | Speed|    Type     |
 |   0    |  6   |  SATA0      |
 |   1    |  5   |  PCIe0      |
 |   2    |  6   |  SATA1      |
 |   3    |  5   |  USB3 HOST1 |
 |   4    |  5   |  PCIe1      |
 |   5    |  0   |  SGMII2     |
:** Link is Gen1, check the EP capability
PCIe, Idx 0: Link upgraded to Gen2 based on client cpabilities
:** Link is Gen1, check the EP capability
PCIe, Idx 1: remains Gen1
High speed PHY - Ended Successfully
DDR3 Training Sequence - Ver TIP-1.46.0
mvSysEnvGetTopologyUpdateInfo: TWSI Read failed
DDR3 Training Sequence - Switching XBAR Window to FastPath Window
DDR3 Training Sequence - Ended Successfully
Not detected suspend to RAM indication
BootROM: Image checksum verification PASSED

U-Boot 2013.01 (May 18 2017 - 16:37:44) Marvell version: 2015_T1.QA.0p16

Boot version : v2.0.9

Board: RD-NAS-88F6820-DDR3
SoC:   MV88F6820 Rev A0
       running 2 CPUs
CPU:   ARM Cortex A9 MPCore (Rev 1) LE
       CPU 0
       CPU    @ 1866 [MHz]
       L2     @ 933 [MHz]
       TClock @ 200 [MHz]
       DDR3    @ 933 [MHz]
       DDR3 32 Bit Width,FastPath Memory Access, DLB Enabled, ECC Disabled
DRAM:  512 MiB
NAND:  256 MiB
MMC:   mv_sdh: 0

you could use the recovery boot loader.

The unit have two FWs, check if you can recover using the secondary fw.

1 Like

corrupt bootloader?

thanks for advise tried swapping firmware but not happening think uboot is corrupt

It looks as if Uboot shops before attempting to boot. According to the device's wiki pages you should be able to uart boot it to recover.

The description there seems to indicate that you need to time sending the uart boot with the power on of the router.

thanks for your help i have an old laptop i have put linux mint on to try and replace uboot but not a clue what im doing really

Another option could be to run Ubuntu under WSL. It should give you access to the serial ports. (If you got your dongle working on Windows you won't need to get it working under Linux as well.