HELP! Bricked Mikrotik BaseBox 2 - how to boot from USB?

I've been using Mikrotik BaseBoxes running for a while with no problems. But... Now I'm down to just one BaseBox. I make some changes to the wifi and now I can't get into it. Not through the ethernet port and the wifi doesn't show up at all, so I'm guessing the network config is hosed.

I've tried failsafe, but while the LEDs blink during the boot process it does not enter failsafe when I press the reset button.

I've tried TCPDump and it never requests a boot image via TFTP. So I'm down to building a boot image on a usb. How do I put an Openwrt boot image on a bootable USB?

Progress of sorts. I can send a boot file to the router. Any suggestions on what file to send? I've tried a few - vmlinux-initramfs.bin|elf but the router does not appear to be executing them. What can I send to get some sort of system up and running? It's a ar71xx system.

Did you try this?;
https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset

Alternate for expert users: Wait (with a packet sniffer) for a special broadcast packet and press a button. The packet will be sent to destination address 192.168.1.255 port UDP 4919. The packet contains the text “ Please press button now to enter failsafe ”. So for example, in a terminal and using tcpdump, with the router connected to port eth0, you would enter the command

tcpdump -Ani eth0 port 4919 and udp

Tried that. No packet shows up.

Here's the upload log. The file uploads but the box never responds to pings at 192.168.1.1

root@HotMess:/home/yan/Downloads# dnsmasq -i enp0s25 --dhcp-range=192.168.1.100,192.168.1.200 --dhcp-boot=openwrt-ar71xx-nand-vmlinux-initramfs.elf--enable-tftp --tftp-root=/srv/tftp/ -d -p0 -K --log-dhcp --bootp-dynamic
dnsmasq: started, version 2.79 DNS disabled
dnsmasq: compile time options: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TFTP conntrack ipset auth DNSSEC loop-detect inotify
dnsmasq-dhcp: DHCP, IP range 192.168.1.100 -- 192.168.1.120, lease time 12h
dnsmasq-dhcp: DHCP, IP range 192.168.1.100 -- 192.168.1.200, lease time 1h
dnsmasq-dhcp: DHCP, sockets bound exclusively to interface enp0s25
dnsmasq-tftp: TFTP root is /srv/tftp 
dnsmasq-dhcp: 3379635104 available DHCP range: 192.168.1.100 -- 192.168.1.200
dnsmasq-dhcp: 3379635104 available DHCP range: 192.168.1.100 -- 192.168.1.120
dnsmasq-dhcp: 3379635104 vendor class: Flashboot
dnsmasq-dhcp: 3379635104 tags: bootp, known, enp0s25
dnsmasq-dhcp: 3379635104 BOOTP(enp0s25) 192.168.1.99 4c:5e:0c:35:1c:5e 
dnsmasq-dhcp: 3379635104 bootfile name: openwrt-ar71xx-nand-vmlinux-initramfs.elf
dnsmasq-dhcp: 3379635104 next server: 192.168.1.6
dnsmasq-dhcp: 3379635104 sent size:  4 option:  1 netmask  255.255.255.0
dnsmasq-dhcp: 3379635104 sent size:  4 option: 28 broadcast  192.168.1.255
dnsmasq-dhcp: 3379635104 sent size:  4 option:  3 router  192.168.1.6
dnsmasq-tftp: sent /srv/tftp/openwrt-ar71xx-nand-vmlinux-initramfs.elf to 192.168.1.99

Without a console or printenv ( or similar ) it's difficult to know whats going on. You might research that functionality in general to see how it works when it works....

Assuming it fails to "execute" ... not sure why nand is in the name ( installer image is it preconfigured somehow? ) then to perform remote magic you'd need boot.txt / scr support already... or console access... or a second stage loader like syslinux.0 .....

So 1 find out how that feature works normally.... check if there is any boot.env/scr support.... check if a non nand initramfs exists, try for console.... and finally if none of them work readup on syslinux or equivalent loaders for your architecture......

Dont know that device though, good chance there is a stupidly simple fix im not aware of......

Yeah. I did this once before on this device and the fix was stupidly easy - so easy that I forgot what it is..... Argh....

I've tried various versions of initramfs files from AA to 18.06.2 and all of them behave the same way - dnsmasq tells me the file uploaded, the device boots, but never shows up on the network and can't be pinged.

I'm gonna have to find a windows machine and try to install the original RouterOS. Sigh.

Well turns out the board was dying. The fix was to get a new router. Sigh.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.