Help --> A problem with [stubby Dns over TSL dnsmasq]

Hello dear people, I do not get internet connection with the settings.

Where is the mistake? Who can help me?

/etc/stubby/stubby.yml
---> /etc/config/stubby ---> option manual '1'

# Note: by default on OpenWRT stubby configuration is handled via
# the UCI system and the file /etc/config/stubby. If you want to
# use this file to configure stubby, then set "option manual '1'"
# in /etc/config/stubby.
resolution_type: GETDNS_RESOLUTION_STUB
dnssec: GETDNS_EXTENSION_TRUE
dnssec_return_status: GETDNS_EXTENSION_TRUE
round_robin_upstreams: 1
appdata_dir: "/var/lib/stubby"
tls_ca_file: "/etc/ssl/certs/ca-certificates.crt"
tls_authentication: GETDNS_AUTHENTICATION_REQUIRED
tls_query_padding_blocksize: 128
edns_client_subnet_private: 1
idle_timeout: 10000
listen_addresses:
  - 127.0.0.1@5453
  - 0::1@5453
dns_transport_list:
  - GETDNS_TRANSPORT_TLS
upstream_recursive_servers:
  - address_data: 2606:4700:4700::1111
    tls_auth_name: "cloudflare-dns.com"
  - address_data: 2606:4700:4700::1001
    tls_auth_name: "cloudflare-dns.com"
  - address_data: 1.1.1.1
    tls_auth_name: "cloudflare-dns.com"
  - address_data: 1.0.0.1
    tls_auth_name: "cloudflare-dns.com"

/etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option nonwildcard '1'
	option localservice '1'
	option cachesize '1000'
	option noresolv '1'
	option dnssec '1'
	option dnsseccheckunsigned '1'
	option proxydnssec '1'
	list server '127.0.0.1#5453'
	list server '0::1#5453'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd49:2fe1:e873::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '00:ad:24:4e:36:20'

config interface 'wan'
	option proto 'dhcp'
	option peerdns '0'
	option dns '127.0.0.1'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr '00:ad:24:4e:36:22'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'
	option peerdns '0'
	option reqprefix 'auto'
	option reqaddress 'try'
	list dns '0::1'
	list dns '127.0.0.1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 0t'

config interface 'wwan'
	option proto 'dhcp'

config interface 'wwan2'
	option proto 'dhcp'

config interface 'wwan3'
	option proto 'dhcp'

config interface 'wwan4'
	option proto 'dhcp'

config interface 'wwan5'
	option proto 'dhcp'

config interface 'wwan6'
	option proto 'dhcp'
root@OpenWrt:~# netstat -lnpt | grep -E '^Active|^Proto|/stubby'
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 127.0.0.1:5453          0.0.0.0:*               LISTEN      9726/stubby
tcp        0      0 ::1:5453                :::*                    LISTEN      9726/stubby
root@OpenWrt:~# netstat -lnptu | grep stubby
tcp        0      0 127.0.0.1:5453          0.0.0.0:*               LISTEN      9726/stubby
tcp        0      0 ::1:5453                :::*                    LISTEN      9726/stubby
udp        0      0 127.0.0.1:5453          0.0.0.0:*                           9726/stubby
udp        0      0 ::1:5453                :::*                                9726/stubby

You can use a working how-to with no need to make it complicated:
https://openwrt.org/docs/guide-user/services/dns/dot_dnsmasq_stubby

1 Like