Help: 2 external WiFi sticks detected as one

I have 2 Realtek WiFi sticks. I want to use one as input, the other as output and the lan as output. The setup works with 1 usb. I can access the WiFi over lan and the usb is connected to the WiFi. It’s getting confusing when I plug in the second usb. Ifconfig wlan1 up does not work. I can unplug the first WiFi usb and plugin the other WiFi usb and it works fine. It only detects wlan0 even if both usbs are plugged in. Any idea how I can set up both sticks separately?

Check this:

ls -l /sys/class/net
lsusb -v -v -t

Also try using an externally powered USB hub.

I ran the command and got as a result br-lan, eth0,lo, phy0-sta0
Phy0-sta0 seems to be the WiFi with the path ../../devices/platform/soc/3f3000000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1/net/phy-sta0.

Sadly I don’t have an external powered usb dock laying around. Any other ideas?

devices/platform/soc/3f3000000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:2 exists as a directory but does not have the net folder

Are there two radios (wifi-device) with different USB paths in your /etc/config/wireless?

When using USB radios keep them plugged into the exact same physical USB ports on the machine. Plugging into a different port will be detected as a new/different radio.

If you erase /etc/config/wireless then reboot with both USB radios plugged in, you should get a default configuration with two radios. If that does not work it likely is a hardware issue such as lack of power.

Nope. That’s the problem. I tried to write it manually with :2 as ending, but the devices will be detected as generic unknown and not work ofcourse

Check dmesg - if there are oddball USB disconnects that are NOT when you unplugged a device, you've got a power problem.

You don't say exactly which realtek USB stick you're using (first red flag, lots of realtek adapters have absolutely shitty Linux support), and what your host device is.

For example, I can tell you that a GL-MT3000 with the stock power adapter doesn't have enough power budget to handle even a single MT7921U adapter without external power injection. ( GL-MT3000 (MT7981) USB host reliability - #2 by Entropy512 for more detail on that one)

This is why people are suggesting trying an external powered USB hub - if the problems disappear when you use it, you almost surely have a power problem.

I am using a raspberry pi 3b and this WiFi stick Maxesla USB WLAN Stick for PC, 1300 Mbps USB 3.0 WLAN Adapter PC 2.4 GHz / 5 GHz WLAN USB Stick with 5 dBi Dual Band High Gain for PC/Desktop/Tablet/Laptop, Compatible with Windows 10/8/7/Vista/XP, Mac OS X

It's not a support issue bc they are both working on their own

I found the issue. It's not power management but the serial number on both is 123456. any idea how to fix that or distinguish the stick by product and serial number. The names are slightly different

I just buy a new WiFi antenna

After I saw your previous post this was my first response - if the manufacturer didn't bother to set a unique serial number, you should avoid that manufacturer like the plague that they are, and leave a negative 1-star review for not even doing the bare minimum to manufacture a USB device properly.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.