Having trouble after install of OPENWRT on WNDR4500V3 netgear

The instructions are not clear at the official page https://openwrt.org/toh/netgear/wndr4500_v3 to install for example how to even SSH in the 1st place. My first time with this router and I am trying to set it up with open WRT. Anyway after some research I was able to finish the requirements and after installing .bin file on the router I am getting syntax errors up top? Below it, something tries to load and never does. I believe this is the overview page. I so far only have my computer connected to the router with no wan. I tried doing a hard reset by holding the tiny button for 10 seconds. Tried pulling out the power and turning it back on. Tried to give it a wan connection, but it won't be able to acces internet on my netgear mr1100 modem yet because it would need to get confirgured. However still the syntax errors appear at the top? How do I get this working? I saw the official firmware went from 1.0.0.32 to the .58 one before doing the procedure to install openWRT firmware. The netgear firmware looks pretty intuitive and feature rich, but I went straight to installing openwrt thinking it must be better so far I am stuck and it doesn't work? Any help would be appreciated.

As a start, please post the exact error messages that you're seeing. Then:

  • Has your computer received an IP address from the OpenWrt box?
  • Can you ping 192.168.1.1?
  • Can you SSH to the box?
2 Likes

And what file did you install(exact filename, please)? What method did you use?

1 Like

Hi I am getting this, but i deleted the end piece of those error lines not sure if it's safe to share that or not.
Syntax error
in http://192.168.1.1/luci-static/resources/view/status/include/29_ports.js?v= at Anonymous function (http://192.168.1.1/luci-static/resources/luci.js?v=git- at Anonymous function (http://192.168.1.1/luci-static/resources/promis.min.js?v=git at m (http://192.168.1.1/luci-static/resources/promis.min.js?v=git-

Yes I can ping 192.168.1.1 just fine. I didnt see what IP address the DHCP provided to my computer, but if I can enter the controls I am assuming I got an IP. I SSH just fine which is why I made it this far. I had to SSH to install the sysupgrade.bin file.

I used the instructions I found on this site. The official instructions not clear so I got assistance from other instructions on the forums. AFter having netgear firmware 1.0.0.58 I used that firmware to install "openwrt-23.05.0-ath79-nand-netgear_wndr4500-v3-squashfs-factory.img". Then when that was complete I did the SCP command to put the file in the /tmp folder of router to install the "openwrt-23.05.0-ath79-nand-netgear_wndr4500-v3-squashfs-sysupgrade.bin" file when I SSH next into it. The common instruction is to use wget but that is aweful that requires internet that I won't have access to. I already had the bin file on my computer that I got from the official instruction to install at: https://openwrt.org/toh/netgear/wndr4500_v3#installation
which why I say the official instructions are bad.

Can you be more specific about this?

Did you successfully upgrade from the vendor firmware to OpenWrt using the web interface? Why did you then install the sysupgrade file? And what commands did you run (exact commands)?

Yes I followed the instructions https://openwrt.org/toh/netgear/wndr4500_v3#installation. It says to use the bin upgrade file after the img file to finish installing the openwrt. The page says that you have to do that to avoid bricking the router after you power down the router. Therefore it is an essential step.

Yes I did successfully install the openwrt img file using the official netgear firmware I thought I made that clear in past posts. The final command after ssh into router was:

sysupgrade -v /tmp/openwrt-23.05.0-ath79-nand-netgear_wndr4500-v3-squashfs-sysupgrade.bin

before that:

scp openwrt-23.05.0-ath79-nand-netgear_wndr4500-v3-squashfs-sysupgrade.bin root@192.168.1.1:/tmp

Why isn't this straightforward I feared this would be difficult when it shouldn't be.