Having issues opening ftp on wan

I have been trying to access my ftp server from wan port without much luck
using vsftp
currently the error i get is:

Disconnected from server
Connection failed.
OOPS: priv_sock_get_result

I installed Package name kmod-nf-nathelper today after seeing other post on here but still no luck

PORT mode or PASV mode?

im not sure is that a vsftp configuration?

here is that config (vsftp.conf)


Since you have vsftpd running on the nat box, you only need the firewall traffic rule. Get rid of the port forward and nat rules. Also, ftp uses tcp only; get rid of allowing udp.

1 Like

i have made those changes but still same error

Sorry, I forgot, add seccomp_sandbox=NO to your vsftpd configuration.

Also, make sure you have a strong password on that ftp server. Since you're exposing it to the public internet, it's only a matter of time before botnets find it, possibly in as little as a few minutes.

You may also want to consider using port knocking for protection by installing luci-app-fwknopd so that your ftp server can't just be accessed by anyone.

1 Like

It's rather a client option/choice.

Does the ftp work from inside you LAN?

yes it does

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.