Have I bricked my Archer C20 v1?

Tried installing in openwrt in my Archer C20 V1. Instead of installing firmware, I had installed a snapshot. Then tried installing the full firmware again. Not sure what happened but now only the USB LED glows when I switch on the router and goes off. How do I recover it? My router is EU version V1. https://openwrt.org/toh/hwdata/tp-link/tp-link_archer_c20_ac750_v1

A "snapshot" is a firmware, just one that has not been deemed as "stable". However, snapshots do not have a nice graphical interface, you can install it yourself, or you can just install a release version.

Yes. I got that by reading few other posts but when I tried to reinstall the firmware from openwrt, somehow it got stuck and doesn't respond anymore. Hope can I check if my router can be recovered? Tried the official method of setting static IP to upload the recovery in web page but unable to do so

Which instructions exactly have you followed?

The instructions in official page weren't clear enough for me. https://openwrt.org/toh/tp-link/tp-link_archer_c20_v1

Followed the instructions from here without using UART but flashed the snapshot instead of full firmware.

On top of that, tried to overwrite that with the official firmware instead of looking for other options. Not sure about the recovery options. I will solder pins to access serial port.