Hang on Raspberry Pi

Installing on Raspberry Pi 5. Interface working can SSH in an such. But any attempt to change WiFi SSID or encryption status cause a hang. The Save button just spins. Reloading the page and there is no change. I can see the default WiFI on my phone and connect to it. I just cannot change the settings.

How are you making the change? Are you connected by wifi or ethernet?

I'm making the change through the web interface through ethernet.

Since this is a Raspberry Pi 5 I have to install via snapshot. That dosen't have Luci. So I manually added my IP, gateway and DNS to /etc/config/network. I installed Luci then removed my manual edits other than IP address. I then resetup the network through Luci.

It's still hanging and the only thing I try to change from defaults is the SSID. The only thing I modify from defaults is SSID. It just circles on Save.

I can reload the page and everything is working. But nothing changes.

Let's take a look at the details:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
mount
df -h
# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd6:5d3:8eda::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '10.0.2.99'
        option netmask '255.255.255.0'
        option ip6assign '60'
        list dns '8.8.8.8'
        list dns '8.8.4.4'
        option gateway '10.0.2.15'

# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/axi/1001100000.mmc/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option band '5g'
        option channel '36'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

So I'm not going to bother with dhcp or firewall at this point. This is just attached to my LAN so I can configure it. Eventually is will become the main house router.

I hope you don't plan to use it for wifi.

Based on what you posted, I don't really see any issues that would cause the problem you're describing -- can you manually set the encryption and passphrase if you edit the config file? You might also try using auto channel and 40MHz channel width.

Setting to 40 mhz width alone - same problem
Setting to 20 mhz width alone - same problem
Setting encryption on without changing SSID - same problem

Would a screenshot of the wireless setup page help?

have you tried doing this via the text file?

Also, what is the output of:

mount
df -h

No I have not yet tried manually editing /etc/config/wireless. I wouldn't know how to input the encryption settings anyway.

root@Rasp5:~# mount
/dev/root on / type ext4 (rw,noatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
cgroup2 on /sys/fs/cgroup type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
/dev/mmcblk0p1 on /boot type vfat (rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
tmpfs on /dev type tmpfs (rw,nosuid,noexec,noatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,noatime,mode=600,ptmxmode=000)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,noatime)
bpffs on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,noatime,mode=700)
root@Rasp5:~# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                98.3M     22.9M     73.4M  24% /
tmpfs                     2.0G    188.0K      2.0G   0% /tmp
/dev/mmcblk0p1           63.9M     15.0M     48.8M  24% /boot
tmpfs                

Sounds like this is unsolvable and I should just try a future snapshot.

It can have LuCI but I'm not sure if its opk or apk...

Well what I need is an image that I can transfer to the micro sd card with Rufus.

Goal posts are moving and its confusing.
Now you are having trouble flashing the card with Rufus? After you reflash, attempting to flush and start over, you still have persistent settings?

If so you can try using firstboot -y && reboot or you can flash the SD card to Pi OS and then flash it with OpenWrt.
RPis can be difficult to erase one of the partitions when re-flashing; I don't know about the 5.

No the image downloaded flashes just fine in Rufus and the system boots. It's the wifi settings screen in Luci that is failing.

So, you have tried to clear all settings by reflashing but changing wifi settings will not take effect and if rebooted the same wifi settings persist?

Humor me:
Flash the sd card to Pi OS. Just use the full install.
Then flash OpenWrt (no need to even boot to Pi OS) and see if you have control of everything.

This is a virtually destructive way to completely repartition all partitions then set them to a true fresh OpenWrt install.
Firstboot usually works but let's just go full Pi on it.

I'm going to need more detailed instructions to do what you say. I have no idea how to "flash" OpenWrt on a base linux installation.

What I am doing is downloading the ext4 factory image from:
https://firmware-selector.openwrt.org/?version=SNAPSHOT&target=bcm27xx%2Fbcm2712&id=rpi-5

Then I flash that image to a micro sd card and it boots just fine from there. I have to SSH in to manually change the network settings to allow me to add Luci. From there I'm trying to do everythink in Luci and that's where I have this problem.

Ummm,

Flashing different Linux distros on Raspberry Pis is usually among the first things learned. Its kind of the whole community thing.

How did you flash your Pi to OpenWrt?

Did you edit that in or did I miss, all, that?

Okay:
The goal is to ensure the card is, truly, wiped. Pis have a tendency to hold on to old settings (which manifests in the inability to change settings) so there are a couple ways to 'fix' it:

  1. firstboot.(almost always works)

  2. write a different distro to the card and then write a new flash of OpenWrt. (always works)

Like I said I downloaded a snapshot from here and used Rufus to copy it to a micro USB. Booted on the Pi5 just fine.

Do you see a pattern?