Hail Mary Recovery of TP-LINK ARCHER C7 V4

This is not a question as much as a success story .
I have been running openwrt on my TP-Link Archer C7 v4 for some years now but started wondering about performance . I never tested the stock firmware so I decided to try . Here is the sequence of events:

  1. use tftp to revert to factory firmware . This worked 1st time with no complaints.
  2. test factory firmware and while the performance was good it is lacking in other features
  3. install dd-wrt . This worked with no complaints .
  4. test dd-wrt . Did not like the results so decided to go back to factory firmware

Here is where the wheels came off . Even though I was using the same host , same tftp software and same factory firmware (renamed to ArcherC7v4_tp_recovery.bin) I could not get tftp to install the firmware. The log showed that the router 'requested read of ArcherC7v4_tp_recovery.bin' but that is as far as it got . It just sat there and stared at me and I could no longer connect to it.
After 2 hours of trying I was convinced I was going to have to buy a new router . So then I said , what the heck it cant get any worse so I copied 'openwrt-19.07.3-ath79-generic-tplink_archer-c7-v4-squashfs-factory.bin' as ArcherC7v4_tp_recovery.bin into the tftp directory and then pushed the buttons.

It worked . Even the blind pig finds a truffle now and then