GWF-3S03 chipset Ralink RT5370

Comrades, good afternoon.
Please tell me what driver you need to install in order for the wi-fi adapter to work on the Ralink RT5370 chipset? System Snapshot of OpenWrt for Raspberry Pi 4B
Thank you very much!

2 Likes

You correctly noticed everything, thank you for the information.
But I didn't create the theme with ease, since I already installed it using the command:

opkg install kmod-rt2800-lib kmod-rt2800-usb kmod-rt2x00-lib kmod-rt2x00-usb

But the result is no, the Wi-Fi adapter does not work :frowning:
What else is required, I cannot understand. Thanks.
I also connected the adapter to a Kali Linux machine. Loaded modules match
2020-05-08_13-31-13

Maybe you're missing the general wi-fi support?
Check/install kmod-mac80211 kmod-cfg80211 iw wireless-tools wpad
Please refer to https://openwrt.org/docs/guide-user/network/wifi/wireless.overview

kmod-mac80211 kmod-cfg80211 packages were already installed.
To install iw wireless-tools wpad appears:

Collected errors:
 * check_data_file_clashes: Package wpad wants to install file /usr/sbin/hostapd
        But that file is already provided by package  * wpad-basic
 * check_data_file_clashes: Package wpad wants to install file /usr/sbin/wpa_supplicant
        But that file is already provided by package  * wpad-basic
 * check_data_file_clashes: Package wpad wants to install file /usr/sbin/wpad
        But that file is already provided by package  * wpad-basic
 * opkg_install_cmd: Cannot install package wpad.

But I don't think it has anything to do with it.
There is also a Wi-Fi adapter Atheros AR9271, after installing the drivers:

opkg install kmod-ath9k-htc

everything works perfectly, no problems.

rt2800-usb-firmware ?

root@OpenWrt:~# opkg install rt2800-usb-firmware
Package rt2800-usb-firmware (20200122-1) installed in root is up to date.

Have you seen this?

Wireless Country Code Issue

The Country Code under Wireless in OpenWrt does not work, and you do need to set/change the country code in the latest Raspbian, and then you can go back to OpenWrt; the new country code will be used. Starting with Raspberry Pi 3 B+, the on-board wireless won't even start if there is no country code (set in Raspbian)

1 Like

Yes, I've read this, but I'm not sure that it concerns me, my internal Wi-Fi adapter works fine, without any additional settings, and other adapters also work, such as MediaTek MT7601U, and the one I mentioned above...

OK, then please elaborate on Wi-Fi adapter does not work
Show the relevant part of your log, show your wireless configuration, etc.

One stupid idea. Your adapter usb vid&pid simple absent in driver code. Show output of lsusb command or just check usb id.


root@OpenWrt:~# lsusb
Bus 001 Device 003: ID 1c4f:0002 SiGma Micro Keyboard TRACER Gamma Ivory
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Ok. Next step. Show dmesg output and content of /etc/config/wireless (w/o password :))


root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option htmode 'VHT80'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'wwan'
        option mode 'sta'
        option encryption 'psk2'
        option ssid 'TEST'
        option key '12345678'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb1/1-1/1-1.3/1-1.3:1.0'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'


root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb0:6049:a07a::/48'

config interface 'lan'
        option ifname 'eth0'
        option proto 'static'
        option delegate '0'
        option force_link '0'
        option ipaddr '192.168.1.20'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        list dns '192.168.1.1'

config interface 'wwan'
        option proto 'dhcp'

radio1 was detected but disabled by default. Is it your adapter? Remove

 option disabled '1'

or change to '0'

1 Like

Thank you for advice. But please forgive me, I gave You the wrong data, the radio 1 module is a different wi-fi adapter, not the one I need. I reinstalled the system and installed everything.


root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option htmode 'VHT80'
        option disabled '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
root@OpenWrt:~# lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

So the radio 1 module is not created in the configuration... maybe I should create it manually... or I don't understand something... can you tell me what to do next? how do I fix the problem? Thank you very much

another note, I didn't find any downloaded modules from the wi-fi adapter drivers:

brcmfmac              258048  0 
brcmutil               16384  1 brcmfmac
cfg80211              323584  2 brcmfmac,mac80211
compat                 16384  3 brcmfmac,mac80211,cfg80211
crc_ccitt              16384  1 ppp_async
ehci_hcd               53248  2 ehci_pci,ehci_platform
ehci_pci               16384  0 
ehci_platform          16384  0 
evdev                  24576  0 
fat                    69632  1 vfat
hid                   114688  2 usbhid,hid_generic
hid_generic            16384  0 
ip_tables              24576  4 iptable_nat,iptable_mangle,iptable_filter
ip6_tables             20480 24 ip6table_mangle,ip6table_filter
ip6t_REJECT            16384  2 
ip6table_filter        16384  1 
ip6table_mangle        16384  0 
ipt_MASQUERADE         16384  1 
ipt_REJECT             16384  2 
iptable_filter         16384  1 
iptable_mangle         16384  0 
iptable_nat            16384  1 
ledtrig_heartbeat      16384  0 
mac80211              565248  0 
nf_conntrack           98304 10 ipt_MASQUERADE,xt_state,xt_nat,xt_conntrack,xt_REDIRECT,xt_CT,nf_nat_ipv4,nf_nat,nf_flow_table,nf_conntrack_rtcache
nf_conntrack_rtcache   16384  0 
nf_defrag_ipv4         16384  1 nf_conntrack
nf_defrag_ipv6         16384  1 nf_conntrack
nf_flow_table          24576  2 xt_FLOWOFFLOAD,nf_flow_table_hw
nf_flow_table_hw       16384  1 
nf_log_common          16384  2 nf_log_ipv4,nf_log_ipv6
nf_log_ipv4            16384  0 
nf_log_ipv6            16384  0 
nf_nat                 28672  3 xt_nat,xt_REDIRECT,nf_nat_ipv4
nf_nat_ipv4            16384  2 iptable_nat,ipt_MASQUERADE
nf_reject_ipv4         16384  1 ipt_REJECT
nf_reject_ipv6         16384  1 ip6t_REJECT
nls_cp437              20480  1 
nls_iso8859_1          16384  1 
nls_utf8               16384  0 
ohci_hcd               40960  2 ohci_pci,ohci_platform
ohci_pci               16384  0 
ohci_platform          16384  0 
ppp_async              20480  0 
ppp_generic            40960  3 pppoe,ppp_async,pppox
pppoe                  20480  0 
pppox                  16384  1 pppoe
slhc                   16384  1 ppp_generic
snd                    65536  9 snd_bcm2835,snd_rawmidi,snd_seq_device,snd_pcm_oss,snd_pcm,snd_timer,snd_mixer_oss,snd_hwdep,snd_compress
snd_bcm2835            24576  0 
snd_compress           20480  0 
snd_hwdep              20480  0 
snd_mixer_oss          28672  1 snd_pcm_oss
snd_pcm                90112  3 snd_bcm2835,snd_pcm_oss,snd_pcm_dmaengine
snd_pcm_dmaengine      16384  0 
snd_pcm_oss            53248  0 
snd_rawmidi            32768  0 
snd_seq_device         16384  1 snd_rawmidi
snd_timer              28672  1 snd_pcm
soundcore              16384  1 snd
uhci_hcd               36864  0 
usbhid                 36864  0 
vfat                   20480  1 
x_tables               28672 24 ipt_MASQUERADE,xt_state,xt_nat,xt_conntrack,xt_REDIRECT,xt_FLOWOFFLOAD,xt_CT,ipt_REJECT,xt_time,xt_tcpudp,xt_multiport,xt_mark,xt_mac,xt_limit,xt_comment,xt_TCPMSS,xt_LOG,iptable_mangle,iptable_filter,ip_tables,ip6table_mangle,ip6table_filter,ip6_tables,ip6t_REJECT
xt_CT                  16384  0 
xt_FLOWOFFLOAD         16384  0 
xt_LOG                 16384  0 
xt_REDIRECT            16384  0 
xt_TCPMSS              16384  0 
xt_comment             16384107 
xt_conntrack           16384 12 
xt_limit               16384 20 
xt_mac                 16384  0 
xt_mark                16384  0 
xt_multiport           16384  0 
xt_nat                 16384  0 
xt_state               16384  0 
xt_tcpudp              16384  8 
xt_time                16384  0 

Friends, do you have any thoughts on this issue?

Unplug and replug the USB adapter then read the kernel log to see if any driver loaded.

Friends, thank you all very much for your advice and help. The problem was solved. The problem was my inattention and incompetence, I was installing the old version of snapshot, came across a new release, installed it, installed the drivers, the adapter started. Thank you all again