Guest WLAN and normal 2.4GHZ WLAN not working (neither)

Hi,
tried to setup a guest wlan following the openwrt guide.
Sure I did it mostly right... But then things failed.
First I could see my guest wlan on my iphone, but no Internet connection because of port rules.
Added them, but still the same issue.
Did a firewall restart, then a restart of the 2.4 ghz radio1.. Now the real issue starts!
I can only use 5ghz no matter what I try to restart and remove.
Wireless is not associated

My device is a linksys 1900acs v1 with davidc502 software installed.
Any clues on how to get my 2.4ghz back in the first place is really appreciated, I've removed the guest wlan for now. Might be a issue with the wifi driver?

EDIT: Router restart did the trick for my 2.4ghz network.
Back to the Guest WLAN troubleshooting :slight_smile:

EDIT 2: My phone and PC are trying to connect to my guest network now, but failing.
System logs says:

daemon.warn dnsmasq-dhcp[9888]: DHCP packet received on wlan1-1 which has no address

Post your config files here, please.

Network:

config interface 'guest'
        option proto 'static'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'


DHCP:

config dhcp 'guest'
        option interface 'guest'
        option start '100'
        option limit '150'
        option leasetime '3h'

Firewall:

config zone
        option name 'guest'
        option network 'guest'
        option output 'ACCEPT'
        option forward 'REJECT'
        option input 'REJECT'

config forwarding
        option src 'guest'
        option dest 'wan'

config rule
        option name 'GUEST Allow DNS'
        option src 'guest'
        option target 'ACCEPT'
        option proto 'tcp udp'
        option dest_port '53'

config rule
        option name 'GUEST Allow DHCP request'
        option src 'guest'
        option src_port '67-68'
        option dest_port '67-68'
        option proto 'udp'
        option target 'ACCEPT'

EDIT: also using dnscryptproxy but that shouldn't be a issue for my iphone getting a ip with dhcp for guest interface?

EDIT 2: compared with my LAN interface, and my guest interface didn't have any bridge to anything. Added bridge to my guest wifi controller (?) and now it does work!