Guest WLAN access on two devices

I have two OpenWrt devices, both using 21.02 and DSA. Device 1 setup as main router with Internet access and Device 2 connected to Device 1 by Ethernet and configured as a dumb AP. Device 1 has 4 LAN ports as follows:

LAN 1 = VLAN10
LAN 2 = VLAN20
LAN4 = (trunk port to Device 2 carrying the above 3 VLANs)

Device 2 also has 4 LAN ports with LAN 4 being used to connect to Device 1 (trunk port).

Both devices have WLANs configured and connected to the relevant VLANs on each device i.e. the WLAN network is defined as belonging to the corresponding VLAN network. Different subnets in use for each VLAN and DHCP server configured for each on Device 1 only. All of this works perfectly.

However, I also have Guest WLAN configured on Device 1 with Internet access only configured, no wired ports for Guests, all good.

My problem is I would like to also have Guest WLAN configured on Device 2 with fast roaming between the two devices. Device 1 and Device 2 are some distance apart hence why connected with Ethernet so don't really want a solution that relies on bridging WLAN over the air between the two devices, sooner connect the two over Ethernet somehow?. I'm seeking guidance on what possible solutions might fit the bill, have read about "relayd" and BATMAN a little but need some advice please, are these the right type of solutions or is there an easier way?

Also I could sacrifice a physical port on Device 2 and create a Guest VLAN and then bridge Guest WLAN to that bridge but I don't have any spare ports on Device 1 to allocate to Guest so not sure that helps? Thanks

Create a new vlan for guest, add it in the lan4 trunk, bridge it with the guest interface, and do the same on the second device.

Thanks, but that didn't work, not even on just Device1. Let me tell you what I did in case I've misinterpreted your instructions.....

Added another VLAN (40) in "devices" to my main bridge (br-home) device which has all 4 LAN ports added. This automatically created a 802.1q device called "br-home.40".

within my main bridge (br-home) configuration I added the new software VLAN to the bridge ports i.e. "br-home.40"

In the Bridge VLAN filtering configuartion I marked VLAN40 to be egress tagged on LAN4 and also to be egress untagged on br-home.40 itself (although I tried without this too). I then configured the GUEST interface to be associated with br-home.40

The WLAN set up for Guests was already associated in the wireless configuration with the GUEST interface.

My device could authenticate with the GUEST wireless network but couldn't get an address via DHCP. I also tried setting a static address and it still couldn't communicate.

When I look at the bridge ports in device config it says "absent interface : br-home.40"

In a nutshell, you should do it in the same way you did the others. The only difference is that you are not allocating any untagged port for vlan40.
If it still doesn't work, you can post the following to inspect.

Please run the following commands (copy-paste the whole block) and paste the output here, using the "Preformatted text </> " button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have

ubus call system board; \
uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru

Thanks very much, that worked a treat this time by just not allocating any untagged port for vlan40 :+1: :+1:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.