Hello,
Scenario : Main gateway 192.168.0.1 - LAN 192.168.0.x everything works fine. No VLAN. I need to create a couple of guest wlan interfaces with separate address (192.168.1.x) and that can't comunicate with main lan.
I follow guest wifi on dumb ap guide and triple check all steps. Assigned to new interface (Residenti) ip 192.168.1.1 and br-residenti (empty bridge). Leaved gateway empty on interface as described in guide.,
Now i have two more wifi.... but if i try to connect, it give's me ip address from dhcp desidered but no internet access.
Thanks for helping
network :
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd08:17b3:7fa7::/48'
config atm-bridge 'atm'
option vpi '1'
option vci '32'
option encaps 'llc'
option payload 'bridged'
option nameprefix 'dsl'
config dsl 'dsl'
option annex 'a'
option tone 'av'
option ds_snr_offset '0'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'
config device
option name 'lan1'
option macaddr 'c8:91:f9:4b:9e:3e'
config device
option name 'lan2'
option macaddr 'c8:91:f9:4b:9e:3e'
config device
option name 'lan3'
option macaddr 'c8:91:f9:4b:9e:3e'
config device
option name 'lan4'
option macaddr 'c8:91:f9:4b:9e:3e'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.0.3'
option netmask '255.255.255.0'
option ip6assign '60'
config device
option name 'dsl0'
option macaddr 'c8:91:f9:4b:9e:3f'
config device
option type 'bridge'
option name 'br-lanresidenti'
option bridge_empty '1'
option ipv6 '0'
config interface 'residenti'
option proto 'static'
option device 'br-lanresidenti'
list dns '8.8.8.8'
list ipaddr '192.168.1.1'
option broadcast '192.168.1.255'
wireless:
config wifi-device 'radio0'
option type 'mac80211'
option path 'pci0000:01/0000:01:00.0/0000:02:00.0'
option channel '36'
option band '5g'
option htmode 'VHT80'
option disabled '0'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'Serenario-5ghz'
option encryption 'psk2'
option disabled '0'
option key 'XXXXXXXXX'
config wifi-device 'radio1'
option type 'mac80211'
option path 'pci0000:00/0000:00:0e.0'
option channel 'auto'
option band '2g'
option htmode 'HT40'
option cell_density '0'
option txpower '20'
option country 'IT'
config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'Serenario'
option encryption 'psk-mixed'
option key 'XXXXXXXX'
config wifi-iface 'wifinet2'
option device 'radio1'
option mode 'ap'
option ssid 'Serenario-Residenti'
option encryption 'psk-mixed'
option key 'XXXXXXXXX'
option network 'residenti'
config wifi-iface 'wifinet3'
option device 'radio1'
option mode 'ap'
option ssid 'Serenario-CasaVacanze'
option encryption 'psk-mixed'
option key 'XXXXXXXXXXXX'
option network 'residenti'
dhcp:
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
option filter_aaaa '0'
option filter_a '0'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
list ra_flags 'managed-config'
list ra_flags 'other-config'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config dhcp 'residenti'
option interface 'residenti'
option start '100'
option limit '150'
option leasetime '12h'
option force '1'
firewall:
config defaults
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option synflood_protect '1'
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
list network 'lan'
config zone
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option name 'residenti'
list network 'residenti'
config rule
option name 'residenti-dhcp'
list proto 'udp'
option src 'residenti'
option dest_port '67-68'
option target 'ACCEPT'
config rule
option name 'residenti-dns'
option src 'residenti'
option dest_port '53'
option target 'ACCEPT'
config rule
option name 'bloccaresidenti_dalla_lan'
list proto 'all'
option src 'residenti'
option dest 'lan'
list dest_ip '192.168.0.0/24'
option target 'REJECT'
config forwarding
option src 'residenti'
option dest 'lan'