Guest SSID and Home SSID under radio1 Configuration Issue

Hello all,

I have been having trouble setting up a guest network on 2.4ghz to isolate untrusted clients from the LAN while keeping the regular network enabled as well (guest SSID and regular SSID under radio1).

I have tried all of the tutorials on the wiki but radio1 will not associate unless I remove the guest network. Does it have to do with having multiple SSID's under the same radio? I could be wrong, but it looks like the tutorials assume (1) SSID per radio.

Also with the guest interface, the wiki isn't clear on whether or not to set a device or keep it unspecified; do I set anything here?

Apologies if this has already been covered before, just couldn't find a clear method.

Thank you for your time.

I have guest WiFi on both 2.4 and 5 Ghz issues.

Decent video tutorial on setting up guest WiFi...

1 Like

Hi. I've used Tomato and DD-WRT and aspire to one day understand 1 or 2% of openwrt too. I am looking to isolate some devices on both radios. I tried the suggested video and just ended up editing an existing SSID, not creating an additional one. However, having reset the router and re-established the original network, I found . I scrolled down to Command-line Instructions, copied and pasted everything via Putty and ended up with an isolated 5Gh network. I know the same (edited) steps could be followed to configure a 2.4 network, but my brain is full. If you get it done for 2.4 would you let me know how you did it? I'll let you know if I do. Best of luck!

Hello.. if you want to connect to the 2.4ghz radio just change the 0 to a 1 in this line: WIFI_DEV="$(uci get wireless.@wifi-iface[1].device)

Finally found a solution to my issue (probably device specific but others may be affected) from this bug report: FS#3904 - Adding another SSID to a radio prevents the interface from starting due to duplicate BSSID

Just needed to write in a different macaddr (just used my main SSID address with the last number changed) for the guest network portion in /etc/config/wireless with option macaddr *insert different address here*

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.