Guest network problem

There seems to be something missing from my attempt to create a guest wireless network. My LAN is 192.168.2.0/24 and my guest should be 192.168.3.0/24. Looks like there's some sort of DHCP issue as clients can't connect to ESSID 'chinahouse' but i can supply info as needed. Firstly here are some config files.
TIA
etc/config/network


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd15:93aa:3d35::/48'

config atm-bridge 'atm'
	option vpi '1'
	option vci '32'
	option encaps 'llc'
	option payload 'bridged'
	option nameprefix 'dsl'

config dsl 'dsl'
	option annex 'a'
	option tone 'av'
	option ds_snr_offset '0'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.2.1'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr '40:f2:01:48:99:d4'

config interface 'wan'
	option proto 'pppoa'
	option encaps 'vc'
	option atmdev '0'
	option vci '38'
	option vpi '0'
	option username 'bthomehub@btbroadband.com'
	option password 'BT'
	option ipv6 'auto'
	option peerdns '0'
	option dns '208.67.222.222 8.8.8.8'

config device 'wan_dev'
	option name 'dsl0'
	option macaddr '40:f2:01:48:99:d5'

config interface 'wan6'
	option ifname '@wan'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '5 6t'

config interface 'CHGuest'
	option proto 'static'
	option ifname '@wan'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'
	option type 'bridge'


/etc/config/wireless


config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:01/0000:01:00.0/0000:02:00.0'
	option htmode 'VHT80'
	option country 'GB'
	option legacy_rates '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'OpenWrt5g'
	option network 'lan'
	option encryption 'psk2'
	option key 'xxxxxxxxxx'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:0e.0'
	option htmode 'HT20'
	option disabled '0'
	option country 'GB'
	option legacy_rates '1'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'psk2'
	option key 'xxxxxxxxxx'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-iface
	option device 'radio0'
	option mode 'ap'
	option network 'CHGuest'
	option key 'xxxxxxxx'
	option ssid 'chinahouse'
	option encryption 'none'


/etc/config/dhcp


config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option local '/home/'
	option domain 'home'
	option serversfile '/tmp/adb_list.overall'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'
	option ra_management '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config domain
	option name 'nucsrv.home'
	option ip '192.168.2.144'

config domain

config host
	option name 'nucsrv.home'
	option dns '1'
	option ip '192.168.2.144'
	option mac 'C0:3F:D5:64:4B:23'

config host
	option name 't410.home'
	option dns '1'
	option mac '58:94:6B:9A:03:84'
	option ip '192.168.2.206'

config dhcp 'languest'
	option start '100'
	option leasetime '12h'
	option limit '150'
	option interface 'languest'

config dhcp 'CHGuest'
	option start '100'
	option leasetime '12h'
	option limit '150'
	option interface 'CHGuest'


I haven't done this since I started using LEDE a few years ago (am migrated over to OW). Someone more knowledgeable may reply. I am posting to see if you found this wiki page that might be helpful.

2 Likes

Have you bridged the guest network with the WAN interface!?

1 Like

Thanks for the reply.
Well i was following a tutorial that said assign it to the WAN firewall zone. I thought that might bridge it 'automatically'. As it happens, WAN is not in the drop down.
Wireless Network: Master "chinahouse" (CHGuest)
is though.

I do not know why tutorial you where following, but you must not bridge the guest network to WAN, or even put then on the same firewall zone.

I would follow the "official" guide, as pointed out by @darksky.

2 Likes

Thanks folks. i'll check it out