Gretap + bridge is not working

I am trying to replicate ruckus style capwap/gre tunnel system where APs send all client traffic over gre tunnel back to central server. I cant get the bridge or gretap to come up on the openwrt side. In Luci it does not give me option to add wireless interface to br-wifi most likely due to it not being up.
Here is my test setup
AP side is eap615-wall running 22.03.0-rc6.
/etc/config/network

config interface 'tap'
        option proto 'gretap'
        option ipaddr '10.1.0.155'
        option peeraddr '10.1.0.162'
        option tunlink 'backbone'
        option mtu '1500'
        option type 'bridge'
        option force_link '1'
config device 'device2'
        option name 'br-wifi'
        list ports 'gre4t-tap'
        option type 'bridge'
        option bridge_empty '1'

brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.3460f997134c       no              wlan0-1
                                                        lan2
                                                        wlan0
                                                        lan0
                                                        lan3
                                                        wlan1
                                                        lan1

server side is Ubuntu 20.04
setup with

ip link add tun1 type gretap remote 10.1.0.155 local 10.1.0.162 dev enp1s0
ip link set tun1 up

side note how can this be fixed
image
I have gre, kmod-gre, and luci-proto-gre installed.

Interface level bridge declarations are deprecated and not supported anymore.
Try this:

config interface 'tap'
        option proto 'gretap'
        option ipaddr '10.1.0.155'
        option peeraddr '10.1.0.162'
        option tunlink 'backbone'
        option mtu '1500'
        option force_link '1'

config device
        option name 'br-wifi'
        list ports 'gre4t-tap'
        option type 'bridge'
        option bridge_empty '1'

config interface tapbr
       option proto none
       option device br-wifi

Then select tapbr as network for the wifi SSID.

@jow Thanks for the help so far, I am making progress I got the tunnel up and traffic is passing but it is not stable, I think it has something to do with the errors below. addr:34:60:f9:97:xx:xx is the mac address of lan/br-lan

Wed Aug 10 13:41:11 2022 kern.warn kernel: [159425.840121] br-wifi: received packet on gre4t-tap with own address as source address (addr:34:60:f9:97:xx:xx, vlan:0)

Here is my current config. I had change the Ubuntu host as I realized that I needed a host with two NIC.

config device 'device1'
        option name 'br-lan'
        list ports 'lan0'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        option type 'bridge'

config interface 'lan'
        option device 'br-lan'
        option proto 'dhcp'
config interface 'tap'
        option proto 'gretap'
        option ipaddr '10.1.0.155'
        option mtu '1500'
        option force_link '1'
        option network 'tapbr'
        option tunlink 'lan'
        option multicast '1'
        option peeraddr '10.1.0.13'
        option nohostroute '1'
        option defaultroute '0'

config device
        option name 'br-wifi'
        list ports 'gre4t-tap'
        option type 'bridge'
        option bridge_empty '1'
        option auto '1'
        option igmp_snooping '1'

config interface 'tapbr'
        option proto 'none'
        option device 'br-wifi'
        option force_link '1'
        option defaultroute '0'


Here is the linux side

ip link add tun1 type gretap remote 10.1.0.155 local 10.1.0.13 dev bond0
brctl addbr br0
brctl addif br0 enp8s0f1
brctl addif br0 tun1
ip link set br0 up
ip link set tun1 up

Looping back around to this, I found the fix to this problem.
It looks like the mac address of br-lan comes from the mac address of lan0, well on my hardware wlan0 ALSO has the same mac address of br-lan/lan0. After setup a mac address override for lan0 the error went away.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.