Grep that handles long lines

I'm trying to build w_scan and get the following error when running ./configure:-

checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... configure: error: no acceptable grep could be found in /usr/sbin:/usr/bin:/sbin:/bin:/usr/xpg4/bin

What should I do?

you could try: opkg update ; opkg install grep to get GNU grep version 2.26 (see which might be sufficient for your problem. Mind you I have not tried that so it might not be enough.

1 Like

Thanks, that worked. Apparently the built in grep is part of busybox. GNU grep needs to be installed, just as you suggested.

You could also try to contact the BusyBox developers and try to convince them to teach BusyBox grep to handle long lines... :wink:

But, opkg is there for a reason, do just installing the full grep is certainly a good solution. Just keep in mind that unless you build your own firmware to flash, any update you will install will not have gnuvgrep installed. Do you will need to install it manually after an update (or after running the Firstboot script, as that reverts the router to the pure firmware, by deleting all data added after flashing).

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.