GRE tunnel and OpenWrt 22.03

I'm trying to set up a GRE tunnel on a Linksys EA-8300 which is running OpenWrt 22.03.2. This is my setup:

/etc/config/network:

config interface 'amprnet'
	option ipaddr '45.137.xxx.yyy'
	option peeraddr '145.220.aaa.bbb'
	option proto 'gre'

config interface 'amprnet_static'
	option proto 'static'
	option device '@amprnet'
	option ipaddr '10.20.61.114'
	option netmask '255.255.255.252'

The firewall rules in /etc/config/firewall:

config zone
	option name 'amprnet'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	list network 'amprnet'
	list network 'amprnet_static'

config rule
	option name 'Allow-GRE-to-gw-44-137'
	option family 'ipv4'
	list proto 'gre'
	list dest_ip '145.220.aaa.bbb'
	option target 'ACCEPT'
	option dest '*'

config rule
	option name 'Allow-GRE-from-gw-44-137'
	list proto 'gre'
	option src 'wan'
	list src_ip '145.220.aaa.bbb'
	option target 'ACCEPT'

config rule
	option name 'Allow-traffic-to-amprnet'
	list proto 'icmp'
	option target 'ACCEPT'
	list src_ip '10.20.61.114'
	option dest '*'

I also set the 'Restrict Masquerading to given destination subnets' on the WAN interface to !10.20.0.0/16.

I'm trying to ping 10.20.61.113 which is the IP address of the tunnel interface on the other side. I get no response and I don't see GRE packets leaving the WAN interface.

Am I forgetting something. I seem to remember needing a NAT helper for iptables on a previous version of OpenWrt while using GRE tunnels. Is this also necessary for nftables which is used now in version 22.03? If so, in which package is this helper?

Let me know if I should show more of the configuration of the router.