GParted cannot see NanoPi OpenWrt uSD, Win11 sees uSD partitions but cannot resize

I have a strange problem that I've never seen before.

I flashed/wrote the NanoPi OpenWrt image (wrote fr compressed image)
openwrt-23.05.0-rockchip-armv8-friendlyarm_nanopi-r4s-ext4-sysupgrade.img.gz.
Used Rufus to write, worked fine.
This image I got fr OpenWrt downloads, not fr FriendlyARM.

Win11 sees OpenWrt partitions fine

GParted doesn't see ANY OpenWrt device/partitions. It sees Win11 install (on M.2) & GParted (its own) install.

My aim of using GParted is to resize the OpenWrt main partition. I'm not gonna waste the majority of my SD card.

I do not yet have delivery of my ordered NanoPi R4S (w MAC chip). Its "delayed", prob shipping fr China? (to German Amazon).

Anyone know why GParted cannot see OpenWrt? I assume ext4 filesystem is used? Surely GParted can read ext4?

I am using an "Inline" / "Intos Electronic AG" SD card reader. Haven't tested the card reader w any other SD card, currently don't have spare SD cards lying around. Surely GParted has enough drivers to see an SD Card reader??

If GParted cannot even detect the device, I think this is an issue with the card, the card reader, or GParted, not OpenWrt; no matter what OpenWrt might have written in that card, GParted should be able to detect the device.

I agree with @eduperez this isn't openwrt related, but gparted.

if you use ext4, it's really easy to resize the partition from cli.

Related to my thread.... I've tried accessing the Ext4 USB drive from Win11/WSL2. Was unsuccessful trying to use USB/IP. Someone referenced a thread here which explains a lot. WSL2 apparently has too many limitations currently. Reminds me of the early days of Linux TBH.

I have not yet figured out why GParted refuses to recognise this my USB drive.
GParted seems to be less & less supported. Joined the GParted forum, only to see a Sticky thread that the forum will be taken offline EndOfMonth!!! Its been privately hosted for YEARS apparently.

USB reader & SD certainly readable in Win11, can see it / listed in PowerShell. Just can't mount it until I've installed iSCSI emulator.

PS: People here referring to resizing partitions via CLI. Not obv WHICH CLI.... OpenWrt CLI when (finally) I'm able to TRY booting my NanoPi ?
OR...
Normal Linux CLI ?

I'm tempted to just install a working Debian VM onto Win. No stranger to VMs, but thought I'd take a look at WSL first. Regretting that....

you can resize using Linux or Openwrt, booted off a flash drive.

with ext4,
delete the rootfs partition, and recreate it immediately afterwards, with the new size.
save, and run resize2fs on the partition, then fsck as a final step.
done.

if blockid is used during boot to find the rootfs, make sure you update the ID in the boot loader, it might have changed.

Ext4 has partition issues.
The easiest way I have found to truly wipe an sd card with Ext4 is to flash it to Raspberry OS, then flash it to OpenWrt.

Something, something raspberry pi something.

Ignore all that github stuff and just flash it to Raspberry OS and then flash it to OpenWrt.

If you want to resize it after OpenWrt is installed, use gparted

except OP is using ..... a NanoPi ?

Where do you see that??!?!?!

Oh, yeah: everywhere.

Time to sleep.
Thx.

Interesting to hear that Ext4 has partition issues....

Well if temporarily flashing to Rasp OS actually helps, then why not?

... But I have another question.... I haven't yet been able to mount & look at the OpenWrt partitions. But I did notice that ....

  1. There is LOTS of empty space before 1st partition. Why is that required, or is/was that just someone building OpenWrt from rubbish partitioning for whatever reason?
  2. There is EMPTY space betw partition 1 & partition 2. Again,is there a reason for this?
  3. Not sure if Partition 2 is an empty root partition, or is populated? Ie will deleting it make zero difference, or is there populated w required files/drivers/whatever?
  4. I assume partition 1 is /boot partition?

Managed to get OpenWrt SD mounted into WSL2/Debian. What an absolute nightmare to do this in WSL2.

Had to RECOMPILE KERNEL to include iSCSI support.
Had to install/convert WSL2 to Systemd (thats not by default).
Had to install iSCSI support on both Win11 & Debian.
Follow incomprehensible command lines, thankfully all copy/paste.

OK, so my screenshot of the OpenWrt root folder....

Remind me where static IP is specified? Diff Linux distros do it differently.
I don't run any "infrastructure machines" on dynamic.

the LAN IP is in /etc/config/network, but I'm not sure the file's there unless you've booted openwrt at least once.

Tnx. My (basic) router doesn't even tell me which DHCP IPs are in use.

Yup, no /etc/config dir.

OK, I don't even yet have delivery of the expected NanoPi yet, so can't boot anything.

Is there anything I should be editing before 1st boot? I remember something about the default IP set to 192.168.1.1, or is that Rasp Pi docs?
My router/GW is 192.168.0.1.

openwrt's default IP is always 192.168.1.1

as long as the WAN and LAN subnets aren't the same, you're good to go, for now.

May I ask what "partition issues" are you talking about?

Easier than wipefs, dd, or even badblocks? I don't think so...

1 Like

Continuing the discussion from Pi remembers my mistakes: