Got stuck in installing an old Easybox 803a aka ARV752DPW22

I had an old Easybox 803a (ARV752DPW22) lying around here. And as I am going to a longer holiday thought it would be a great idea to flash OpenWrt so having a device I could trust and connect to being around.
I installed the box following that guides

And all worked but took very, very long to flash (around 16 hours). But when booting it don't start with Linux but with that:

RUNTASK id=4 period_task...
RUNTASK id=5 dhcp_daemon...
RUNTASK httpd...
Starting Multitask...
period_task running!!!
httpd: listen at
period_task running 60

if you enter the administrative Mode instead, you can again upload with [M] the u-boot.img.bin into the memory. If you follow up with [Y] you indeed enter to a Linux:

[ 181.616000] sched: RT throttling activated
[ 396.476000] device eth0.1 entered promiscuous mode
[ 396.480000] device eth0 entered promiscuous mode
[ 396.556000] br-lan: port 1(eth0.1) entered forwarding state

And also the network seems somehow to be configured:

root@OpenWrt:/# /sbin/ifconfig -a
br-lan Link encap:Ethernet HWaddr 9C:80:DF:B7:EB:62
inet addr: Bcast: Mask:
inet6 addr: fd7a:7497:c4a4::1/60 Scope:Global
inet6 addr: fe80::9e80:dfff:feb7:eb62/64 Scope:Link
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:121 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:11134 (10.8 KiB)

eth0 Link encap:Ethernet HWaddr 9C:80:DF:B7:EB:62
inet6 addr: fe80::9e80:dfff:feb7:eb62/64 Scope:Link
eth0.1 Link encap:Ethernet HWaddr 9C:80:DF:B7:EB:62
lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
nas0 Link encap:Ethernet HWaddr 9C:80:DF:B7:EB:63
wlan0 Link encap:Ethernet HWaddr 00:0C:43:30:62:00
root@OpenWrt:/# netstat -a
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0* LISTEN
tcp 0 0* LISTEN
tcp 0 0* LISTEN
tcp 0 0 :::www :::* LISTEN
tcp 0 0 :::domain :::* LISTEN
tcp 0 0 :::ssh :::* LISTEN
tcp 0 0 :::telnet :::* LISTEN
udp 0 0*
udp 0 0*
udp 0 0 :::dhcpv6-server :::*
udp 0 0 :::domain :::*
raw 0 0 :::58 ::%4430844:* 58
raw 0 704 :::58 ::%4430844:* 58

But I can't connect to the box via LAN. Just via the serial adapter. The is not accessible from any device out of the box. From the box you can ping it.
From the Easybox you neither can't contact the outside. Tried all 4 switch ports as I do not know which port is refered by the br-lan interface. The eth0 and eth0.1 interfaces do not have an IP configured.

Did I something wrong? Is the device bricked? Have I to reinstall the orginial firmware which I backed up? I hesitate a bit, because of the very long time the flashing took. And after all I am not sure if I have to solder something to get the Easybox in the UART mode so that I can reinstall the original image. Or can I flash the original image also fromt the Linux mode which I can receive with the uboot Image?

Thank you all for any hint

There has been very little testing for lantiq chipsets older than vr9/ VRX2xx in recent years, you might be the first (and only-) one to notice (or being able to fix-) it...

could be that I am the only one. But I am probably not able to fix it, as I am not very experienced with flashing and alternate firmware...I just am experienced with any kind of UNIX - so if I get Linux running I can help myself, but the rest I do not have deep understanding.