Google Wifi unable to install


Long term OpenWRT user here, flashed old Meraki APs and other consumer level routers.

So I've got 4x Google Wifi devices that I would like to flash OpenWRT onto, however I've been hugely unsuccessful so far getting snapshot onto one, let alone four.

Model: NLS-1304-25

Steps so far:

Use OnHub Recovery Utility to create USB recovery image, using official images.
Reset according to instructions on TOH page.

This works successfully and the device resets using the factory image provided.

I've then used the OnHub Recovery Utility to prep a USB install image (openwrt-ipq40xx-chromium-google_wifi-squashfs-factory.bin) which completes as expected.

This is where this seems to all fall apart, I've tried with different USB-C adapters, USB-C docks, hubs etc.
Different USB devices from all sorts of different brands.

I follow steps 1-5 successfully. However the image never seems to boot successfully.

Once I complete step 5 and press the SW7 button (once the indicator light is flashing purple), the light then turns off entirely.

It then stays off for around 5-10 seconds before flashing light blue very quickly (around 6-8 times with a half second interval) then flashes once before the light goes off entirely and reboots. After rebooting it goes back to flashing purple, and eventually pulsing purple/blue.

The device never responds on when an ethernet cable is plugged in to the LAN port (although the computer does show that there is a wired connection)

I've also tried creating the squashfs image using balenaEtcher and linux.

Any pointers before I give the thing a tickle with a hammer? :wink:

After trying all sorts of different things, I've finally got it installed!

Steps taken to install:

Install galeforce (, do not connect the device to the internet.
Connect a network cable from PC to LAN port, set IP address to

SSH into device (ssh://root@ password is simply changeme

Create another USB stick, although format as fat32. Copy the squashfs-factory.bin over to the root of the newly formatted drive.

Insert USB stick into USB port of USB-C adapter. You can confirm that its connected by running "dmesg" and checking the last few lines that show.

In the SSH session, run the following command to mount the USB storage to /media

mount -t vfat /dev/sda1 /media

Then execute ls /media and make sure that the bin file is found.

Now follow step 7, ignore running the scp command and instead run the following:

dd if=/dev/zero bs=512 seek=7634911 of=/dev/mmcblk0 count=33
dd if=/media/openwrt-ipq40xx-chromium-google_wifi-squashfs-factory.bin of=/dev/mmcblk0

Reboot and success, give it a few mins and the indicator should light up solid blue, it will go through a cycle of flashing purple, then nothing, and finally should quickly flash blue before going solid blue.

Ping should respond on once the indicator light has gone solid blue.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.