Google Play can't download or update apps via OpenWrt router

Hi, I have problem.


I can't download or update apps via google play on every device I have at my home, I am only getting loop shown on picture. Internet works in home, only Google play doesn't.
It works fine via 4G.

I tried using my ISP dns instead of Cloudflare, it didn't solved issue.
My network topology

Huawei ONT
| PPPoE on VLAN 35
|
V
GL-B1300 with OpenWRT 21.02.1 -> Galaxy S9
|
| 802.11r on 5GHz
V
Archer C7 v2 with OpenWRT 21.02.1 -> Galaxy S10

Any help is appreciated

are you sure your phone's using your DNSes ?

There's no guarantee, just because it's using your wifi.

I am 100% sure phone is using router DNS.

in that case, see what DNS names it requests ...

you're not using any DNS adblocker, by any chance ?

I can say the Google play installation wheel spins for me too, for a good 10+ sec,
before it actually starts the DL and install of the app.

I'm not using DNS adblocker.

Saw similar reports in IRC, a tcpdump would be helpful

2 Likes

Password: OpenWRT

EDIT: I forgot to mention, I am using software offload.

Some IPv6 packets are dropped when software flow offloading is used: FS#3373
As a workaround, do not activate software flow offloading, it is deactivate by default.

disable software flow and try again.

I am not using IPv6 on WAN.

Hello,

I have the same issue, i cannot update or download from the google play store while connected to my openwrt router.

I am not using software flow offloading.

Did you find a solution?

@jow was mentionning some reports on IRC, did someone find a solution?

Ok so i have analyse some tcpdump and it seem that i have time to live exceed paquet from an ip when i try to update an app.

Kinda weird, but issue fixed by itself.

For me maybe (because actually I really don't know) setting google DNS helped.

Thanks for the update.

On my side i have investigate, and it seems that i cannot ping a server from google : 64.15.118.19.
My DNS resolve well, but the paquet is lost on a node that belong to my ISP. So i start to think that is an ISP issue.

Do you have the correct MTU set on the PPoE router and on the openwrt router?

I have check that, and apparently my PPoE router is on 1500 MTU (i can not change that) and i have not touch the MTU setting on my openwrt router, so by default it is 1500 too.

That might indicate the incorrect setting, the PPPoE connection usually requires a different setting. Colud you check the maximal MTU that the connection provides using ping command? You can check this guide: https://kb.netgear.com/19863/Ping-Test-to-determine-Optimal-MTU-Size-on-Router