[Google OnHub][23.05.0-rc3] 2 OnHubs with all radios in luci showing "Generic unknown", but one OnHub works fine

I have 2x TP-Link OnHubs and 1x Asus OnHub. One of my TP-Link's is working fine, showing 3 Qualcomm Atheros QCA9880 radios. The other TP-Link OnHub and Asus OnHub show "Generic unknown, Device is not active".

What can I try? My /etc/config/wireless is the same for all 3:

config wifi-device 'radio0'
        option band '2g'
        option cell_density '0'
        option channel 'auto'
        option htmode 'HT40'
        option legacy_rates '1'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option type 'mac80211'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid '(V)(;,,,;)(V)'
        option encryption 'psk2'
        option key 'california'
        option dtim_period '3'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option channel 'auto'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid '(V)(;,,,;)(V)'
        option encryption 'psk2'
        option key 'california'
        option dtim_period '3'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'soc/1b900000.pci/pci0002:00/0002:00:00.0/0002:01:00.0'
        option channel 'auto'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid '(V)(;,,,;)(V)'
        option encryption 'psk2'
        option key 'california'
        option dtim_period '3'
        option ieee80211r '1'
        option ft_over_ds '0'
        option ft_psk_generate_local '1'

All 3 have the same /etc/openwrt_release:

DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='23.05.0-rc3'
DISTRIB_REVISION='r23389-5deed175a5'
DISTRIB_TARGET='ipq806x/chromium'
DISTRIB_ARCH='arm_cortex-a15_neon-vfpv4'
DISTRIB_DESCRIPTION='OpenWrt 23.05.0-rc3 r23389-5deed175a5'
DISTRIB_TAINTS=''

One interesting thing is I think it's actually working as I see this in syslog:

Sep 26 10:48:43 wifi_office hostapd: phy1-ap0: STA d4:3a:2c:98:31:45 IEEE 802.11: authenticated
Sep 26 10:48:43 wifi_office hostapd: phy1-ap0: STA d4:3a:2c:98:31:45 IEEE 802.11: associated (aid 2)
Sep 26 10:48:43 wifi_office hostapd: phy1-ap0: AP-STA-CONNECTED d4:3a:2c:98:31:45 auth_alg=open
Sep 26 10:48:43 wifi_office hostapd: phy1-ap0: STA d4:3a:2c:98:31:45 WPA: pairwise key handshake completed (RSN)
Sep 26 10:48:43 wifi_office hostapd: phy1-ap0: EAPOL-4WAY-HS-COMPLETED d4:3a:2c:98:31:45

Please let me know where else I can look for clues to get the luci interface to work.

Thanks!

23.05.0-rc4 seems to have fixed the issue.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.