Going back to stock (re200)

How many times can I go back to Stock on my re200

as many as you'd like, there's no counter.

Forgot to add
and still get updates

This also makes the following impossible:

flash OpenWrt
revert to stock
flash OpenWrt again (fails because the firmware already has the version used by this image)

you mean flashing openwrt -> stock -> openwrt ?

should work, what's the exact error message ?

I havn't tried it yet
I wanted to know before I do it, as I might use openwrt again in the future

you came from stock, redoing the same thing again shouldn't be an issue.

1 Like

it says you can't install an older firmware version

who sais

openwrt or stock ?

openwrt -> stock is documented in [OpenWrt Wiki] TP-Link RE200

1 Like

it will require the firmware image to contain a later firmware version than the one currently installed.

Now I understand the issue :slight_smile:
Well, if you were on the latest one, you're currently (probably) f*cked, unless you can find
some beta FW in the TP-Link forums.

Just tried it and the lights keep flashing, it turning on and rebooting
any idea how to re-flash it without opening the case
or any tips for opening the case

According to the wiki:

The case is welded together and you can't open it easily. I used a swivel vise to crack open the case. If done carefully, it only leaves a few small marks. I super-glued mine back together after porting OpenWrt.

any other ways to reflash it other than serial

I thought there was a way to recover from a bad flash if it dosn't overwrite U-boot
the website is either lieing or its only avalible with serial
and if its a lie whoever written that page owes my a re200
because I did this thinking I could recover a bad flash

Since you didn't mention what version (1, 2, 3, or 4) yor device is, here is the list with links to each hardware data page for each version -

I get that you posted it, but did you actually read through.

Click on the View/Edit data link for whatever version you're using to get the the hardware data page.

Then, click on the link for the Supported Since Commit: section -

Install and recovery instructions are located there.

OpenWrt, or "whoever wrote the page" doesn't owe you anything.

It's part of the risk you take when installing 3rd party firmware.

This might be relevant too TP-Link RE200 V3 refuses to install OpenWrt - #8 by tmomas

What have I said
It won’t turn on fully

OpenWrt, or "whoever wrote the page" doesn't owe you anything.
It's part of the risk you take when installing 3rd party firmware.

But I thought they was a way to recover from a bad flash
I was mislead

And now I need to find a way of opening it to connect to the serial pins

You didn't understand that sometimes serial is the the only way to recover.

Once you get it open, the pinouts can be seen here -

If I get it open, I have no tools other than a scredriver
any tips for something else I could use as I do not have a vice

Also it dosn't say serial is the only way to recover

Web Interface Method (v2, v3, v4)

Simply install the -factory.bin image via the stock web interface. This procedure does not overwrite U-Boot, hence you have higher chances of being able to recover from a bad flash.

the website does not explain properly should I have done something to the stock image