Going back to stock on WRT3200ACM, boot_part not defined

I am trying to go back to stock on WRT3200ACM after using LEDE for a while, this is what I am getting when I try flashing from terminal:
root@LEDE:~# sysupgrade -n -v -F FW_WRT3200ACM_1.0.6.181063_prod.img
Image metadata not found
Image check 'fwtool_check_image' failed but --force given - will update anyway!
killall: watchdog: no process killed
Sending TERM to remaining processes ... logd rpcd netifd odhcpd uhttpd ntpd dnsmasq ubusd askfirst
Sending KILL to remaining processes ... askfirst
Switching to ramdisk...
Performing system upgrade...
## Error: "boot_part" not defined
cannot find target partition

When I run
root@LEDE:~# /usr/sbin/fw_printenv -n boot_part
I get
## Error: "boot_part" not defined

Flashing over wifi gui is no good as the new flashfile does not pass the meta data requirements.
Any suggestions how to turn my router back to stock?

The WRT3200ACM has two partitions.

When you flash stock firmware with LEDE, LEDE is installed on the alternate partition.

So unless you flashed both partitions with LEDE, you can return to stock firmware by doing the following...


What is the output of the plain "fw_printenv" without any arguments?
There should be several variables with values.

(Is your WRT3200ACM quite new? Just wondering, as there is speculation that something may have changed in the recent WRT3200ACMs compared to the earlier ones.)

Have you tried flashing via Serial.

  • Firmware Recovery procedure is also in the wiki, as users should be pointed to a centralized location