GLiNet Beryl Router- Tailscale Exit Node Not Working

Hey all. I bought an GLiNet router which is a build of OpenWrt specifically so that I could have a router with Tailscale on in. The idea is to use it as a router level site to site VPN.

Well, I was able to do this successfully for a couple of months, but then I moved and my Tailscale stopped working. Before, it worked using the OOTB firmware with out any issues. Could this be due to some kind of conflict with the subnet route of the router and the modem/router at the new place I am in? It's an Airbnb so it's not my router or internet. How would I troubleshoot this to check to see if this is the issue? All other devices on my Tailscale network can use the exit node flawlessly with no issues, so I know the issue is the router itself.

I have tried multiple different things to fix this and several different firmware versions, but nothing is seeming to fix this. I can get Tailscale to turn on and connect on my network just fine, but as soon as I turn on the exit node it would kill my internet. I read online that you needed to go into Luci and create a firewall zone and and interface for Tailscale which I did. This did change the behavior, but it didn't fix the issue. What this did was instead of killing my internet, it would turn on and my internet was fine, but the exit node doesn't do anything and doesn't change my IP as it should, any check of my IP displays my real IP.

Any ideas on what the issue for this is or how to fix it? Any help would be much appreciated.

You mean, a self-compiled OpenWrt image or the OpenWrt image provided by the manufacturer?

1 Like

It's the OpenWrt image provided by GLiNet. I didn't make any changes to it other than adding the firewall zone that I mentioned. It was working without me needing to do that earlier, so I'm guessing there must be some issue with a conflict with the modem of where I'm staying? I am on the latest firmware for the device as well.

You’ll need to ask on the gl-Inet forums. The version of OpenWrt that they provide has significant differences relative to the official version (from and therefore is not supportable here.

1 Like

I did ask, I just thought that someone here might also have a workaround in case they took forever to be able to get back to me or nobody there knew anything. Just wanted to see if there was anyone on here with experience with it.

I understand. But a response here may not be helpful anyway because gl-inet has made many changes to openwrt for their devices, so it’s a different animal entirely. You’ll have to rely on their forums.

1 Like

I guess the hardware forum on here might be of help? I figure there may be someone who has had the same issues. I have been asking on their forum but only gotten one response and it was from the team there and it didn't fix my problem, so I'm trying to do anything that I can to try to figure out how to fix this on my own, lol.

No, the hardware subsection is about selecting hardware to use with the official OpenWrt firmware. Your device is not supported by the official project, so you’ll need to rely on the manufacturer and their support channels.

I’m sorry that your problem has not been resolved there, but the GL-inet support channels and/or other sites on the internet that can advise about their firmware are where you need to go. This forum cannot and does not support GL-inet’s heavily modified version of OpenWrt.