Gli MT6000 with Batman-adv (MTU and Routing Alg. Questions)

Hi,
I hope someone can help me...
there is probably a configuration error here...

all devices have Openwrt 24.10 installed

I use 6x MT6000, 2x MT3000 and some repeaters in my network (trunk port is always 2.5GB).
SQM is activated for the trunk ports. The MTs are all connected with cable (CAT6A)
but with the current settings I can achieve with iperf3 (I think more should be possible here, right?)
(iperf3 -c -P 10 - test between 2 MT6000)
[ ID] Interval Transfer Bitrate Retr
[ 5] 0.00-10.00 sec 534 MBytes 448 Mbits/sec 18 sender
[ 5] 0.00-10.00 sec 531 MBytes 445 Mbits/sec receiver

Now I would like to increase the performance here, but there seem to be several approaches that I am not entirely sure about.

  1. Choose a better MTU size (but where exactly do you have to enter it)
  2. Use routing algorithm (BATMAN_V)
  3. I would of course be grateful for other ideas
    here are my config files (just cleaned up a few VLANs to keep them shorter as they are actually just repeated)

Network1:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '------------/48'
	option packet_steering '2'

config interface 'lan'
	option device 'br-aVlan.10'
	option proto 'static'
	option ipaddr '192.168.2.20'
	option netmask '255.255.255.0'
	option defaultroute '0'
	option gateway '192.168.2.1'
	option delegate '0'

config interface 'wan'
	option device 'eth1'
	option proto 'dhcp'

config interface 'wan6'
	option device 'eth1'
	option proto 'dhcpv6'
	option auto '0'
	option reqaddress 'try'
	option reqprefix 'auto'
	option disabled '1'


config interface 'GAST'
	option proto 'static'
	option device 'br-aVlan.999'
	option ipaddr '192.168.99.20'
	option netmask '255.255.255.0'
	option defaultroute '0'
	option delegate '0'


config interface 'bat0'
	option proto 'batadv'
	option force_link '1'
	option routing_algo 'BATMAN_IV'
	option gw_mode 'off'
	option gw_bandwidth '200000/200000'
	option hop_penalty '30'
	option defaultroute '0'
	option bridge_loop_avoidance '1'
	option aggregated_ogms '1'

config interface 'batmesh'
	option proto 'batadv_hardif'
	option force_link '1'
	option master 'bat0'
	option defaultroute '0'
	option mtu '1532'
	option delegate '0'
	option disabled '1'
	option auto '0'

config interface 'batwire'
	option proto 'batadv_hardif'
	option device 'br-mgmt'
	option force_link '1'
	option master 'bat0'
	option defaultroute '0'
	option delegate '0'
	option mtu '1532'

config device
	option type 'bridge'
	option name 'br-aVlan'
	option bridge_empty '1'
	option stp '1'
	option igmp_snooping '1'
	list ports 'bat0.10'
	list ports 'bat0.999'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'lan5'

config bridge-vlan
	option device 'br-aVlan'
	option vlan '10'
	list ports 'bat0.10'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'
	list ports 'lan5'


config bridge-vlan
	option device 'br-aVlan'
	option vlan '999'
	list ports 'bat0.999'

config interface 'batmesh5g'
	option proto 'batadv_hardif'
	option force_link '1'
	option master 'bat0'
	option mtu '1532'
	option defaultroute '0'
	option delegate '0'


config device
	option name 'bat0'
	option mtu '1532'

config device
	option type 'bridge'
	option name 'br-mgmt'
	option bridge_empty '1'
	list ports 'lan1'


Network 2-5:


config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix '------------/48'
	option packet_steering '2'

config interface 'lan'
	option device 'br-aVlan.10'
	option proto 'static'
	option ipaddr '192.168.2.32'
	option netmask '255.255.255.0'
	option gateway '192.168.2.1'
	option delegate '0'

config interface 'GAST'
	option proto 'none'
	option device 'br-aVlan.999'
	option force_link '1'
	option defaultroute '0'
	option delegate '0'

config interface 'bat0'
	option proto 'batadv'
	option routing_algo 'BATMAN_IV'
	option gw_mode 'off'
	option gw_bandwidth '100000/100000'
	option hop_penalty '30'
	option bridge_loop_avoidance '1'
	option force_link '1'
	option defaultroute '0'
	option delegate '0'
	option aggregated_ogms '1'

config interface 'batmesh'
	option proto 'batadv_hardif'
	option master 'bat0'
	option defaultroute '0'
	option mtu '1532'
	option force_link '1'
	option delegate '0'
	option disabled '1'
	option auto '0'

config interface 'batwire'
	option proto 'batadv_hardif'
	option device 'br-mgmt'
	option master 'bat0'
	option defaultroute '0'
	option force_link '1'
	option delegate '0'
	option mtu '1532'

config interface 'batmesh5g'
	option proto 'batadv_hardif'
	option master 'bat0'
	option defaultroute '0'
	option mtu '1532'
	option force_link '1'
	option delegate '0'

config device
	option type 'bridge'
	option name 'br-aVlan'
	option bridge_empty '1'
	option stp '1'
	option igmp_snooping '1'
	option multicast_querier '0'
	list ports 'bat0.10'
	list ports 'bat0.999'
	list ports 'lan4'
	list ports 'lan5'

config bridge-vlan
	option device 'br-aVlan'
	option vlan '10'
	list ports 'bat0.10'
	list ports 'lan4'
	list ports 'lan5:t'


config bridge-vlan
	option device 'br-aVlan'
	option vlan '999'
	list ports 'bat0.999'
	list ports 'lan5:t'

config device
	option name 'bat0'
	option mtu '1532'

config device
	option type 'bridge'
	option name 'br-mgmt'
	option bridge_empty '1'
	list ports 'eth1'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'

SQM:

config queue 'eth1'
	option enabled '0'
	option interface 'eth1'
	option download '2250000'
	option upload '2250000'
	option qdisc 'cake'
	option script 'layer_cake.qos'
	option linklayer 'none'
	option debug_logging '0'
	option verbosity '5'

config queue
	option enabled '0'
	option interface 'lan1'
	option download '2250000'
	option upload '2250000'
	option debug_logging '0'
	option verbosity '5'
	option qdisc 'cake'
	option script 'layer_cake.qos'
	option linklayer 'none'

OpenWrt conf:

#Flint2MT6000
CONFIG_TARGET_mediatek=y
CONFIG_TARGET_mediatek_filogic=y
CONFIG_TARGET_mediatek_filogic_DEVICE_glinet_gl-mt6000=y
CONFIG_TARGET_PACKAGES_mediatek_filogic_DEVICE_glinet_gl-mt6000=y
CONFIG_TARGET_PROFILE="DEVICE_glinet_gl-mt6000"
CONFIG_TARGET_MULTI_PROFILE=n
CONFIG_TARGET_ALL_PROFILES=n
CONFIG_TARGET_PROFILE="DEVICE_glinet_gl-mt6000"
CONFIG_TARGET_PER_DEVICE_ROOTFS=y
CONFIG_TARGET_OPTIMIZATION="-O2 -pipe -mcpu=cortex-a53"

#kmod
CONFIG_PACKAGE_kmod-tun=y

#MBEDTLS
CONFIG_PACKAGE_wpad-basic-mbedtls=m
CONFIG_PACKAGE_wpad-mbedtls=y

#servicesandtools
CONFIG_PACKAGE_curl=y
CONFIG_PACKAGE_iperf3=y
CONFIG_PACKAGE_wget=y
CONFIG_PACKAGE_arp-scan=y
CONFIG_PACKAGE_bind-host=y
CONFIG_PACKAGE_irqbalance=y
CONFIG_PACKAGE_luci-app-irqbalance=y

#luci
CONFIG_PACKAGE_luci=y
CONFIG_PACKAGE_luci-compat=y
CONFIG_PACKAGE_luci-mod-admin-full=y


#mesh-batman
CONFIG_PACKAGE_luci-proto-batman-adv=y
CONFIG_PACKAGE_kmod-batman-adv=y
CONFIG_PACKAGE_batctl-full=y

#qos
CONFIG_PACKAGE_sqm-scripts=y
CONFIG_PACKAGE_luci-app-sqm=y

#Firewall
CONFIG_PACKAGE_iptables-mod-ipopt=y

#USB
CONFIG_PACKAGE_luci-app-ksmbd=m
CONFIG_PACKAGE_luci-app-hd-idle=y
CONFIG_PACKAGE_kmod-fs-exfat=y
CONFIG_PACKAGE_exfat-fsck=y
CONFIG_DEFAULT_kmod-usb3=y
CONFIG_PACKAGE_kmod-usb-storage-uas=y
CONFIG_PACKAGE_usbutils=y
CONFIG_PACKAGE_lock-mount=y
CONFIG_PACKAGE_mount-utils=y
ubus call system board
cat /etc/config/firewall

and remove iptables userland plugin.

i hope it help...
and i will remove iptables now

Nr1

ubus call system board
{
        "kernel": "6.6.69",
        "hostname": "OpenWrt-1",
        "system": "ARMv8 Processor rev 4",
        "model": "GL.iNet GL-MT6000",
        "board_name": "glinet,gl-mt6000",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "24.10-SNAPSHOT",
                "revision": "r0-e620694",
                "target": "mediatek/filogic",
                "description": "OpenWrt 24.10-SNAPSHOT r0-e620694",
                "builddate": "1736517479"
        }
}

Nr2-5

ubus call system board
{
        "kernel": "6.6.69",
        "hostname": "OpenWrt-2",
        "system": "ARMv8 Processor rev 4",
        "model": "GL.iNet GL-MT6000",
        "board_name": "glinet,gl-mt6000",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "24.10-SNAPSHOT",
                "revision": "r0-e620694",
                "target": "mediatek/filogic",
                "description": "OpenWrt 24.10-SNAPSHOT r0-e620694",
                "builddate": "1736517479"
        }
}

Nr1

 cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest '*'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest '*'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'


config zone
        option name 'GAST'
        option input 'DROP'
        option output 'ACCEPT'
        option forward 'DROP'
        list network 'GAST'

config forwarding
        option src 'GAST'
        option dest 'wan'

config rule
        option name 'LAN-DNS-DHCP'
        option src 'lan'
        option dest_port '53 67 68'
        option target 'ACCEPT'

config rule
        option name 'GAST-DNS-DHCP'
        option src 'GAST'
        option dest_port '53 67 68'
        option target 'ACCEPT'

Nr2-5

 cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'

and i got this kernel log

[   17.391803] batman_adv: bat0: Adding interface: br-mgmt
[   17.397036] batman_adv: bat0: The MTU of interface br-mgmt is too small (1500) to handle the transport of batman-adv packets. Packets going over this interface will be fragmented on layer2 which could impact the performance. Setting the MTU to 1532 would solve the problem.
[   17.421221] batman_adv: bat0: Interface activated: br-mgmt

but if i change the MTU of this bridge Device i lost the connection to my MT3000

what should i do?

Did you adjusted the mtu on both ends? (Both peers need to speak with the same MTU to each other)

First set mtu in far end?