GL-X3000 cellular connection failure on some startups

Hi

I'm encountering a weird issue on my GL-X3000 router regarding the modem. For some reasons when starting it up, sometimes the modem interface can't establish a cellular connection. This happens seemingly at random. Here below is an image of the LuCi interface when the fault occurs.

When this happens, I can simply restart the modem interface manually and that solves the problem.

I'm running OpenWRT 24.10.0 (sysupgrade image from the firmware selector)

Here is my config/network file:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fda9:1dcd:ff58::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'eth0'
	option proto 'dhcp'

config interface 'modem'
	option proto 'qmi'
	option device '/dev/cdc-wdm0'
	option apn '<redacted>'
	option auth 'both'
	option username '<redacted>'
	option password '<redacted>'
	option pdptype 'ipv4'

When the faults happens, it can be seen in the syslog that the udhcpc DISCOVER request doesn't get an answer.

Tue Feb 25 22:44:56 2025 daemon.notice netifd: modem (2350): Starting network modem
Tue Feb 25 22:44:57 2025 daemon.notice netifd: modem (2350): Setting up wwan0
Tue Feb 25 22:44:57 2025 daemon.notice netifd: Interface 'modem' is now up
Tue Feb 25 22:44:57 2025 daemon.notice netifd: Network device 'wwan0' link is up
Tue Feb 25 22:44:57 2025 daemon.notice netifd: Network alias 'wwan0' link is up
Tue Feb 25 22:44:57 2025 daemon.notice netifd: Interface 'modem_4' is enabled
Tue Feb 25 22:44:57 2025 daemon.notice netifd: Interface 'modem_4' has link connectivity
Tue Feb 25 22:44:57 2025 daemon.notice netifd: Interface 'modem_4' is setting up now
Tue Feb 25 22:44:57 2025 daemon.notice netifd: modem_4 (3333): udhcpc: started, v1.36.1
Tue Feb 25 22:44:57 2025 user.notice firewall: Reloading firewall due to ifup of modem (wwan0)
Tue Feb 25 22:44:57 2025 daemon.notice netifd: modem_4 (3333): udhcpc: broadcasting discover
Tue Feb 25 22:44:58 2025 daemon.warn odhcpd[2059]: No default route present, overriding ra_lifetime to 0!
Tue Feb 25 22:45:00 2025 daemon.notice netifd: modem_4 (3333): udhcpc: broadcasting discover
Tue Feb 25 22:45:03 2025 daemon.notice netifd: modem_4 (3333): udhcpc: broadcasting discover
Tue Feb 25 22:45:14 2025 daemon.warn odhcpd[2059]: No default route present, overriding ra_lifetime to 0!
Tue Feb 25 22:45:16 2025 daemon.err uhttpd[2177]: [info] luci: accepted login on / for root from 192.168.1.191
Tue Feb 25 22:45:30 2025 daemon.warn odhcpd[2059]: No default route present, overriding ra_lifetime to 0!
Tue Feb 25 22:55:26 2025 daemon.warn odhcpd[2059]: No default route present, overriding ra_lifetime to 0!

Here are the results of some digging I did:

I initially thought it might be a sort of race condition where udhcpc fires the broadcast discover request before the modem is ready. I tried adding a delay before the udhcpc command is executed in the /lib/netifd/proto/dhcp.sh file but even with that the fault occured.

When the fault occurs I am am still able to talk with the modem via AT commands and uqmi.
When the fault occurs, the command uqmi -d /dev/cdc-wdm0 --get-data-status returns "disconnected"
When the fault occurs, the command tcpdump -i wwan0 port 67 or port 68 returns
17:22:02.616780 IP 0.0.0.0.68 > 255.255.255.255.67: BOOTP/DHCP, Request from 52:25:69:c9:5b:0d (oui Unknown), length 300 on repeat.

Would anyone here be able to help me regarding this ?

Thanks in advance !

Still stuck with this, anyone has an idea ?