GL-SFT1200 firewall rules

HELLO,
I remove the wireguard masquerade ticks in the openwrt firewall section of my gl.inet device. But when I restart the device, it goes back to its old settings. How can I make these settings immutable?

Are you using the GL-inet stock firmware, or have you installed an official version of OpenWrt?

ubus call system board
1 Like

Uploading: 1.JPG...
I am using gl.inet device. I am making changes from the openwrt software on the gl.inet device.

Did you install the official OpenWrt firmware? If so, what version.

1 Like

version information :

Firmware Version OpenWrt 18.06 r0-d5ed025 / LuCI openwrt-18.06 branch (git-18.228.31946-f64b152)
Kernel Version 4.14.90

The system works only when I untick the masquerade of the wireguard section in the firewall section.
However, when I restart the device, the masquerade in the masquerade section appears to be active again.

You are using gl-inet firmware, not an official version of OpenWrt.

It appears you are using firmware that is not from the official OpenWrt project.

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

1 Like

You may be able to get help from @luochongjun or @hoff.xin who work for gl-inet. Otherwise, you should ask in the gl-inet user forums because the behavior you are describing is not typical of the official openwrt firewall/persistent settings.

1 Like

@luochongjun @hoff.xin please your support.

1 Like

Hi bekirarpacik, can you tell me what's fimrware version do you use? you can get the firmware version from the web interface, like the picture below.

We don't speed much time to maintenance luci interface, so maybe there are soome bugs in the luci interface, If you can give us your requirement and what steps do you operate in GL.iNet firmware, it may be useful for me to solve your problem, I will test your report problem.

Hi Psherman, thank you very much, I will help bekirarpacik to solve his problem.

1 Like

Hi,
fimrware version 3.216
thank you @hoff.xin

Hi bekirarpacik, I have tested your problem, it is normal, when I use SFT1200+V3.216 firmware to configure like you set(disable masquerade), and then I reboot the device, the masquerade is still disable, please refer to my screetshot below.


If there is same problem with your device, you can share device to me via our goodcloud, you can follow the steps with the attachment file to share device to me, if you worry about the your MAC and password leakage, you can sent email to me, my email is hoff.xin@gl-inet.com

Information has been sent to your e-mail address.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.