GL-MT300N-V2 - LUCI 17.01 / Clean image - Can't get ethernet to work

Hi,

I've been using a raspberry PI one as a bridge device for my printer. The printer simply doesn't have wireless and pulling a cable is way to much work. So, i've taken a raspberry pi 1 (old one), plugged in a wifi dongle and used relayd to let is act as a wifi-repeater. The configuration with relayd is such that any device connected to the NIC/Ethernet port of the raspberry acts as a normal wireless client.
This has been working well, but i must add that the raspberry pi was crappy to begin with and i'm now just fed up with rebooting it.

In comes the GL-MT300N-V2.
The device is small, cheaper than a raspberry and runs the LEDE project. Great.
I've not found out that the shell that GL-INET adds doesn't seem to allow me to configure it with relayd, so i've downloaded the 'clean' image that they provide and this gives me a LUCI 17.01 device.

I can ge to the device via wireless, but i'm unable to get the LAN ports to work. I've removed practically every interface (except for the wifi) and added a new 'LAN' port and in the physical section selected eth0. Vlan's have been disabled on the switch settings. The LAN interface is set to DHCP.

For whatever reason: the device does not perform a DHCP query and doesn't get an IP address.
What also confused me is that the interface i have for my WIFI is always in bridge mode and uses the apcli0 device as well. This seems a bit off to me and it seems like some configuration is forced.

I'm looking for help with regards to this, as i must be doing something simple wrong!

I use this GL-MT300V2 alos some others little box as NEXX WT3020

no problem in relayd mode ( my wifi network )

i can use with:

  • MT300 -> 2 * Lan printer + 1 USB Printer +minidlna , samba for HDD :

  • NEXX WT3020 ->
    1 * Lan Printer + 1 USB Printer + minidlna
    or a TV LG or Samsung when i use the LAN port ( TV are without wifi )
    or a scanner USB ( opkg install sane …

a first time i use Putty with TTL interface for edit the files ( if ok i run afer i save the configuration with Luci )

etc/firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan wwan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan wan6'

config forwarding
	option src 'lan'
	option dest 'wan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config include 'miniupnpd'
	option type 'script'
	option path '/usr/share/miniupnpd/firewall.include'
	option family 'any'
	option reload '1'



etc/network:file 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd6b:b79d:353f::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option gateway '192.168.1.1'
	option dns '192.168.1.1 8.8.8.8'
	option ipaddr '192.168.2.230'
	option _orig_ifname 'eth0 wlan0-1'
	option _orig_bridge 'true'
	option ifname 'eth0'

config interface 'wwan'
	option _orig_ifname 'wlan0'
	option _orig_bridge 'false'
	option proto 'static'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option dns '8.8.8.8 192.168.1.1'
	option ipaddr '192.168.1.230'

config interface 'stabridge'
	option proto 'relay'
	list network 'lan'
	list network 'wwan'

etc/Wireless


config wifi-device 'radio0'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/10300000.wmac'
	option htmode 'HT20'
	option disabled '0'
	option country '00'
	option legacy_rates '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option network 'lan'
	option ssid 'GL-MT300N-V2-230'
	option encryption 'psk-mixed'
	option key '1234567890'
	option wpa_disable_eapol_key_retries '1'

config wifi-iface
	option ssid 'TOMATO'
	option encryption 'psk2'
	option device 'radio0'
	option mode 'sta'
	option bssid 'XX:....... '
	option key '1234567890'
	option network 'wwan lan'

etc/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option dhcpv6 'server'
	option ra 'server'
	option ignore '1'
	option ra_management '1'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

My router is : 192.168.1.1
Wifi master is WNR3500 TOMATO ( 192.168.1.235 ) password : 1234567890 MAC adress: XX….
GL-MT300 is 192.168.1.230

My network is similar to this :slight_smile:

GL-MT300V2

Thanks for the response!

Which version of lede/openwrt are you running?
I've just installed the snapshot and it seems very unstable. I can sometimes change things but often the device just stops responding.

I have comiled last git sources code

OpenWrt SNAPSHOT r7360-e15565a01c /LuCI Master (git-18.202.70567-a8a5b2f)

kernel 4.14.51