GL-INET MT1300 (Beryl) WiFi interface not exist

Hi all,

I have a GL-INET MT1300 bought a few weeks ago, getting some trouble on official OpenWRT release .

I tried 21.02 rc3/rc4, also snapshot, after installation, the interface list doesn't show me any WiFi interface. I remember that the first time installing RC4, the WiFi does show up, however after some setup the router seems crashed so I reset it, since then WiFi interface never show up in Luci (even checking in ssh session there is no interface other than wired one).

I flash the GL-INET stock firmware and WiFI was working, so this is definitely not hardware problem, can someone give me some hints on what's happening? (One interesting thing is, I installed Luci within GL-INET firmware, and the Luci network interface session are unable to show WiFi status properly)

looks like a general issue, you might need to stay on vendor firmware for a while, until OpenWRT development for that device has made more progress on WiFi:

Did you try RC4 or snapshot?
After recovery, my WiFi never show up again.

21.02.0 was released on Sept. 4th. Unfortunately it is still not working on my router.
However, according to GliNet MT-1300 Beryl 21.02.1-rc3 Wifi Issue - For Developers - OpenWrt Forum, this problem had been fixed on snapshot version on June. Maybe developers have not merged changes to stable version?

I have this device too and I think it's works. Not out of the box. Here my solution.

First I tried it with release 21.02.0 and with a self-compiled-snapshot. Both with the same result. So my description is for 21.02.0.

You need a ssh-access for it.

First I propose to delete the configuration and start with a fresh file:

rm -f /etc/config/wireless
wifi config

So the file /etc/config/wireless look like:

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+1'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

We have 2 interfaces with the same band (5.7 GHz), the same channel and the same SSID. And without Encryption.
My target: both bands (2.4 GHz and 5.7 GHz), diffferent SSID and Encryption.

I changed the wireless-file:

`config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '2G'
	option htmode 'HT20'
	option hwmode '11g'
	option channel '3'
	option cell_density '0'
	option country 'DE'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'guest-2'
	option encryption 'psk2'
	option key '123456789'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+1'
	option band '5g'
	option hwmode '11a'
	option channel '140'
	option country 'DE'
	option htmode 'VHT80'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'guest-5'
	option encryption 'psk2'
	option key '123456789'

After reboot I checked the wireless-status in LuCI. Both bands were visible, only the first interface worked. So I restarted the second interface with LuCI and some times later, both interfaces worked (1 or 2 minutes later).
After reboot the same: only the first interface worked.

So I edit the file /etc/rc.local (or use LuCI: System / Startup / local Sttartup):

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.

sleep 60
/sbin/wifi

exit 0

So I'm very happy with my new device. Please change the country, SSID and your password :grinning:

The changes to /etc/config/wireless also work on latest snapshot to get the 2.4Ghz and 5.0Ghz bands working

uci set wireless.radio0.channel=11
uci set wireless.radio0.hwmode=11g
uci set wireless.radio0.htmode=HT20
uci set wireless.radio0.band=2G
uci commit

The snapshot firmware also brings up both radios at boot by default, so it does not require adding /etc/rc.local to run /sbin/wifi

2 Likes

Really appreciate your finding, I was struggling on this for long, the GUI is showing wlan0 as 5GHz while wlan1 as 2.4GHz which is completely reversed after I looked at your config!

BTW now I am with 21.02.2 latest release, I don't seem to need the interface delayed start up and both interfaces showed up right after a reboot.

There's still the same problem with OpenWrt-22.03.3. As a workaround, edit /etc/config/wireless and add "band 2g" and "phy phy0" options to radio0 and "band 5g" and "phy phy1" (and usually "country" too) to radio1. Then reboot (or just restarting wifi might be enough: wifi down; sleep 10; wifi up).

BTW, the GUI shows the device names as "Generic MAC80211" rather than "MediaTek MT7615E" as before.

Wired....on my Beryl, I just updated it to 22.03.3, it's showing me Mediatek but not Generic....

I was upgraded from 22.02 to 22.03 previously (with a wipe), and then 22.03.3 just now (after I saw your post, without wipe), I don't need to do any manual settings.

Yes, that's odd. I upgraded to 22.03.3 from the stock GL-INET firmware 4.1.0 beta3 (which is actually based on 22.03.2) simply by uploading the sysupgrade image into their upgrade GUI.

Anyway, yesterday I tried to 're-flash' the same 22.03.3 image as before (openwrt-22.03.3-ramips-mt7621-glinet_gl-mt1300-squashfs-sysupgrade.bin) from 22.03.3 and got this:


:worried:

So what's the final output after re-flashing?

I didn't force-flash the image. The router is working fine and I wont risk ignoring that big red warning for now.

Uh, I noticed the picture is wrong and doesn't match my description. It's actually the warning shown on the attempt to revert from 22.03.3 to OEM 3.215 firmware (see "Size: 16.50 MB").

The warning shown by OEM 3.215 firmware when installing OpenWrt sysupgrade image (using LuCI included in OEM firmware) is the following:

I've successfully force-upgraded to 22.03.3 and managed to configure both 2.4G and 5G wi-fi only using LuCI this time. The device names are displayed as "Generic MAC80211 ...".