GL.iNET Flint 2 (GL-MT6000) discussions

I believe so as you mentioned both your clients are connected to the 1G ports on router and not the 2.5G port, the client's link is limited by the bandwidth of the port it's connected to on router. Seeing your NAS is connected to the 2.5G port on router you may get an improvement in speeds for wireless clients but i'm guessing only if your wireless clients support full 4x4 160Mhz Wi-Fi channels.

I'm considering getting a 2.5G switch and connecting it to the second 2.5G port for this. I just don't have any realworld use for it other than performance tests (and seems like a waste of power if not needed). When I see one on sale I'll probably do it.

So, mine should be here today.
I simply load SNAPSHOT, and I am 100% official OpenWRT?

I just flashed the snapshot sysupgrade through the firmware update page of the stock firmware. It’s been fine for a month now.

1 Like

Just use the latest snapshot sysupgrade image

1 Like

As others have already said, yes.
However the snapshots don't come with Luci. If you want Luci - and you probably do - you can install it after flashing, or you can request a build with it included.
To request a build, use the Firmware Selector.
Choose 'Customize installed packages and/or first boot script'. The default selections include Luci. Then 'Request Build'.

2 Likes

Thanks for the replies, the interface it ships with looks kinda cool...

Is this device-dependent, or has it changed recently? I've grabbed snapshots within the last couple of weeks that had LuCI included by default.

Their interface does look nice, but their firmware contains packages that are extremely out of date and bugs that don't exist in OpenWrt snapshots.

GL.iNet recently downgraded their upcoming firmware to OpenWrt 21.02.3 too, which seems absurd to me since this is their $150+ flagship product and their firmware "upgrade" is an EOL version of OpenWrt with more vulnerable packages.

When using OpenWrt snapshots nothing should crash or randomly stop working. However, any devices that don't support 802.11ax won't exceed 100 Mbps when using 2.4GHz.

2 Likes

I don't know.
The download page says that snapshots don't contain Luci, and I know they did not last time I tried. Maybe that has changed?

that's what i thought too, but checking the firmware packages just then it contains luci, maybe some recent backend changes? (didn't contain it back in december 2023)

hi everyone
I have a question want to ask
I just want to upgrade the more update version to my openwrt in mt6000 , I have donwloaded the backup but when i install the new firmwire, I cannot restore the backup file (zip file)

The main goal of that was just to simply test the closed source drivers for improvements on wifi and nothing more. The closed source drivers also indeed fixed the wifi problems that both latest "stable" release of gl and openwrt snapshot have. But yeah, I hope they update the Openwrt version if the testing phase ends.

I think they added luci to the snapshots to make it more user friendly and to stop the constant questions from newbies about why they couldn’t access the web interface after installing a snapshot.

There is difference between various "snapshots":

  • snapshots from the development main/master branch, where LuCI is not included, "SNAPSHOT"
  • snapshots from release branches (like 23.05) do contain LuCI "23.05-SNAPSHOT".

Release branch snapshots are a new addition. Generally, most often, traditionally, the "snapshot" still refers to the development snapshots, but newly available release branch snapshots make things more confusing.

3 Likes

I really like the snapshot release branch as bug fixes are backported to it.
I do not know if that is something we can choose in the firmware selector (I compile my own builds with snapshot 23.05) but if not perhaps it should be?

How is this version downloadable? Via the firmware selector?

https://downloads.openwrt.org/releases/23.05-SNAPSHOT/

Or build by yourself from the git head of 23.05

Would anyone know about the fixes for the following bugs, if they have already been fixed? I'm using today's snapshot:

  • Speed on 2.4 GHz drive less than 100 mbps
  • 2.4GHz network only connects to 20 MHz, even if you configure Wifi to the 40 MHz band

I can't see anything from the GL.iNet developers that confirms that though. Instead I found this post from Jan 16th, this post from Jan 26th, this post from Jan 29th and this post from Feb 4th.

I hope that they don't release it as a stable version, but it looks like they will since they've done similar testing with previous firmware versions before pushing them to the stable branch.

That's still an issue and it's unlikely to change while nobody has submitted a bug report.

Most of the time you shouldn't use 40MHz anyway, but did you enable the option to force 40MHz mode? And if you have then have you tried using other channels?