GL iNet AR750 5GHz radio0 not working (with/without travelmate)

Hi. I have a GL iNet AR750. It works great with radio1 on 2.4GHz. I can't seem to make it work on radio0 5GHz.

  • With travelmate: it does not connect to the 5GHz uplink (home router). The system log is full of: ath10k_pci 0000:00:00.0: SWBA overrun on vdev 0, skipped old beacon
  • Without travelmate: enabling the connection works, but it's slow on the router and my computer can't connect. 64 bytes from 1.1.1.1: seq=14 ttl=55 time=2038.096 ms (router) and From 192.168.1.1 icmp_seq=166 Destination Port Unreachable (computer). The router has a gigabits connection and connecting directly to it gives no issues to multiple devices. I want to connect to it through my gl inet and to other 5GHz connections.

It's an OpenWrt 19.07.4.

Wireless configuration

config wifi-device 'radio0'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option htmode 'VHT80'
	option legacy_rates '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/qca953x_wmac'
	option htmode 'HT20'

config wifi-iface 'radio0_ROUTER'
	option network 'trm_wwan'
	option device 'radio0'
	option mode 'sta'
	option encryption 'psk2'
	option disabled '1'
	option ssid 'ROUTER'
	option key 'mykey'

config wifi-iface 'default_radio0'
	option encryption 'psk2'
	option device 'radio0'
	option mode 'ap'
	option network 'lan'
	option key 'mykey'
	option ssid 'glinet'

Network configuration

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd89:4b25:79c4::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 0t'

config interface 'wwan'
	option proto 'dhcp'

config interface 'trm_wwan'
	option proto 'dhcp'

Firewall configuration

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan wan6 wwan trm_wwan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config zone 'vpn'
	option name 'vpn'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list device 'tun0'
	option network 'vpn'

config forwarding 'lan_vpn'
	option src 'lan'
	option dest 'vpn'

Travelmate configuration

config travelmate 'global'
	option trm_captive '1'
	option trm_netcheck '0'
	option trm_autoadd '0'
	option trm_iface 'trm_wwan'
	option trm_triggerdelay '2'
	option trm_debug '0'
	option trm_maxretry '5'
	option trm_listexpiry '0'
	option trm_minquality '35'
	option trm_maxwait '30'
	option trm_timeout '60'
	option trm_rtfile '/tmp/trm_runtime.json'
	option trm_proactive '1'
	option trm_enabled '1'

I doubt it has to do with travelmate now. I tried flashing openwrt-19.07.4-ar71xx-generic-gl-ar750-squashfs-sysupgrade without keeping my settings, all combinations of ath10k-firmware-qca9887 + kmod-ath10k-ct, ath10k-firmware-qca9887-ct + kmod-ath10k-ct (default), ath10k-firmware-qca9887 + kmod-ath100k, ath10k-firmware-qca9887 + kmod-ath100k-ct, 40/80 as above, N/AC, setting the country to mine / US / default, removing kmod-ath9-ct. None of these work. I might have some wrong settings somewhere even with a new firmware. I don't know what to try. I will post it in my main thread.

Where can I get more logs to debug this?

What can I post to get help here? Where can I look?

Is your upstream device set to channel 36?

Yes. Connecting to the upstream is not a problem.

433.3 Mbit/s, 80 MHz, VHT-MCS 9, VHT-NSS 1, Short GI
433.3 Mbit/s, 80 MHz, VHT-MCS 9, VHT-NSS 1, Short GI

It shows as connected under Associated Stations. The connection does not work however: my computer cannot connect to the Internet and pinging 1.1.1.1 from ssh gives

64 bytes from 1.1.1.1: seq=117 ttl=55 time=25.140 ms
64 bytes from 1.1.1.1: seq=118 ttl=55 time=25.459 ms
64 bytes from 1.1.1.1: seq=128 ttl=55 time=3010.655 ms
64 bytes from 1.1.1.1: seq=129 ttl=55 time=2010.488 ms
64 bytes from 1.1.1.1: seq=130 ttl=55 time=1010.260 ms
64 bytes from 1.1.1.1: seq=131 ttl=55 time=25.463 ms
64 bytes from 1.1.1.1: seq=132 ttl=55 time=25.691 ms
64 bytes from 1.1.1.1: seq=133 ttl=55 time=25.368 ms
64 bytes from 1.1.1.1: seq=134 ttl=55 time=25.575 ms
64 bytes from 1.1.1.1: seq=151 ttl=55 time=1044.834 ms

The upstream is fast and connecting my devices to it directly gives nothing like this.
I'm using vanilla 19.07.4 now

  • You don't have an ALLOW Forwarding rule to permit traffic from LAN to the WAN Firewall Zone.
  • In addition, you only permit forwarding from LAN to a Zone called vpn - but the related network interface is nonexistent. You may want to fix that too.
1 Like

Thank you @lleachii for your reply. The reason for not allowing forwarding from LAN to WAN is here and for the vpn zone here for the kill switch.
I flashed again the firmware without keeping any setting and it worked. Installing travelmate was the problem with the previous configuration.

I honestly have no clue if you're telling me something; or explaining why [you now understand how] it was broken.

Glad you got it working [without Travelmate].

You don't explain why you're installing Travelmate, so I'm not sure what I'm supposed to consider here.

For reference the configs network and firewall. Internet works when the radio0 is connected, this is not a problem of firewall or interfaces

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdce:cd6c:042a::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option hostname 'GL-AR750-acb'
	option ipaddr '192.168.8.1'

config interface 'wan'
	option ifname 'eth0'
	option proto 'dhcp'
	option hostname 'GL-AR750-acb'

config interface 'wan6'
	option ifname 'eth0'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 0t'

config interface 'guest'
	option ifname 'guest'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.9.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wwan'
	option proto 'dhcp'
	option metric '20'

config interface 'trm_wwan'
	option proto 'dhcp'

root@OpenWrt:~# cat /etc/config/firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'
	option network 'lan'

config zone
	option name 'wan'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option network 'wan wan6 wwan trm_wwan'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option src_ip 'fc00::/6'
	option dest_ip 'fc00::/6'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config forwarding 'lan_wan'
	option src 'lan'
	option dest 'vpn'
	option enabled '0'

config zone 'vpn'
	option name 'vpn'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	list device 'tun+'

config forwarding 'lan_vpn'
	option src 'lan'
	option dest 'vpn'

I'm installing travelmate so that the router connects to wifis without having to restart it.

I have some logs and stacktraces now:

Thu Oct 29 13:06:05 2020 daemon.notice netifd: Interface 'trm_wwan' is enabled
Thu Oct 29 13:06:06 2020 kern.warn kernel: [  609.396703] ath10k_pci 0000:00:00.0: 10.1 wmi init: vdevs: 16  peers: 127  tid: 256
Thu Oct 29 13:06:06 2020 kern.info kernel: [  609.414117] ath10k_pci 0000:00:00.0: wmi print 'P 128 V 8 T 410'
Thu Oct 29 13:06:06 2020 kern.info kernel: [  609.420334] ath10k_pci 0000:00:00.0: wmi print 'msdu-desc: 1424  sw-crypt: 0 ct-sta: 0'
Thu Oct 29 13:06:06 2020 kern.info kernel: [  609.428661] ath10k_pci 0000:00:00.0: wmi print 'alloc rem: 21576 iram: 11700'
Thu Oct 29 13:06:06 2020 kern.warn kernel: [  609.501074] ath10k_pci 0000:00:00.0: pdev param 0 not supported by firmware
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.519535] ------------[ cut here ]------------
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.524438] WARNING: CPU: 0 PID: 6236 at /builder/shared-workdir/build/build_dir/target-mips_24kc_musl/linux-ar71xx_generic/ath10k-ct-regular/ath10k-ct-2019-09-09-5e8cd86f/ath10k-4.19/mac.c:6598 0x8770bd34 [ath10k_core@87700000+0x5d070]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.546086] Modules linked in: ath9k ath9k_common pppoe ppp_async ath9k_hw ath10k_pci ath10k_core ath pppox ppp_generic nf_conntrack_ipv6 mac80211 iptable_nat ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_FLOWOFFLOAD xt_CT slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_conntrack_ipv4 nf_nat_ipv4 nf_nat nf_log_ipv4 nf_flow_table_hw nf_flow_table nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack iptable_raw iptable_mangle iptable_filter ip_tables crc_ccitt compat nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 tun usb_storage ehci_platform sd_mod scsi_mod ehci_hcd gpio_button_hotplug usbcore nls_base
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.619071]  usb_common
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.621607] CPU: 0 PID: 6236 Comm: kworker/0:0 Tainted: G        W       4.14.195 #0
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.629630] Workqueue: events_freezable 0x87680718 [mac80211@87680000+0x6c5c0]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.637100] Stack : 8046f31c 8774e2e0 8770bd34 000019c6 00000000 00000000 00000000 00000000
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.645748]         00000000 00000000 00000000 00000000 00000000 00000001 86b79c98 0e632c30
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.654400]         86b79d30 00000000 00000000 0001ff10 00000038 80434df8 00000008 00000000
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.663036]         000004d4 804d0000 000004d3 00000000 86b79c78 00000000 00000000 8774e2e0
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.671686]         8770bd34 000019c6 87d1ed48 00000000 00000001 8026f4b4 00000000 80540000
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.680332]         ...
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.682856] Call Trace:
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.682870] [<8770bd34>] 0x8770bd34 [ath10k_core@87700000+0x5d070]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.691778] [<80434df8>] 0x80434df8
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.695397] [<8770bd34>] 0x8770bd34 [ath10k_core@87700000+0x5d070]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.701798] [<8026f4b4>] 0x8026f4b4
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.705425] [<8006c22c>] 0x8006c22c
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.709023] [<8006c234>] 0x8006c234
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.712624] [<800869f0>] 0x800869f0
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.716247] [<8770bd34>] 0x8770bd34 [ath10k_core@87700000+0x5d070]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.722655] [<80086ad8>] 0x80086ad8
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.726293] [<8770bd34>] 0x8770bd34 [ath10k_core@87700000+0x5d070]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.732721] [<876b94ec>] 0x876b94ec [mac80211@87680000+0x6c5c0]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.738853] [<800a746c>] 0x800a746c
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.742468] [<876e0000>] 0x876e0000 [mac80211@87680000+0x6c5c0]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.748618] [<876807e4>] 0x876807e4 [mac80211@87680000+0x6c5c0]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.754746] [<8009b3a8>] 0x8009b3a8
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.758355] [<8009bd74>] 0x8009bd74
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.761961] [<8009c240>] 0x8009c240
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.765590] [<8009bf20>] 0x8009bf20
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.769194] [<800a1614>] 0x800a1614
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.772791] [<800a14ec>] 0x800a14ec
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.776414] [<800a14ec>] 0x800a14ec
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.780014] [<80067118>] 0x80067118
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.783621]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.785168] ---[ end trace 121bdcd9fb010d44 ]---
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.789929] ------------[ cut here ]------------
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.794722] WARNING: CPU: 0 PID: 6236 at /builder/shared-workdir/build/build_dir/target-mips_24kc_musl/linux-ar71xx_generic/ath10k-ct-regular/ath10k-ct-2019-09-09-5e8cd86f/ath10k-4.19/mac.c:6642 0x8770bf80 [ath10k_core@87700000+0x5d070]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.816348] Modules linked in: ath9k ath9k_common pppoe ppp_async ath9k_hw ath10k_pci ath10k_core ath pppox ppp_generic nf_conntrack_ipv6 mac80211 iptable_nat ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_FLOWOFFLOAD xt_CT slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_conntrack_ipv4 nf_nat_ipv4 nf_nat nf_log_ipv4 nf_flow_table_hw nf_flow_table nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack iptable_raw iptable_mangle iptable_filter ip_tables crc_ccitt compat nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 tun usb_storage ehci_platform sd_mod scsi_mod ehci_hcd gpio_button_hotplug usbcore nls_base
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.889325]  usb_common
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.891856] CPU: 0 PID: 6236 Comm: kworker/0:0 Tainted: G        W       4.14.195 #0
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.899870] Workqueue: events_freezable 0x87680718 [mac80211@87680000+0x6c5c0]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.907332] Stack : 8046f31c 8774e2e0 8770bf80 000019f2 00000000 00000000 00000000 00000000
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.915982]         00000000 00000000 00000000 00000000 00000000 00000001 86b79c98 0e632c30
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.924627]         86b79d30 00000000 00000000 00000b20 00000038 80434df8 00000008 00000000
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.933260]         000004f9 804d0000 000004f8 00000000 86b79c78 00000000 00000000 8774e2e0
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.941911]         8770bf80 000019f2 87d1ed48 00000000 00000001 8026f4b4 00000000 80540000
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.950557]         ...
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.953080] Call Trace:
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.953092] [<8770bf80>] 0x8770bf80 [ath10k_core@87700000+0x5d070]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.962003] [<80434df8>] 0x80434df8
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.965621] [<8770bf80>] 0x8770bf80 [ath10k_core@87700000+0x5d070]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.972011] [<8026f4b4>] 0x8026f4b4
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.975631] [<8006c22c>] 0x8006c22c
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.979230] [<8006c234>] 0x8006c234
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.982831] [<800869f0>] 0x800869f0
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.986453] [<8770bf80>] 0x8770bf80 [ath10k_core@87700000+0x5d070]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.992867] [<80086ad8>] 0x80086ad8
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  609.996510] [<8770bf80>] 0x8770bf80 [ath10k_core@87700000+0x5d070]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  610.002946] [<876b94ec>] 0x876b94ec [mac80211@87680000+0x6c5c0]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  610.009081] [<800a746c>] 0x800a746c
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  610.012702] [<876e0000>] 0x876e0000 [mac80211@87680000+0x6c5c0]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  610.018857] [<876807e4>] 0x876807e4 [mac80211@87680000+0x6c5c0]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  610.024980] [<8009b3a8>] 0x8009b3a8
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  610.028587] [<8009bd74>] 0x8009bd74
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  610.032185] [<8009c240>] 0x8009c240
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  610.035811] [<8009bf20>] 0x8009bf20
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  610.039419] [<800a1614>] 0x800a1614
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  610.043016] [<800a14ec>] 0x800a14ec
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  610.046639] [<800a14ec>] 0x800a14ec
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  610.050237] [<80067118>] 0x80067118
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  610.053860]
Thu Oct 29 13:06:07 2020 kern.warn kernel: [  610.055396] ---[ end trace 121bdcd9fb010d45 ]---
Thu Oct 29 13:06:07 2020 kern.info kernel: [  610.457166] ath10k_pci 0000:00:00.0: device successfully recovered
Thu Oct 29 13:06:07 2020 daemon.notice netifd: Network device 'wlan0-1' link is down
Thu Oct 29 13:06:07 2020 kern.info kernel: [  610.481671] br-lan: port 2(wlan0-1) entered disabled state
Thu Oct 29 13:06:10 2020 daemon.notice wpa_supplicant[4779]: wlan0: SME: Trying to authenticate with f0:b0:c1:44:15:01 (SSID='router' freq=5180 MHz)
Thu Oct 29 13:06:10 2020 kern.info kernel: [  613.335155] wlan0: authenticate with f0:b0:c1:44:15:01
Thu Oct 29 13:06:10 2020 kern.info kernel: [  613.345499] wlan0: send auth to f0:b0:c1:44:15:01 (try 1/3)
Thu Oct 29 13:06:10 2020 kern.info kernel: [  613.352108] wlan0: authenticated
Thu Oct 29 13:06:10 2020 daemon.notice wpa_supplicant[4779]: wlan0: Trying to associate with f0:b0:c1:44:15:01 (SSID='router' freq=5180 MHz)
Thu Oct 29 13:06:10 2020 kern.info kernel: [  613.363895] wlan0: associate with f0:b0:c1:44:15:01 (try 1/3)
Thu Oct 29 13:06:10 2020 kern.info kernel: [  613.371516] wlan0: RX AssocResp from f0:b0:c1:44:15:01 (capab=0x1531 status=0 aid=8)
Thu Oct 29 13:06:10 2020 kern.info kernel: [  613.381099] wlan0: associated
Thu Oct 29 13:06:10 2020 daemon.notice netifd: Network device 'wlan0' link is up
Thu Oct 29 13:06:10 2020 daemon.notice netifd: Interface 'trm_wwan' has link connectivity
Thu Oct 29 13:06:10 2020 daemon.notice netifd: Interface 'trm_wwan' is setting up now
Thu Oct 29 13:06:10 2020 daemon.notice wpa_supplicant[4779]: wlan0: Associated with f0:b0:c1:44:15:01
Thu Oct 29 13:06:10 2020 daemon.notice wpa_supplicant[4779]: wlan0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Thu Oct 29 13:06:10 2020 daemon.notice wpa_supplicant[4779]: wlan0: WPA: Key negotiation completed with f0:b0:c1:44:15:01 [PTK=CCMP GTK=CCMP]
Thu Oct 29 13:06:10 2020 daemon.notice wpa_supplicant[4779]: wlan0: CTRL-EVENT-CONNECTED - Connection to f0:b0:c1:44:15:01 completed [id=0 id_str=]
Thu Oct 29 13:06:10 2020 daemon.notice hostapd: wlan0-1: AP-STA-DISCONNECTED 0f:18:f8:90:54:40
Thu Oct 29 13:06:10 2020 daemon.notice hostapd: wlan0-1: AP-STA-DISCONNECTED bb:10:72:ba:ab:7d
Thu Oct 29 13:06:10 2020 kern.info kernel: [  613.405877] br-lan: port 2(wlan0-1) entered blocking state
Thu Oct 29 13:06:10 2020 kern.info kernel: [  613.411562] br-lan: port 2(wlan0-1) entered forwarding state
Thu Oct 29 13:06:10 2020 daemon.notice netifd: Network device 'wlan0-1' link is up
Thu Oct 29 13:06:10 2020 daemon.notice netifd: trm_wwan (6802): udhcpc: started, v1.30.1
Thu Oct 29 13:06:10 2020 daemon.notice netifd: trm_wwan (6802): udhcpc: sending discover
Thu Oct 29 13:06:12 2020 user.info travelmate-1.5.5[1256]: uplink 'radio0_router' is out of range (0/35)
Thu Oct 29 13:06:13 2020 daemon.notice netifd: trm_wwan (6802): udhcpc: sending discover
Thu Oct 29 13:06:13 2020 daemon.notice netifd: trm_wwan (6802): udhcpc: sending select for 192.168.1.3
Thu Oct 29 13:06:13 2020 daemon.notice netifd: trm_wwan (6802): udhcpc: lease of 192.168.1.3 obtained, lease time 86400
Thu Oct 29 13:06:14 2020 daemon.notice netifd: Interface 'trm_wwan' is now up
Thu Oct 29 13:06:14 2020 user.notice firewall: Reloading firewall due to ifup of trm_wwan (wlan0)
Thu Oct 29 13:06:16 2020 daemon.info hostapd: wlan0-1: STA 0f:18:f8:90:54:40 IEEE 802.11: authenticated
Thu Oct 29 13:06:16 2020 daemon.info hostapd: wlan0-1: STA 0f:18:f8:90:54:40 IEEE 802.11: associated (aid 1)
Thu Oct 29 13:06:16 2020 daemon.notice hostapd: wlan0-1: AP-STA-CONNECTED 0f:18:f8:90:54:40
Thu Oct 29 13:06:16 2020 daemon.info hostapd: wlan0-1: STA 0f:18:f8:90:54:40 WPA: pairwise key handshake completed (RSN)
Thu Oct 29 13:06:16 2020 daemon.info dnsmasq-dhcp[6171]: DHCPREQUEST(br-lan) 192.168.8.230 0f:18:f8:90:54:40
Thu Oct 29 13:06:16 2020 daemon.info dnsmasq-dhcp[6171]: DHCPACK(br-lan) 192.168.8.230 0f:18:f8:90:54:40 f01898091c7b
Thu Oct 29 13:06:17 2020 kern.warn kernel: [  620.971026] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:18 2020 kern.warn kernel: [  621.073448] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:18 2020 kern.warn kernel: [  621.175829] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:18 2020 kern.warn kernel: [  621.278251] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:18 2020 kern.warn kernel: [  621.380658] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:18 2020 kern.warn kernel: [  621.483046] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:18 2020 kern.warn kernel: [  621.585465] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:18 2020 kern.warn kernel: [  621.689374] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:18 2020 kern.warn kernel: [  621.790243] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:18 2020 daemon.info dnsmasq-dhcp[6171]: DHCPREQUEST(br-lan) 192.168.8.230 0f:18:f8:90:54:40
Thu Oct 29 13:06:18 2020 daemon.info dnsmasq-dhcp[6171]: DHCPACK(br-lan) 192.168.8.230 0f:18:f8:90:54:40 f01898091c7b
Thu Oct 29 13:06:18 2020 kern.warn kernel: [  621.892649] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:19 2020 kern.warn kernel: [  621.995047] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:19 2020 kern.warn kernel: [  622.097469] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:19 2020 kern.warn kernel: [  622.201403] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:19 2020 kern.warn kernel: [  622.302276] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:19 2020 kern.warn kernel: [  622.404657] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:19 2020 kern.warn kernel: [  622.507070] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:19 2020 kern.warn kernel: [  622.609453] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:19 2020 kern.warn kernel: [  622.713373] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:19 2020 kern.warn kernel: [  622.814262] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:19 2020 kern.warn kernel: [  622.916660] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:20 2020 kern.warn kernel: [  623.019066] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:20 2020 kern.warn kernel: [  623.121465] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Thu Oct 29 13:06:20 2020 kern.warn kernel: [  623.225387] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon

My setup is simple.

  1. Openwrt 19.07.4 flashed without keeping settings
  2. Install openvpn and travelmate
  3. Configure travelmate to have 1 radio0 uplink and only look at radio0 (do not use radio1)

I can get the list of packages if it's useful, but this installation is default

What happens is:

  1. My gl inet connects to the router in radio0 for a few seconds
  2. The connection drops, it restarts

I am happy to help by building with code changes and flashing it again. If it is a bug I can help fix it and push some code to do it so I can start developing on openwrt. Please help me.

???

I guess i'm lost at why a stationary device is needs to randomly connect to multiple APs...hopefully someone else can assist.

Maybe I should note if I have not already - that the client connection must be established before the AP will come online. Further, you cannot forward traffic to an interface (i.e. vpn) that does not exist.

???

:open_mouth:

OK...well...I hope you get it working! :smiley:

I've never seen anyone have success forwarding traffic from LAN, to a VPN that doesn't exist. Maybe I'm misreading your configs.

:face_with_raised_eyebrow:

Sorry @lleachii I'm not good at this so this is what I understand.

I use travelmate so that when I travel or turn off/on different routers it connects to the closest/highest (in priority) one. If I don't use travelmate every time I move to another room I have to reboot my gl inet. If it's not the case, apologies.

For forwarding to vpn: I ran the commands in https://openwrt.org/docs/guide-user/services/vpn/openvpn/extras#kill_switch after installing openvpn and openvpn luci. Is this a mistake?

I apologize if you see my replies as stupid. I don't know much about this. I will learn and be more helpful when posting. Please advise how I can give you more details to help me. Thank you.

  • Do you actually have a VPN?
  • If so, where are those (network) configs?

:bulb: I hope you're understanding that there's no VPN network config; but yet you keep mentioning a VPN. Your LAN traffic will fail since you only allow FORWARD of traffic to a nonexistent interface. I would advise fixing this first - then proceed to verify Travelmate is working.

Hummm...interesting use case. I don't really understand the point; but I get why Travelmate would work for it.

Ok. My vpn configs are in /etc/openvpn

This is the ovpn file

client
dev tun
script-security 2
auth-user-pass /etc/openvpn/vpn.auth
down /etc/openvpn/client.sh
up /etc/openvpn/client.sh
script-security 2
down /etc/openvpn/client.sh
up /etc/openvpn/client.sh
proto udp
remote 11.11.11.11 1194
resolv-retry infinite
remote-random
nobind
tun-mtu 1500
tun-mtu-extra 32
mssfix 1450
persist-key
persist-tun
ping 15
ping-restart 0
ping-timer-rem
reneg-sec 0
comp-lzo no

remote-cert-tls server

verb 3
pull
fast-io
cipher AES-256-CBC
auth SHA512
<ca>
-----BEGIN CERTIFICATE-----
...

The openvpn config

root@OpenWrt:/etc/openvpn# cat /etc/config/openvpn
config openvpn 'myvpn'
	option config '/etc/openvpn/vpn.ovpn'
	option enabled '1'

Here the scripts for up/down

root@OpenWrt:/etc/openvpn# cat client.sh 
#!/bin/sh
env | sed -n -e "
/^foreign_option_.*=dhcp-option.*DNS/s//nameserver/p
/^foreign_option_.*=dhcp-option.*DOMAIN/s//domain/p
" | sort -u > /tmp/resolv.conf.vpn
case ${script_type} in
(up) uci set dhcp.@dnsmasq[0].resolvfile="/tmp/resolv.conf.vpn" ;;
(down) uci revert dhcp ;;
esac
/etc/init.d/dnsmasq restart &
root@OpenWrt:/etc/openvpn# cat killswitch.sh 
#!/bin/sh
if pgrep openvpn
then
uci set firewall.lan_wan.enabled="1"
/etc/init.d/openvpn stop &
else
uci revert firewall
/etc/init.d/openvpn start &
fi
/etc/init.d/firewall restart &
root@OpenWrt:/etc/openvpn# cat reconnect.sh 
#!/bin/sh
n=10
while sleep 60; do
t=$(ping -w 20 -c $n 1.1.1.1 | grep -o -E '[0-9]+ packets r' | grep -o -E '[0-9]+')
if [ "$t" -eq 0 ]; then
/etc/init.d/openvpn restart
fi
done

In Network -> Interfaces there is no vpn interface. I will try reset the router again and install travelmate without openvpn. The way I understood this was gl inet can connect to the uplink itself, but my computer connecting to gl inet cannot connect to the internet unless that vpn connection is established. What is travelmate used for if not this?

I disabled openvpn and added the forwarding rule lan->wan.
I still see these logs

Fri Oct 30 09:01:06 2020 kern.err kernel: [  178.533429] ath10k_pci 0000:00:00.0: Invalid state: 3 in ath10k_htt_tx_32, warning will not be repeated.
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533434] ------------[ cut here ]------------
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533455] WARNING: CPU: 0 PID: 126 at /builder/shared-workdir/build/build_dir/target-mips_24kc_musl/linux-ar71xx_generic/ath10k-ct-regular/ath10k-ct-2019-09-09-5e8cd86f/ath10k-4.19/htt_tx.c:1220 0x87724ca8 [ath10k_core@87700000+0x5d070]
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533458] Modules linked in: ath9k ath9k_common pppoe ppp_async ath9k_hw ath10k_pci ath10k_core ath pppox ppp_generic nf_conntrack_ipv6 mac80211 iptable_nat ipt_REJECT ipt_MASQUERADE cfg80211 xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_FLOWOFFLOAD xt_CT slhc nf_reject_ipv4 nf_nat_redirect nf_nat_masquerade_ipv4 nf_conntrack_ipv4 nf_nat_ipv4 nf_nat nf_log_ipv4 nf_flow_table_hw nf_flow_table nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack iptable_raw iptable_mangle iptable_filter ip_tables crc_ccitt compat nf_log_ipv6 nf_log_common ip6table_mangle ip6table_filter ip6_tables ip6t_REJECT x_tables nf_reject_ipv6 tun usb_storage ehci_platform sd_mod scsi_mod ehci_hcd gpio_button_hotplug usbcore nls_base
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533615]  usb_common
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533628] CPU: 0 PID: 126 Comm: kworker/0:1 Not tainted 4.14.195 #0
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533645] Workqueue: events_freezable 0x87680718 [mac80211@87680000+0x6c5c0]
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533650] Stack : 8046f31c 877570fc 87724ca8 000004c4 00000000 00000000 00000000 00000000
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533670]         00000000 00000000 00000000 00000000 00000000 87d02415 87c07c60 d46725f2
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533689]         87c07cf8 00000000 00000000 00000000 00000038 80434df8 00000001 30323131
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533708]         40383736 804d0000 0000016c 38303030 87c07c40 00000000 00000000 877570fc
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533727]         87724ca8 000004c4 87d50868 87346c10 00000002 00000000 00000000 80540000
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533746]         ...
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533751] Call Trace:
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533764] [<87724ca8>] 0x87724ca8 [ath10k_core@87700000+0x5d070]
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533803] [<80434df8>] 0x80434df8
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533819] [<87724ca8>] 0x87724ca8 [ath10k_core@87700000+0x5d070]
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533840] [<8006c22c>] 0x8006c22c
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533845] [<8006c234>] 0x8006c234
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533851] [<800869f0>] 0x800869f0
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533861] [<87724ca8>] 0x87724ca8 [ath10k_core@87700000+0x5d070]
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533882] [<80086ad8>] 0x80086ad8
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533904] [<87724ca8>] 0x87724ca8 [ath10k_core@87700000+0x5d070]
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533917] [<8009a9a0>] 0x8009a9a0
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533927] [<800c33cc>] 0x800c33cc
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533964] [<876afb80>] 0x876afb80 [mac80211@87680000+0x6c5c0]
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533973] [<87701c14>] 0x87701c14 [ath10k_core@87700000+0x5d070]
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.533989] [<8009adb4>] 0x8009adb4
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534028] [<87701b24>] 0x87701b24 [ath10k_core@87700000+0x5d070]
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534079] [<8770cfa8>] 0x8770cfa8 [ath10k_core@87700000+0x5d070]
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534137] [<8770d330>] 0x8770d330 [ath10k_core@87700000+0x5d070]
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534176] [<876b7850>] 0x876b7850 [mac80211@87680000+0x6c5c0]
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534200] [<876b7670>] 0x876b7670 [mac80211@87680000+0x6c5c0]
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534210] [<876b7798>] 0x876b7798 [mac80211@87680000+0x6c5c0]
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534225] [<876e0000>] 0x876e0000 [mac80211@87680000+0x6c5c0]
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534239] [<876e0000>] 0x876e0000 [mac80211@87680000+0x6c5c0]
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534245] [<80089adc>] 0x80089adc
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534255] [<8043a910>] 0x8043a910
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534260] [<800baae4>] 0x800baae4
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534265] [<8006145c>] 0x8006145c
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534273] [<80231200>] 0x80231200
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534284] [<80067498>] 0x80067498
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534291]
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534295] ---[ end trace 286b93bdb86a75f7 ]---
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534306] ath10k_pci 0000:00:00.0: failed to transmit packet, dropping: -19
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534323] ath10k_pci 0000:00:00.0: failed to submit frame: -19
Fri Oct 30 09:01:06 2020 kern.warn kernel: [  178.534331] ath10k_pci 0000:00:00.0: failed to push frame: -19
Fri Oct 30 09:01:16 2020 daemon.info hostapd: wlan0-1: STA ... IEEE 802.11: authenticated
Fri Oct 30 09:01:16 2020 daemon.info hostapd: wlan0-1: STA ... IEEE 802.11: associated (aid 1)
Fri Oct 30 09:01:16 2020 daemon.notice hostapd: wlan0-1: AP-STA-CONNECTED ...
Fri Oct 30 09:01:16 2020 daemon.info hostapd: wlan0-1: STA ... WPA: pairwise key handshake completed (RSN)
Fri Oct 30 09:01:19 2020 daemon.info dnsmasq-dhcp[1978]: DHCPDISCOVER(br-lan) ...
Fri Oct 30 09:01:19 2020 daemon.info dnsmasq-dhcp[1978]: DHCPOFFER(br-lan) 192.168.8.137 ...
Fri Oct 30 09:01:19 2020 daemon.info dnsmasq-dhcp[1978]: DHCPDISCOVER(br-lan) ...
Fri Oct 30 09:01:19 2020 daemon.info dnsmasq-dhcp[1978]: DHCPOFFER(br-lan) 192.168.8.137 ...
Fri Oct 30 09:01:19 2020 daemon.info dnsmasq-dhcp[1978]: DHCPDISCOVER(br-lan) ...
Fri Oct 30 09:01:19 2020 daemon.info dnsmasq-dhcp[1978]: DHCPOFFER(br-lan) 192.168.8.137 ...
Fri Oct 30 09:01:19 2020 daemon.info dnsmasq-dhcp[1978]: DHCPREQUEST(br-lan) 192.168.8.137 ...
Fri Oct 30 09:01:19 2020 daemon.info dnsmasq-dhcp[1978]: DHCPACK(br-lan) 192.168.8.137 ...
Fri Oct 30 09:01:20 2020 daemon.notice wpa_supplicant[2556]: CTRL_IFACE: Detach monitor that cannot receive messages: /var/run/iwinfo-wlan0-3368\x00
Fri Oct 30 09:01:27 2020 daemon.notice netifd: Network device 'eth1' link is down
Fri Oct 30 09:01:27 2020 kern.info kernel: [  200.071200] eth1: link down
Fri Oct 30 09:01:27 2020 kern.info kernel: [  200.076146] br-lan: port 1(eth1.1) entered disabled state
Fri Oct 30 09:01:27 2020 daemon.notice netifd: VLAN 'eth1.1' link is down
Fri Oct 30 09:01:47 2020 kern.warn kernel: [  220.102522] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon
Fri Oct 30 09:01:47 2020 kern.warn kernel: [  220.204923] ath10k_pci 0000:00:00.0: SWBA overrun on vdev 1, skipped old beacon

I will flash the firmware again now.

Re flashed. I did not keep any setting.

No travelmate and no openvpn.

Wireless: connected to radio0 uplink and enabled "OpenWrt" open wifi connection.

The router pings slowly

64 bytes from 1.1.1.1: seq=3 ttl=53 time=28.377 ms
64 bytes from 1.1.1.1: seq=4 ttl=53 time=28.043 ms
64 bytes from 1.1.1.1: seq=35 ttl=53 time=2046.180 ms
64 bytes from 1.1.1.1: seq=36 ttl=53 time=1046.031 ms
64 bytes from 1.1.1.1: seq=37 ttl=53 time=45.803 ms

The router cannot download packages

Failed to send request: Operation not permitted
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/releases/19.07.4/targets/ar71xx/generic/packages/Packages.gz, wget returned 4.
 * opkg_download: Check your network settings and connectivity.

My computer cannot connect to the internet with this connection. This is all stock now. Can it be radio0 not working? Firmware or driver issue?

Correct, that's the problem.

Doesn't matter if you changed the routes, though.

Wait...your router's crashing!?!?

It's quite difficult when you followed one step, then erased everything.

Wait...your router's crashing!?!?

Yes. This is why I was talking about building it myself to help debug it. I don't know why it is happening. That is the stacktrace I see in the system log.

It's quite difficult when you followed one step, then erased everything.

You are right. I wanted to see if openwrt "as is" (no openvpn no travelmate) would help. It didn't and the connection problems still exist.

I can go back to the state with openvpn and travelmate, the problems occur all the time. Please advise how to proceed, I don't know how to debug this myself and I want to keep using openwrt.

I tried the following steps with both 19.07.3 and 19.07.4

  1. Connect ethernet cable
  2. Flash openwrt, do not keep any setting
  3. radio0 scan, find uplink router, input password and lock to ssid
  4. radio0 enable password-less openwrt wifi station
  5. Disconnect ethernet cable
  6. Connect my computer to openwrt station
  7. Verify under "Associated Stations" both router (client) and openwrt (master) are up, both on channel 36, my router on channel 36 too

Behavior of my gl inet:

  1. ping 1.1.1.1 takes ages (as above)
  2. my computer cannot connect to the Internet

I did not use any travelmate or openvpn, stock openwrt

What could it be? how do I find the fix here?

Does the subnet of the OpenWrt LAN and the upstream WiFi LAN match?

If so, one of the networks have to be renumbered.