GL iNet 4G Smart Router applications port forward

Hello all,
I need to have UDP and TCP ports forwarded to a computer that runs a communication software.
Ports needed are, UDP 5198, 5199 and TCP 5200.
I set up static IP on the computer and do the port forward on the modem, it looks ok but the ports don't open. I'm new to this router. Getting internet through T-Mobile with a SIM card.
Thanks in advance


Very dated, but should be similar with current LuCI (GUI):

1 Like

Are you sure, that t-mobile gives you a public IP?

To ask differently,

"Can the IP address assigned to you by T-Mobile be reached from the Internet outside of T-Mobile's network?"

as, in my experience in the US, an IPv4 address is assigned to my LTE modem that is in the routable space, but it ends up being NAT-ed by T-Mobile before being sent onward. This means that you can't open a "listener" on the assigned IP address and expect to connect to it from the rest of the Internet.

(This may be different in other countries served by T-Mobile)

I think T-Mobile in Germany does the same. Maybe it is their standard.

1 Like

I don't know.... and how to i check that?
All I know is that I had the Alcatel hotspot from T-mobile, feeding a Netgear router. I couldn't do any forwarding on the hotspot itself and I tried to do it through the Netgear router and it did work! I had my digital radio repeater accusing the internet (you need to have specific ports open) with no problem.
The reason I switched to GL iNet 4G is, that for some reason the Alcatel hotspot stopped working and I had to restart it every couple of days.
So, I don't know what to tell you. From what I just said, do you think that IP T-mobile gives is accessible?

Connect to the public Internet in a way other than via your LTE modem (via a VPN should work if you only have that single Internet access) and try to ping the IP address of the LTE modem. If that succeeds (and isn't just loopback by mistake), then you know it's accessible. If it fails, then it's possible they're blocking inbound pings (but allowing connections), so you'd need to try a UDP or TCP connection.

I called T-Mobile and the technician assured me that they do not block any ports.
So it's something that has to do with the GL iNet router.
Port forwarding on the router itself looks very simple and I have tried it up to 20 times up to now. I try other settings too, each time I reset the router before try something new, nothing changes.
I tried to ping router IP and it fails, I'm out of ideas...

That is likely in reference to outbound connections, not inbound ones.

I would run a traceroute from the outside and see what you find (likely that it "disappears" at the edge of the T-Mobile world), and/or run tcpdump on your LTE interface and see if you find any packets getting through on inbound connections.